Manual del usuario del Inspector de compatibilidad de códigos de Microsoft Office

 

Se aplica a: Office 2010

Última modificación del tema: 2016-11-29

El Inspector de compatibilidad de códigos de Microsoft Office ayuda a resolver problemas de compatibilidad en los complementos y macros de Microsoft Visual Basic para aplicaciones (VBA).

Use el Inspector de compatibilidad de códigos de Microsoft Office para inspeccionar el código de VBA que creó en versiones anteriores de Microsoft Office y para ayudar a realizar cualquier llamada de la interfaz de programación de aplicaciones de Windows (API) en el código compatible con la edición de 64 bits de Microsoft Office 2010.

En este artículo:

  • Acerca del inspector.

  • Instalación

  • Inspección del código de VBA

  • Inspección del código de VSTO

  • Uso del inspector

  • Otros recursos

Acerca del inspector.

El Inspector de compatibilidad de códigos de Microsoft Office está diseñado para ayudar a una empresa o pequeño negocio a actualizar el código de Visual Basic para Aplicaciones (VBA) y Visual Studio Tools para Office y que sea compatible con Office 2010. El inspector no corrige el código; lo inspecciona y, a continuación, agrega comentarios en líneas específicas de código que hacen referencia a elementos en el modelo de objetos que han cambiado o se han dejado de usar. (En el código de VBA, la herramienta también agrega comentarios a las instrucciones Declare para la compatibilidad de 64 bits). A continuación, se puede modificar el código en función de los comentarios o usar los vínculos proporcionados en los comentarios para ver temas en Internet que sean pertinentes a una línea particular del código.

Como ya se señaló, corresponde al usuario modificar el código si determina que debe modificarse.

Entre las principales características del inspector de compatibilidad de códigos de Office, se incluyen las siguientes:

  • Consta de cuatro complementos que se cargan, un complemento por aplicación, en Excel 2010, PowerPoint 2010, Word 2010 y Visual Studio 2008.

  • Se ejecuta usuario por usuario o documento por documento. En el caso de VBA, los usuarios abren un documento y ejecutan la herramienta desde la ficha Desarrollador. En el caso de los proyectos de Visual Studio, el desarrollador ejecuta la herramienta desde el menú Herramientas.

  • Examina los proyectos en el documento actual o solución de Visual Studio mediante una búsqueda de texto simple, en busca de combinaciones de parentObject.Property, y examina instrucciones Declare para la compatibilidad de 64 bits (en VBA).

  • Agrega comentarios en el código donde busca otros posibles problemas.

  • Muestra un resumen y un informe detallado de los resultados de búsqueda obtenidos tras finalizar la inspección.

No se puede usar esta herramienta para examinar código de Microsoft Outlook o Microsoft Access. Sin embargo, se puede usar la herramienta para examinar código de Excel, PowerPoint y Word para la interacción con el modelo de objetos de Outlook.

Instalación

Para instalar el Inspector de compatibilidad de códigos de Office, siga estos pasos:

  1. Descargue la versión Update 1 de OCCI desde Herramienta de Office 2010: Inspector de compatibilidad (en inglés) (http://go.microsoft.com/fwlink/?linkid=171093\&clcid=0xC0) (en inglés). Guárdela en el escritorio o en otra ubicación conveniente, busque el archivo y ábralo para iniciar la instalación.

    • Puede instalar únicamente el complemento de Visual Studio.

    • Puede instalar únicamente los complementos de Office.

    • O bien, puede instalar ambos.

  2. Siga las instrucciones y seleccione Finalizar para completar la instalación.

Mostrar la ficha Desarrollador

Para cada aplicación de Office en la que va a usar la herramienta, realice las siguientes tareas:

  1. Abra Excel 2010, PowerPoint 2010 o Word 2010 si aún no están abiertos.

  2. En la pestaña Archivo, seleccione Opciones.

  3. Seleccione Personalizar cinta de opciones.

  4. En la opción Comandos disponibles en situada en el lado izquierdo del cuadro de diálogo, seleccione Comandos más utilizados.

  5. En la opción Personalizar cinta de opciones situada en el lado derecho del cuadro de diálogo, seleccione Fichas principales y active la casilla Desarrollador.

  6. Seleccione Aceptar.

Habilitar el acceso al proyecto de VBA

Para cada aplicación de Office en la que va a usar la herramienta, realice las siguientes tareas:

  1. Abra Excel 2010, PowerPoint 2010 o Word 2010 si aún no están abiertos.

  2. En la pestaña Archivo, seleccione Opciones.

  3. Seleccione Centro de confianza.

  4. Seleccione Configuración del Centro de confianza.

  5. En la ficha Configuración de macros, seleccione Acceso de confianza al modelo de objetos del proyecto de VBA.

Inspección del código de VBA

Para inspeccionar la compatibilidad de un documento, siga estos pasos:

  1. Abra el documento en Excel 2010, PowerPoint 2010 o Word 2010.

  2. En la pestaña Desarrollador, seleccione Comprobar código VBA.

    Figura 1. Opciones del Inspector de compatibilidad de códigos en la ficha Desarrollador

    Opciones de Inspector en la ficha Programador

  3. En el cuadro de diálogo Comprobar proyecto VBA, active o desactive las opciones según corresponda y seleccione Inspeccionar.

    Figura 2. Cuadro de diálogo de inspección del proyecto de VBA

    Cuadro de diálogo Inspect VBA Project (Inspeccionar proyecto VBA)

    1. Seleccione Comprobar proyectos de Visual Basic para aplicaciones para, de este modo, inspeccionar el proyecto de VBA en busca de elementos en el modelo de objetos que hayan cambiado o se hayan quitado.

    2. Seleccione Comprobar instrucciones de declaración si el proyecto se iniciará sólo en Office 2010 o el proyecto podría usarse en un sistema con Office 2010 de 64 bits.

    3. Seleccione Agregar comentarios para colocar comentarios en el código en los lugares en que la herramienta identifica posibles problemas de compatibilidad. Los comentarios que agrega el inspector tienen un aspecto similar al ejemplo siguiente.

      '<VBA_INSPECTOR>
      '      <DEPRECATION>
      '        <MESSAGE>Potentially contains ... </MESSAGE>
      '        <ITEM>AnswerWizard.ResetFileList</ITEM>
      '        <URL>http://go.microsoft.com/fwlink/?linkid=171730&clcid=0xC0A
      
    4. Seleccione Informe detallado para crear un informe al final del proceso de inspección. El informe es un archivo de texto que tiene un aspecto similar al ejemplo siguiente.

      SUMMARY:
      ========
      
      Document scanned:        c:\TestFile.xls
      Date Scanned:            Thursday, November 12, 2009
      Total lines scanned:     101
      Total items found:       1
      Deprecated items:        0
      Changed items:           1
      Redesigned items:        0
      Declare statements:      0
      
      DETAILS:
      ========
      
      MODULE:            Module1
      FUNCTION:          Macro1
      LINE:              19
      TYPE:              CHANGE
      ITEM:              Workbook.VBProject
      URL:               http://go.microsoft.com/fwlink/?linkid=170116&clcid=0xC0A:              For Each comp In
      ActiveWorkbook.VBProject.VBComponents
      
  4. Una vez que el inspector finaliza el examen, muestra un informe resumido similar al siguiente.

    Figura 2a. Resumen del Inspector de compatibilidad de códigos

    Resumen de Code Compatibility Inspector

    • Total lines scanned: número total de líneas de código de VBA examinadas en el documento.

    • Total items found: número total de elementos problemáticos encontrados por el Inspector en el código, incluidas las instrucciones Declare que se van a actualizar, los elementos modificados, los elementos desusados y los elementos afectados por cambios de diseño.

    • Deprecated items: elementos del código que se quitaron del modelo de objetos o que ya no se admiten en él. Si el código depende de un elemento desusado, se debe volver a escribir esa parte del código.

    • Changed items: los elementos del código que usan un comando cuya sintaxis ha cambiado. Si el código usa sintaxis obsoleta, debe actualizarlo.

    • Redesigned items: los elementos del código cuya sintaxis es la misma y sigue existiendo, pero cuyo diseño actualizado podría producir resultados inesperados en el código. Por ejemplo, el formato de un cuadro de texto específico podría haber cambiado debido a nuevos servicios de texto y, como resultado, el código podría crear un cuadro de texto; sin embargo, el diseño del texto en el cuadro podría ser diferente al de las versiones anteriores.

    • Instrucciones Declare: el número total de instrucciones de API de Windows detectadas en el código VBA y actualizadas para que sean compatibles con 64 bits mediante la adición de la palabra clave PTRSAFE.

Inspección del código de Visual Studio

Para inspeccionar la compatibilidad de un documento, siga estos pasos:

  1. Abra la solución que se va a inspeccionar en Visual Studio Tools para Office.

  2. En el menú Herramientas, haga clic en Comprobar código VSTO.

    Figura 3. Menú Herramientas de VSTO

    Menú VSTO Tools (Herramientas de VSTO)

  3. En el cuadro de diálogo Comprobar proyecto VSTO, active o desactive las opciones según corresponda y seleccione Inspeccionar.

    Figura 4. Cuadro de diálogo de inspección del proyecto de VSTO

    Cuadro de diálogo Inspect VSTO Project (Inspeccionar proyecto VSTO)

    1. Seleccione Inspect Visual Studio Tools for Office Source (VB.NET and C#) para inspeccionar el proyecto de Visual Studio Tools para Office en busca de elementos en el modelo de objetos que hayan cambiado o se hayan quitado.

    2. Seleccione Agregar comentarios para colocar comentarios en el código en los lugares en que la herramienta identifica posibles problemas de compatibilidad. Los comentarios que agrega el inspector tienen un aspecto similar al ejemplo siguiente.

      //<VSTO_INSPECTOR>
      //  <DEPRECATION>
      //      <MESSAGE>Potentially contains removed items...</MESSAGE>
      //      <ITEM>[mso]AnswerWizard.ResetFileList</ITEM>
      //      <URL>http://go.microsoft.com/fwlink/?linkid=171730&clcid=0xC0A
      
    3. Seleccione Informe detallado para crear un informe al final del proceso de inspección. El informe es un archivo de texto que tiene un aspecto similar al ejemplo siguiente.

      SUMMARY:
      ========
      
      Solution scanned:        ExcelAddIn1
      Date scanned:            Thursday, November 12, 2009
      Total lines scanned:     43
      Total items found:       3
      Deprecated items:        3
      Changed items:           0
      Redesigned items:        0
      
      DETAILS:
      ========
      
      MODULE:      ThisAddIn.cs
      FUNCTION:    ThisAddIn_Startup
      LINE:        17
      TYPE:        DEPRECATION
      APP:         mso
      ITEM:        AnswerWizard
      URL:         http://go.microsoft.com/fwlink/?linkid=171730&clcid=0xC0A:        xlApp.AnswerWizard.ResetFileList();
      
      MODULE:      ThisAddIn.cs
      FUNCTION:    ThisAddIn_Startup
      LINE:        19
      TYPE:        DEPRECATION
      APP:         xls
      ITEM:        SmartTagRecognizers
      URL:         http://go.microsoft.com/fwlink/?linkid=170614&clcid=0xC0A:        xlApp.SmartTagRecognizers.Recognize = true;
      
      MODULE:      ThisAddIn.cs
      FUNCTION:    ThisAddIn_Startup
      LINE:        22
      TYPE:        DEPRECATION
      APP:         xls
      ITEM:        SmartTags
      URL:         http://go.microsoft.com/fwlink/?linkid=170617&clcid=0xC0A:        MessageBox.Show(r.SmartTags.Count.ToString());
      
    4. Seleccione Copia de seguridad para hacer una copia de seguridad de los archivos del proyecto antes de inspeccionar el código.

  4. Una vez que el inspector finaliza el examen, muestra un informe resumido similar al siguiente.

    Figura 5. Resumen del Inspector de compatibilidad de códigos

    Resumen de Code Compatibility Inspector

    • Total lines scanned: número total de líneas de código de Visual Basic .NET o C# examinadas en el documento.

    • Total items found: número total de elementos problemáticos encontrados por el Inspector en el código, incluidos los elementos modificados, los elementos desusados y los elementos afectados por cambios de diseño.

    • Deprecated items: elementos del código que se quitaron del modelo de objetos o que ya no se admiten en él. Si el código depende de un elemento desusado, se debe volver a escribir esa parte del código.

    • Changed items: los elementos del código que usan un comando cuya sintaxis ha cambiado. Si el código usa sintaxis obsoleta, debe actualizarlo.

    • Redesigned items: los elementos del código cuya sintaxis es la misma y sigue existiendo, pero cuyo diseño actualizado podría producir resultados inesperados en el código. Por ejemplo, el formato de un cuadro de texto específico podría haber cambiado debido a nuevos servicios de texto y, como resultado, el código podría crear un cuadro de texto; sin embargo, el diseño del texto en el cuadro podría ser diferente al de las versiones anteriores.

    • Declare statements: el número total de instrucciones de API de Windows detectadas en el código VBA y actualizadas para que sean compatibles con 64 bits mediante la adición de la palabra clave PTRSAFE.

Uso del inspector

Si el inspector encuentra elementos modificados, desusados o rediseñados en el código, debe depurar el código y resolver los problemas. Se recomienda realizar una prueba completa en el código para inspeccionar cada función. Al depurar el código, compruebe si hay comentarios del Inspector de compatibilidad de códigos de Office encima de las líneas que dividen el código. Estos comentarios ayudarán a determinar el problema subyacente con esa línea de código en concreto. Si el problema no es inmediatamente obvio para usted, pegue la dirección URL que se encuentra en los comentarios en el explorador para obtener más información.

Quitar comentarios en VBA

Para quitar los comentarios del código después de completar el proceso y comprobar el código por razones de compatibilidad con Office 2010, seleccione Quitar comentarios en la pestaña Desarrollador en la aplicación de Office 2010.

El inspector quita todos los comentarios que colocó en el proyecto de VBA y, a continuación, notifica el número de elementos que eliminó.

Figura 6. Mensaje que especifica el número de elementos eliminados

Mensaje que especifica el número de elementos quitados

Quitar comentarios en Visual Studio

Para quitar los comentarios del código después de completar el proceso y comprobar el código por razones de compatibilidad con Office 2010, seleccione Quitar comentarios de comprobación de VSTO en el menú Herramientas en Visual Studio.

El inspector quita todos los comentarios que colocó en el proyecto de Visual Studio Tools para Office y, a continuación, notifica el número de elementos que eliminó.

Figura 6a. Mensaje que especifica el número de elementos eliminados

Mensaje que especifica el número de elementos quitados