Cambiar las filas que se importan desde un origen de datos

Al importar datos, puede aplicar un filtro al origen de datos para limitar el número de filas del libro. Posteriormente, si decide agregar más filas, o limitarlas, no necesita volver a crear los datos con otro filtro, simplemente puede modificar los filtros que se aplican al origen de datos.

El primer procedimiento de este tema describe cómo agregar filtros al importar datos para restringir las filas que se agregan a un libro. El segundo procedimiento describe cómo modificar los filtros que se aplican a los orígenes de datos existentes. Ambos procedimientos se centran en importar datos de una base de datos, pero los pasos son similares para otros orígenes de datos. El procedimiento supone que seleccionará tablas en una lista en el Asistente para la importación de tablas; si decide escribir una consulta para importar datos, puede filtrar los datos especificando en la consulta las filas y columnas que importar. Una vez importados los datos, puede aplicar filtros para controlar qué datos se muestran en la ventana de PowerPivot. Para obtener más información, vea Filtrar los datos de una tabla.

[!NOTA]

En Windows Vista y Windows 7, las características de la ventana de PowerPivot están disponibles en una cinta de opciones, que se explica en este tema. En Windows XP, las características están disponibles de un conjunto de menús. Si usa Windows XP y desea ver cómo se relacionan los comandos de menú con los comandos de la cinta de opciones, vea Interfaz de usuario de PowerPivot en Windows XP.

Agregar un filtro durante la importación

Para definir un filtro durante la importación

  1. En la ventana de PowerPivot, haga clic en la pestaña Inicio y en el grupo Obtener datos externos, haga clic en uno de los siguientes botones para abrir el Asistente para la importación de tablas: Desde base de datos, De informe, De fuentes de datos, De texto o De otros orígenes.

  2. En la página Seleccionar tablas y vistas, seleccione una tabla y, a continuación, haga clic en Vista previa y filtrar.

  3. En el cuadro de diálogo Vista previa de la tabla seleccionada, busque la columna que contiene los criterios por los que desea filtrar y, a continuación, haga clic en la flecha hacia abajo que hay a la derecha del encabezado de columna.

  4. En el menú Autofiltro, siga uno de estos procedimientos:

    • En la lista de valores de columna, active o desactive uno o varios valores para filtrar y haga clic en Aceptar.

      Si el número de valores es sumamente grande, algunos elementos individuales podrían no mostrarse en la lista. En su lugar, verá un mensaje similar a "Demasiados elementos para mostrar".

    • Haga clic en Número y filtros o Filtros de texto (en función del tipo de columna) y, a continuación, haga clic en uno de los comandos de operador de comparación (como Es igual a) o haga clic en Filtro personalizado. En el cuadro de diálogo Filtro personalizado, cree el filtro y, a continuación, haga clic en Aceptar.

    [!NOTA]

    Si comete un error y necesita volver a empezar, haga clic en Borrar filtros de fila.

  5. Haga clic en Aceptar para guardar la condición del filtro y volver a la página Seleccionar tablas y vistas del asistente.

    Ahora, la columna Detalles del filtro contiene un vínculo, Filtros aplicados. Haga clic en el vínculo para revisar la expresión del filtro generada por el asistente. La sintaxis de cada expresión de filtro depende del proveedor y no se puede editar manualmente.

  6. Haga clic en Finalizar para importar los datos con los filtros aplicados.

Cambiar la definición de un filtro en un origen de datos existente

Después de haber importado los datos, puede desear cambiar las filas que se importan. Puede hacerlo editando el filtro existente o agregando otros filtros. Para las fuentes de distribución de datos, puede cambiar solo las columnas que se importan; no puede filtrar filas por valores. Sin embargo, puede filtrar las filas que se importan de una fuente de distribución de datos si su origen es un informe y este tiene parámetros. Para obtener más información, vea Importar datos desde un informe de Reporting Services.

Para modificar un filtro para un origen de datos existente

  1. En la ventana de PowerPivot, haga clic en la pestaña Diseño y, en el grupo Conexiones, haga clic en Conexiones existentes.

  2. Seleccione la conexión que tiene los datos que desea cambiar y haga clic en Abrir.

  3. Modifique los criterios de filtrado siguiendo los pasos descritos en el procedimiento anterior.

Vea también

Conceptos

Maneras diferentes de actualizar datos en PowerPivot

Recalcular fórmulas

Editar las propiedades de un origen de datos existente