Tutorial: Crear un formulario Windows Forms para buscar datos

Un escenario habitual de la aplicación es mostrar los datos seleccionados en un formulario. Por ejemplo, puede que desee mostrar los pedidos de un cliente concreto o los detalles de un pedido específico. En este caso, un usuario escribe información en un formulario y, a continuación, se ejecuta una consulta con la entrada del usuario como parámetro; es decir, los datos se seleccionan basándose en una consulta parametrizada. La consulta devuelve sólo los datos que satisfacen los criterios escritos por el usuario. Este tutorial muestra cómo crear una consulta que devuelve los clientes de una ciudad específica y cómo modificar la interfaz de usuario para que los usuarios puedan escribir el nombre de una ciudad y presionar un botón para ejecutar la consulta.

El uso de consultas parametrizadas ayuda a que la aplicación sea más eficaz, ya que permite a la base de datos realizar el trabajo que mejor sabe hacer: filtrar registros rápidamente. Al contrario, si solicita una tabla de base de datos completa, transferirla por la red y, a continuación, utilizar la lógica de la aplicación para buscar los registros que se desean, la aplicación puede tornarse más lenta y difícil de utilizar.

Puede agregar consultas parametrizadas a cualquier TableAdapter (y controles para aceptar los valores de parámetro y ejecutar la consulta) utilizando el Generador de criterios de búsqueda (cuadro de diálogo). Abra el cuadro de diálogo seleccionando el comando Agregar consulta del menú Datos (o en cualquier etiqueta inteligente del TableAdapter).

Las tareas ilustradas en este tutorial incluyen:

Requisitos previos

Para completar las tareas de este tutorial, necesitará:

Crear la aplicación para Windows

El primer paso es crear una Aplicación para Windows. La asignación de un nombre al proyecto es opcional en este paso, pero se le asignará un nombre para guardarlo más adelante.

Para crear el nuevo proyecto de aplicación para Windows

  1. Desde el menú Archivo, cree un nuevo proyecto.

  2. Asigne al proyecto el nombre WindowsSearchForm.

  3. Seleccione Aplicación para Windows y haga clic en Aceptar. Para obtener más información, vea Crear aplicaciones basadas en Windows.

    El proyecto WindowsSearchForm se crea y se agrega al Explorador de soluciones.

Crear el origen de datos

Este paso crea un origen de datos a partir de una base de datos utilizando el Asistente para la configuración de orígenes de datos. Debe tener acceso a la base de datos de ejemplo Northwind para crear la conexión. Para obtener información sobre la configuración de la base de datos de ejemplo Northwind, vea Cómo: Instalar bases de datos de ejemplo.

Para crear el origen de datos

  1. En el menú Datos, haga clic en Mostrar orígenes de datos.

  2. En la ventana Orígenes de datos, seleccione Agregar nuevo origen de datos para iniciar el Asistente para configuración de orígenes de datos.

  3. Seleccione Base de datos en la página Elegir un tipo de datos de origen y luego haga clic en Siguiente.

  4. En la página Elegir la conexión de datos realice una de las siguientes operaciones:

    • Si una conexión de datos a la base de datos de ejemplo Northwind está disponible en la lista desplegable, selecciónela.

      O bien

    • Seleccione Nueva conexión para iniciar el cuadro de diálogo Agregar o modificar conexión. Para obtener más información, vea Agregar/Modificar conexión (Cuadro de diálogo, General).

  5. Si su base de datos requiere una contraseña, seleccione la opción para incluir datos confidenciales y haga clic en Siguiente.

  6. Haga clic en Siguiente en la página Guardar la cadena de conexión en el archivo de configuración de la aplicación.

  7. Expanda el nodo Tablas en la página Elegir los objetos de base de datos.

  8. Seleccione la tabla Customers y, a continuación, haga clic en Finalizar.

    Se agrega al proyecto NorthwindDataSet y la tabla Customers aparece en la ventana Orígenes de datos.

Crear el formulario

Puede crear los controles enlazados a datos arrastrando elementos desde la ventana Orígenes de datos al formulario.

Para crear controles enlazados en el formulario

  1. Expanda el nodo Customers en la ventana Orígenes de datos.

  2. Arrastre el nodo Customers desde la ventana Orígenes de datos hasta el formulario.

    En el formulario aparecen un control DataGridView y una barra de herramientas (BindingNavigator) para navegar por los registros. NorthwindDataSet, CustomersTableAdapter, BindingSourcey BindingNavigator aparecen en la bandeja de componentes.

Agregar parametrización (funcionalidad de búsqueda) a la consulta

Puede agregar una cláusula WHERE a la consulta original utilizando el Generador de criterios de búsqueda (cuadro de diálogo).

Para crear una consulta parametrizada y controles para escribir los parámetros

  1. Seleccione el control DataGridView y, a continuación, elija Agregar consulta en el menú Datos.

  2. Escriba FillByCity en el área Nuevo nombre de consulta en el Generador de criterios de búsqueda (cuadro de diálogo).

  3. Agregue WHERE City = @City a la consulta en el área Texto de la consulta.

    La consulta debe ser similar a lo siguiente:

    SELECT CustomerID, CompanyName, ContactName, ContactTitle, Address, City, Region, PostalCode, Country, Phone, Fax

    FROM Customers

    WHERE City = @City

    Nota

    Los orígenes de datos de Access y Oledb utilizan el signo de interrogación '?' para denotar los parámetros, por lo que la cláusula WHERE tendría esta apariencia: WHERE City = ?.

  4. Haga clic en Aceptar para cerrar el cuadro de diálogo Generador de criterios de búsqueda.

    FillByCityToolStrip se agrega al formulario.

Probar la aplicación

Al ejecutar la aplicación, se abre el formulario listo para tomar el parámetro como entrada.

Para probar la aplicación

  1. Presione F5 para ejecutar la aplicación.

  2. Escriba Londres en el cuadro de texto Ciudad y haga clic en FillByCity.

    La cuadrícula de datos se rellena con clientes que cumplen con los criterios de la parametrización. En este ejemplo, la cuadrícula de datos muestra sólo los clientes que tienen un valor de Londres en su columna City.

Pasos siguientes

Dependiendo de los requisitos de la aplicación, existen varios pasos que se pueden realizar después de crear un formulario parametrizado. Entre las mejoras que podría realizar en las tareas de este tutorial se incluyen:

Vea también

Referencia

Información general sobre el componente BindingSource

Información general sobre el control BindingNavigator (formularios Windows Forms)

Conceptos

Novedades en el desarrollo de aplicaciones de datos

Enlazar controles de Windows Forms a datos en Visual Studio

Información general sobre orígenes de datos

Información general sobre TableAdapter

Otros recursos

Tutoriales sobre datos