Tutorial: Crear un informe de forma libre (Generador de informes)Tutorial: Creating a Free Form Report (Report Builder)

En este tutorial, creará un informe paginado que actúa como un boletín.In this tutorial, you create a paginated report that acts as a newsletter. Cada página muestra texto estático, objetos visuales de resumen y datos de ventas de ejemplo detallados.Each page displays static text, summary visuals, and detailed sample sales data.

report-builder-free-form-report-complete

El informe agrupa la información por territorio y muestra el nombre del administrador de ventas del territorio, así como una información de ventas detallada y sumaria.The report groups information by territory and displays the name of the sales manager for the territory as well as detailed and summary sales information. Comenzará con una región de datos de la lista como la base para el informe de forma libre y, después, agregará un panel decorativo con una imagen, texto estático con datos insertados, una tabla para mostrar información detallada y, opcionalmente, gráficos circulares y de columnas que muestren la información resumida.You start with a list data region as the foundation for the free form report, then add a decorative panel with an image, static text with data inserted, a table to show detailed information, and optionally, pie and column charts to display summary information.

Tiempo estimado para completar este tutorial: 20 minutos.Estimated time to complete this tutorial: 20 minutes.

RequisitosRequirements

Para obtener más información sobre los requisitos, consulte Requisitos previos para los tutoriales (Generador de informes).For more information about requirements, see Prerequisites for Tutorials (Report Builder).

1. Crear un informe en blanco, un origen de datos y un conjunto de datos1. Create a Blank Report, Data Source, and Dataset

Nota

En este tutorial, la consulta contiene los valores de datos, de forma que no necesita un origen de datos externo.In this tutorial, the query contains the data values so that it does not need an external data source. Esto hace que la consulta requiera bastante tiempo.This makes the query quite long. En un entorno empresarial, la consulta no contendría los datos.In a business environment, a query would not contain the data. Esto es solo con fines de aprendizaje.This is for learning purposes only.

Para crear un informe en blancoTo create a blank report

  1. Inicie el Generador de informes desde el equipo, el portal web de Reporting ServicesReporting Services o el modo integrado de SharePoint.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    Se abre el cuadro de diálogo Nuevo informe o conjunto de datos.The New Report or Dataset dialog box opens.

    Si no ve el cuadro de diálogo Nuevo informe o conjunto de datos, vaya al menú Archivo > Nuevo.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. En el panel de la izquierda, asegúrese de que está seleccionada la opción Nuevo informe .In the left pane, make sure New Report is selected.

  3. En el panel derecho, haga clic en Informe en blanco.In the right pane, click Blank Report.

Para crear un nuevo vista origen de datosTo create a new data source

  1. En el panel Datos de informe, haga clic en Nuevo > Origen de datos.In the Report Data pane, click New > Data Source.

  2. En el cuadro Nombre , escriba: ListDataSource.In the Name box, type: ListDataSource

  3. Haga clic en Usar una conexión incrustada en mi informe.Click Use a connection embedded in my report.

  4. Compruebe que el tipo de conexión es Microsoft SQL Server y luego en el cuadro Cadena de conexión, escriba: Origen de datos = <nombre de servidor>Verify that the connection type is Microsoft SQL Server, and then in the Connection string box type: Data Source = <servername>

    <nombre de servidor>, por ejemplo Report001, especifica un equipo en el que se ha instalado una instancia del motor de base de datos de SQL Server.<servername>, for example Report001, specifies a computer on which an instance of the SQL Server Database Engine is installed. Dado que los datos del informe no se extraen de una base de datos de SQL Server, no necesita incluir el nombre de una base de datos.Because the data for this report is not extracted from a SQL Server database, you need not include the name of a database. Para analizar la consulta se usa la base de datos predeterminada en el servidor especificado.The default database on the specified server is just used to parse the query.

  5. Haga clic en Credencialese introduzca las credenciales necesarias para conectarse a la instancia del Motor de base de datos de SQL Server.Click Credentials, and enter the credentials needed to connect to the instance of the SQL Server Database Engine.

  6. Haga clic en Aceptar.Click OK.

Para crear un nuevo conjunto de datosTo create a new dataset

  1. En el panel Datos de informe, haga clic en Nuevo > Conjunto de datos.In the Report Data pane, click New > Dataset.

  2. En el cuadro Nombre , escriba: ListDataset.In the Name box, type: ListDataset.

  3. Haga clic en Usar un conjunto de datos insertado en el informey compruebe que el origen de datos es ListDataSource.Click Use a dataset embedded in my report, and verify that the data source is ListDataSource.

  4. Compruebe que el tipo de consulta Texto está seleccionado, y, a continuación, haga clic en Diseñador de consultas.Verify that the Text query type is selected, and then click Query Designer.

  5. Haga clic en Editar como texto.Click Edit as Text.

  6. Copie y pegue la siguiente consulta en el panel de consulta:Copy and paste the following query into the query pane:

    SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Carrying Case' as Product, CAST(16996.60 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(13747.25 AS money) AS Sales, 55 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Carrying Case' as Product, CAST(9248.15 AS money) As Sales, 37 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1350.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1800.00 AS money) AS Sales, 24 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1125.00 AS money) AS Sales, 15 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1147.50 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,  'Lens Adapter' as Product, CAST(742.50 AS money) AS Sales, 11 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1417.50 AS money) AS Sales, 21 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(13497.30 AS money) AS Sales, 54 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(11997.60 AS money) AS Sales, 48 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(10247.95 AS money) As Sales, 41 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory, 'Tripod' as Product, CAST(1200.00 AS money) AS Sales, 16 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(2025.00 AS money) AS Sales, 27 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1425.00 AS money) AS Sales, 19 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(887.50 AS money) AS Sales, 13 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Lens Adapter' as Product, CAST(607.50 AS money) AS Sales, 9 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1215.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(10191.00 AS money) AS Sales, 79 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(8772.00 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(10578.00 AS money) AS Sales, 82 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory,'Digital' as Subcategory, 'Slim Digital' as Product, CAST(7218.10 AS money) AS Sales, 38 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory,'Digital' as Subcategory, 'Slim Digital' as Product, CAST(8357.80 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory,'Digital' as Subcategory,'Slim Digital' as Product, CAST(9307.55 AS money) AS Sales, 49 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(3870.00 AS money) AS Sales, 30 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(5805.00 AS money) AS Sales, 45 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(8643.00 AS money) AS Sales, 67 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(9877.40 AS money) AS Sales, 52 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(12536.70 AS money) AS Sales, 66 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(6648.25 AS money) AS Sales, 35 as Quantity  
    
  7. Haga clic en el icono Ejecutar (!) para ejecutar la consulta.Click the Run icon (!) to run the query.

    Los resultados de la consulta son los datos disponibles para mostrarse en su informe.The query results are the data available to display in your report.

    report-builder-free-form-tutorial-data

  8. Haga clic en Aceptar.Click OK.

2. Agregar y configurar una lista2. Add and Configure a List

En Reporting ServicesReporting Services, la región de datos de lista es perfecta para crear informes de forma libre.In Reporting ServicesReporting Services the list data region is ideal for creating free-form reports. Se basa en la región de datos tablix , ya que son tablas y matrices.It's based on the tablix data region, as are tables and matrixes. Para obtener más información, consulte Crear facturas y formularios con listas.For more information, see Create Invoices and Forms with Lists.

Usará una lista para mostrar la información de ventas sobre los territorios de ventas en un informe con el formato de un boletín.You will use a list to display the sales information for sales territories in a report formatted like a newsletter. La información está agrupada por territorio.The information is grouped by territory. Agregará un nuevo grupo de filas que agrupa los datos por territorio y, a continuación, eliminará el grupo de filas de detalles integrado.You will add a new row group that groups data by territory, and then delete the built-in Details row group.

Para agregar una listaTo add a list

  1. En la pestaña Insertar > Regiones de datos > Lista.On the Insert tab > Data Regions > List.

  2. Haga clic en el cuerpo del informe (entre las áreas de título y pie de página) y arrastre para crear el cuadro de lista.Click in the report body (between the title and footer areas) and drag to make the list box. Haga el cuadro de lista de 7 pulgadas de alto y 6,25 pulgadas de ancho.Make the list box 7 inches tall and 6.25 inches wide. Para obtener el tamaño exacto, en el panel Propiedades en Posición, escriba los valores de las propiedades Ancho y Alto .To get the exact size, in the Properties pane under Position, type values for the Width and Height properties.

    Nota

    Este informe utiliza la Carta de tamaño del papel (8.5 X11) y márgenes de 1 pulgada.This report uses the paper size Letter (8.5 X11) and 1 inch margins. Un cuadro de lista más alto de 9 pulgadas o más ancho de 6,5 pulgadas podría generar páginas en blanco.A list box taller than 9 inches or wider than 6.5 inches might generate blank pages.

  3. Haga clic dentro del cuadro de lista, haga clic con el botón derecho en la parte superior de la lista y luego haga clic en Propiedades de Tablix.Click inside the list box, right-click the bar at the top of the list, and click Tablix Properties.

    report-builder-free-form-tablix-properties

  4. En la lista desplegable Nombre del conjunto de datos , seleccione ListDataset.In the Dataset name drop-down list, select ListDataset.

  5. Haga clic en Aceptar.Click OK.

  6. Haga clic con el botón derecho dentro de la lista y luego haga clic en Propiedades del rectángulo.Right-click inside the list, and then click Rectangle Properties.

  7. En la pestaña General , active la casilla Agregar un salto de página después .On the General tab, select the Add a page break after check box.

  8. Haga clic en Aceptar.Click OK.

Para agregar un nuevo grupo de filas y eliminar el grupo de detallesTo add a new row group and to delete the Details group

  1. En el panel Grupos de filas, haga clic con el botón derecho en el grupo Detalles, seleccione Agregar grupoy, después, haga clic en Grupo primario.In the Row Groups pane, right-click the Details group, point to Add Group, and then click Parent Group.

    report-builder-free-form-add-parent-group

  2. En la lista Agrupar por , seleccione [Territory].In the Group by list, select [Territory].

  3. Haga clic en Aceptar.Click OK.

    Una columna que contiene la celda [Territory] se agrega a la lista.A column containing the cell [Territory] is added to the list.

  4. Haga clic con el botón derecho en la columna Territory de la lista y, después, seleccione Eliminar columnas.Right-click the Territory column in the list, and then click Delete Columns.

    report-builder-free-form-delete-columns

  5. Seleccione Eliminar solo columnas.Select Delete Columns only.

  6. En el panel Grupos de filas, haga clic con el botón derecho en el grupo Detalles y luego haga clic en Eliminar grupo.In the Row Groups pane, right-click the Details group > Delete Group.

  7. Seleccione Eliminar solo el grupo.Select Delete Group only.

  8. Haga clic en Aceptar.Click OK.

3. Agregar elementos gráficos3. Add Graphic elements

Una de las ventajas de las regiones de datos de la lista es que puede agregar en cualquier parte los elementos de informe, como rectángulos y cuadros de texto, en lugar de limitarse a un diseño tabular.One advantage of list data regions is that you can add report items such as rectangles and text boxes anywhere, instead of being limited to a tabular layout. Mejorará la apariencia del informe agregando un gráfico (un rectángulo relleno con un color).You will enhance the appearance of the report by adding a graphic (a rectangle filled with a color).

Para agregar elementos gráficos al informeTo add graphic elements to the report

  1. En la pestaña Insertar , seleccione Rectángulo.On the Insert tab, select Rectangle.

  2. Haga clic en la esquina superior izquierda de la lista y arrastre para crear el rectángulo de 7 pulgadas de alto y 3,5 pulgadas de ancho.Click in the the upper left corner of the list and drag to make the rectangle 7 inches tall and 3.5 inches wide. De nuevo, para obtener el tamaño exacto, en el panel Propiedades en Posición, escriba los valores de Ancho y Alto.Again, to get the exact size, in the Properties pane under Position, type values for Width and Height.

  3. Haga clic con el botón derecho en el rectángulo > Propiedades del rectángulo.Right-click the rectangle > Rectangle Properties.

  4. Haga clic en la pestaña Rellenar .Click the Fill tab.

  5. En Color de relleno, seleccione Gris claro.In Fill color, select Light Gray.

  6. Haga clic en Aceptar.Click OK.

  7. Haga clic en Ejecutar para obtener la vista previa del informe.Click Run to preview the report.

La parte izquierda del informe tiene ahora un gráfico vertical compuesto por un rectángulo gris claro, tal y como se muestra en la imagen siguiente.The left side of the report now has vertical graphic that consists of a light gray rectangle, as shown in the following image.

report-builder-free-form-gray-rectangle

4. Agregar texto en forma libre4. Add Free Form Text

Puede agregar cuadros de texto para mostrar texto estático que se repite en cada página del informe, así como campos de datos.You can add text boxes to display static text that is repeated on each report page, as well as data fields.

Para agregar texto al informeTo add text to the report

  1. Haga clic en Diseño para volver a la vista de diseño.Click Design to return to design view.

  2. En la pestaña Insertar > Cuadro de texto.On the Insert tab > Text Box. Haga clic en la esquina superior izquierda de la lista, dentro del rectángulo que ha agregado anteriormente, y arrastre para crear el cuadro de texto de 3,45 pulgadas de ancho y 5 pulgadas de alto.Click the upper left corner of the list, inside of the rectangle you added previously, and drag to make the text box about 3.45 inches wide and 5 inches tall.

  3. Coloque el cursor en el cuadro de texto y escriba: Boletín para .With the cursor in the text box and type: Newsletter for . Incluya un espacio después de la palabra "para" para separar el texto del campo que se va a agregar en el paso siguiente.Include a space after the word "for", to separate the text from the field you will add in the next step.

    Agregar texto de encabezado del boletínAdd newsletter heading text

  4. Arrastre el campo [Territory] de ListDataSet en el panel Datos de informe al cuadro de texto y colóquelo después de "Boletín para ".Drag the [Territory] field from ListDataSet in the Report Data pane to the text box and place it after "Newsletter for ".

    report-builder-free-form-territory-field

  5. Seleccione el texto y el campo [Territory].Select the text and the [Territory] field.

  6. En la pestaña Inicio > Fuente, seleccione:On the Home tab > Font, select:

    • Segoe Semibold.Segoe Semibold.
    • 20 pt.20 pt.
    • Tomate.Tomato.
  7. Coloque el cursor debajo del texto que ha escrito en el paso 3 y escriba: Hola, con un espacio después para separar el texto y el campo que se va a agregar en el paso siguiente.Place the cursor below the text you typed in step 3 and type: Hello with a space after the word, to separate the text and the field that you will add in the next step.

  8. Arrastre el campo [FullName] de ListDataSet en el panel Datos de informe al cuadro de texto y colóquelo después de "Hola," y luego escriba dos puntos (:).Drag the [FullName] field from ListDataSet in the Report Data pane to the text box and place it after "Hello ", then type a comma (,).

  9. Seleccione el texto que ha agregado en los pasos anteriores.Select the text you added in the previous steps.

  10. En la pestaña Inicio > Fuente, seleccione:On the Home tab > Font, select:

    • Segoe Semibold.Segoe Semibold.
    • 16 pt.16 pt.
    • Negro.Black.
  11. Coloque el cursor debajo del texto que ha agregado en los pasos 9 a 13 y luego copie y pegue el siguiente texto que carece de sentido:Place the cursor below the text you added in steps 9 through 13, and then copy and paste the following meaningless text:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin sed dolor in ipsum pulvinar egestas. Sed sed lacus at leo ornare ultricies. Vivamus velit risus, euismod nec sodales gravida, gravida in dui. Etiam ullamcorper elit vitae justo fermentum ut ullamcorper augue sodales. 
    Ut placerat, nisl quis feugiat adipiscing, nibh est aliquet est, mollis faucibus mauris lectus quis arcu. In mollis tincidunt lacinia. In vitae erat ut lorem tincidunt luctus. Curabitur et magna nunc, sit amet adipiscing nisi. Nulla rhoncus elementum orci nec tincidunt. 
    Aliquam imperdiet cursus erat vel tincidunt. Donec et neque ac urna rutrum sodales. In id purus et nisl dignissim dapibus. Sed rhoncus metus at felis feugiat eu tempor dolor vehicula. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nullam faucibus consectetur diam eu pellentesque.   
    
  12. Seleccione el texto que acaba de agregar.Select the text you just added.

  13. En la pestaña Inicio > Fuente, seleccione:On the Home tab > Font, select:

    • Segoe UI.Segoe UI.
    • 10 pt.10 pt.
    • Negro.Black.
  14. Coloque el cursor dentro del cuadro de texto, debajo del texto que carece de sentido y escriba: Felicidades por sus ventas totales de, con un espacio después de la palabra para separar el texto y el campo que agregará en el paso siguiente.Place the cursor inside the text box, below the meaningless text and type: Congratulations on your total sales of, with a space after the word to separate the text and the field you will add in the next step.

  15. Arrastre el campo Sales hasta el cuadro de texto, colóquelo después del texto que ha escrito en el paso anterior y luego escriba un signo de exclamación (!).Drag the Sales field to the text box, place it after the text you typed in the previous step, then type an exclamation mark (!).

  16. Seleccione el texto y el campo que acaba de agregar.Select the text and the field you just added.

  17. En la pestaña Inicio > Fuente, seleccione:On the Home tab > Font, select:

    • Segoe Semibold.Segoe Semibold.
    • 16 pt.16 pt.
    • Negro.Black.
  18. Seleccione solo el campo [Sales], haga clic con el botón derecho en el campo > Expresión.Select just the [Sales] field, right-click the field > Expression.

  19. En el cuadro Expresión, cambie la expresión para incluir la función Sum como sigue:In the Expression box, change the expression to include the Sum function as follows:

    =Sum(Fields!Sales.value)  
    
  20. Haga clic en Aceptar.Click OK.

    report-builder-free-form-text-box

  21. Con [Sum(Sales)] aún seleccionado, en la pestaña Inicio > grupo Número > Moneda.With [Sum(Sales)] still selected, on the Home tab > Number group > Currency.

  22. Haga clic con el botón derecho en el cuadro de texto con el texto "Haga clic para agregar un título" y, después, haga clic en Eliminar.Right-click the text box with the "Click to add title" text, and then click Delete.

  23. Seleccione el cuadro de lista.Select the list box. Seleccione las dos flechas de dos puntas y muévalo a la parte superior de la página.Select the two double-headed arrows and move it to the top of the page.

    report-builder-drag-list

  24. Haga clic en Ejecutar para obtener la vista previa del informe.Click Run to preview the report.

El informe muestra el texto estático y cada página del informe incluye datos que pertenecen a un territorio.The report displays static text and each report page includes data that pertains to a territory. Se da formato a las ventas como moneda.Sales are formatted as currency.

report-builder-newsletter-page-preview

5. Agregar una tabla para mostrar los detalles de ventas5. Add a Table to Show Sales Details

Utilice el nuevo Asistente para tablas y matrices para agregar una tabla al informe de la forma libre.Use the New Table and Matrix Wizard to add a table to the free form report. Después de completar el asistente, agregará manualmente una fila para los totales.After you complete the wizard, you will manually add a row for totals.

Para agregar una tablaTo add a table

  1. En la pestaña Insertar > área Regiones de datos > Tabla > Asistente para tablas.On the Insert tab > Data Regions area > Table > Table Wizard.

  2. En la página Elegir un conjunto de datos , haga clic en ListDataset > Siguiente.On the Choose a dataset page, click ListDataset > Next.

  3. En la página Organizar campos , arrastre el campo Product desde Campos disponibles hasta Valores.On the Arrange fields page, drag the Product field from Available fields to Values.

  4. Repita el paso 3 para SalesDate, Quantity y Sales.Repeat step 3 for SalesDate, Quantity, and Sales. Coloque SalesDate bajo Product, Quantity bajo SalesDate y Sales bajo SalesDate.Place SalesDate below Product, Quantity below SalesDate, and Sales below SalesDate.

  5. Haga clic en Siguiente.Click Next.

  6. En la página Elegir el diseño , vea el diseño de la tabla.On the Choose the layout page, view the layout of the table.

    La tabla es simple: cinco columnas sin grupos de filas o columnas.The table is simple: five columns with no row or column groups. Dado que no tiene ningún grupo, las opciones de diseño relacionadas con los grupos no están disponibles.Because it has no groups, the layout options related to groups, are not available. Actualizará manualmente la tabla para incluir un total en una fase posterior del tutorial.You will manually update the table to include a total later in the tutorial.

  7. Haga clic en Siguiente.Click Next.

  8. Haga clic en Finalizar.Click Finish.

  9. Arrastre la tabla bajo el cuadro de texto que agregó en la lección 4.Drag the table to below the text box that you added in lesson 4.

    Nota

    Asegúrese de que la tabla está dentro del cuadro de lista y dentro del rectángulo gris.Make sure the table is inside the list box and inside the gray rectangle.

  10. Con la tabla seleccionada, en el panel Grupo de filas , haga clic con el botón derecho en Detalles > Agregar total > Después.With the table selected, in the Row Group pane right-click Details > Add Total > After.

    report-builder-free-form-table-totals

  11. Seleccione la celda de la columna Product y escriba Total.Select the cell in the Product column and type Total.

    report-builder-free-form-type-total

  12. Seleccione el campo [SalesDate].Select the [SalesDate] field. En la pestaña Inicio > Número, cambie Valor predeterminado por Fecha.On the Home tab > Number, change Default to Date.

  13. Seleccione los campos [SUM(Sales)].Select the [Sum(Sales)] fields. En la pestaña Inicio > Número, cambie Valor predeterminado por Moneda.On the Home tab > Number, change Default to Currency.

Haga clic en Ejecutar para obtener la vista previa del informe.Click Run to preview the report.

El informe muestra una tabla con detalles y totales de ventas.The report displays a table with sales details and totals.

report-builder-free-form-with-table

6. Guardar el informe6. Save the Report

Puede guardar los informes en un servidor de informes, en una biblioteca de SharePoint o en su equipo.You can save reports to a report server, SharePoint library, or your computer.

En este tutorial, guarde el informe en un servidor de informes.In this tutorial, save the report to a report server. Si no tiene acceso a un servidor de informes, guarde el informe en su equipo.If you do not have access to a report server, save the report to your computer.

Para guardar el informe en un servidor de informesTo save the report on a report server

  1. En el botón Generador de informes , haga clic en Guardar como.From the Report Builder button, click Save As.

  2. Haga clic en Sitios y servidores recientes.Click Recent Sites and Servers.

  3. Seleccione o escriba el nombre del servidor de informes donde tiene el permiso para guardar los informes.Select or type the name of the report server where you have permission to save reports.

    Aparecerá el mensaje "Conectando con el servidor de informes".The message "Connecting to report server" appears. Una vez completada la conexión, se mostrará el contenido de la carpeta de informes que el administrador del servidor de informes especificó como ubicación predeterminada para los informes.When the connection is complete, you see the contents of the report folder that the report server administrator specified as the default location for reports.

  4. En Nombre, reemplace el nombre predeterminado por SalesInformationByTerritory.In Name, replace the default name with SalesInformationByTerritory.

  5. Haga clic en Guardar.Click Save.

El informe se guarda en el servidor de informes.The report is saved to the report server. El nombre del servidor de informes al que está conectado aparecerá en la barra de estado en la parte inferior de la ventana.The name of report server that you are connected to appears in the status bar at the bottom of the window.

Para guardar el informe en el equipoTo save the report on your computer

  1. En el botón Generador de informes , haga clic en Guardar como.From the Report Builder button, click Save As.

  2. Haga clic en Escritorio, Mis documentoso Mi PCy vaya a la carpeta donde desea guardar el informe.Click Desktop, My Documents, or My computer, and then browse to the folder where you want to save the report.

  3. En Nombre, reemplace el nombre predeterminado por SalesInformationByTerritory.In Name, replace the default name with SalesInformationByTerritory.

  4. Haga clic en Guardar.Click Save.

7. (Opcional) Agregar una línea para separar áreas del informe7. (Optional) Add a Line to Separate Areas of the Report

Agregue una línea para separar las áreas de editorial y detalles del informe.Add a line to separate the editorial and details areas of the report.

Para agregar una líneaTo add a line

  1. Haga clic en Diseño para volver a la vista de diseño.Click Design to return to design view.

  2. En el insertar ficha > elementos de informe > línea.On the Insert tab > Report Items > Line.

  3. Dibuje una línea debajo del cuadro de texto que ha agregado en la lección 4.Draw a line below the text box you added in lesson 4.

  4. Haga clic en la línea y, en la pestaña Inicio > Borde, seleccione:Click the line, and on the Home tab > Border, select:

    • Ancho seleccione 3 pt.Width select 3 pt.
    • Color seleccione Tomate.Color select Tomato.

8. (Opcional) Agregar visualizaciones de datos resumidos8. (Optional) Add Summary Data Visualizations

Los rectángulos le ayudan a controlar cómo se representa el informe.Rectangles help you control how the report renders. Coloque un grafo circular y de columnas dentro de un rectángulo para asegurarse de que el informe se representa del modo que desea.Place a pie and column chart inside a rectangle to ensure that the report renders the way you want.

Para agregar un rectánguloTo add a rectangle

  1. Haga clic en Diseño para volver a la vista de diseño.Click Design to return to design view.

  2. En el insertar ficha > elementos de informe > rectángulo.On the Insert tab > Report Items > Rectangle. Arrastre el rectángulo dentro del cuadro de lista a la derecha de la tabla para crear un rectángulo de aproximadamente 2,25 pulgadas de ancho y 7,9 pulgadas de alto.Drag the rectangle inside the list box to the right of the table to make a rectangle about 2.25 inches wide and 7.9 inches tall.

  3. Con el nuevo rectángulo seleccionado, en el panel Propiedades, haga BorderColor LightGrey, BorderStyle Solidy BorderWidth 2 pt.With the new rectangle selected, in the Properties pane, make BorderColor LightGrey, BorderStyle Solid, and BorderWidth 2 pt.

  4. Alinee las partes superiores del rectángulo y la tabla.Align the tops of the rectangle and the table.

Para agregar un gráfico circularTo add a pie chart

  1. En la pestaña Insertar > Visualizaciones de datos > Gráfico > Asistente para gráficos.On the Insert tab > Data Visualizations > Chart > Chart Wizard.

  2. En la página Elegir un conjunto de datos , haga clic en ListDataset > Siguiente.On the Choose a dataset page, click ListDataset > Next.

  3. Haga clic en Circular > Siguiente.Click Pie > Next.

  4. En la página Organizar campos del gráfico, arrastre Product hasta Categorías.On the arrange chart fields page, drag Product to Categories.

  5. Arrastre Quantity hasta Valoresy, después, haga clic en Siguiente.Drag Quantity to Values, then click Next.

  6. Haga clic en Finalizar.Click Finish.

  7. Cambie el tamaño del gráfico que aparece en la esquina superior izquierda del informe, para que tenga aproximadamente 2,25 pulgadas de ancho y 3,6 de alto.Resize the chart that appears in the upper left corner of the report to be about 2.25 inches wide and 3.6 inches tall.

  8. Arrastre el gráfico dentro del rectángulo.Drag the chart inside the rectangle.

  9. Seleccione el título del gráfico y escriba: Cantidades de producto vendidas.Select the chart title and type: Product Quantities Sold.

  10. En la pestaña Inicio > Fuente, para el título:On the Home tab > Font, make the title:

    • Fuente Segoe UI Semibold.Font Segoe UI Semibold.
    • Size 12 pt.Size 12 pt.
    • Color Negro.Color Black.
  11. Haga clic con el botón derecho en la leyenda > Propiedades de la leyenda.Right-click the legend > Legend Properties.

  12. En la pestaña General, en Posición de la leyenda, seleccione el punto central en la parte inferior.On the General tab, under Legend position, select the center dot at the bottom.

  13. Haga clic en Aceptar.Click OK.

  14. Si es necesario, arrastre para que la región del gráfico sea más alta.Drag to make the chart region taller, if necessary.

    report-builder-free-form-pie

Para agregar un gráfico de columnasTo add a column chart

  1. En la pestaña Insertar > Visualizaciones de datos > Gráfico, > Asistente para gráficos.On the Insert tab > Data Visualizations > Chart, > Chart Wizard.

  2. En la página Elegir un conjunto de datos, haga clic en ListDataset y, después, en Siguiente.On the Choose a dataset page, click ListDataset, then click Next.

  3. Haga clic en Columnay, luego, en Siguiente.Click Column, then click Next.

  4. En la página Organizar campos del gráfico , arrastre el campo Product hasta Categorías.On the Arrange chart fields page, drag the Product field to Categories.

  5. Arrastre Sales hasta Valores y, después, haga clic en Siguiente.Drag Sales to Values, and then click Next.

    Valores se muestra en el eje vertical.Values display on the vertical axis.

  6. Haga clic en Finalizar.Click Finish.

    Un gráfico de columnas se agrega a la esquina superior izquierda del informe.A column chart is added to the upper left corner of the report.

  7. Cambie el tamaño del gráfico para que tenga aproximadamente 2,25 pulgadas de ancho y casi 4 pulgadas de alto.Resize the chart to be about 2.25 inches wide and almost 4 inches tall.

  8. Arrastre el gráfico al interior del rectángulo, debajo del gráfico circular.Drag the chart inside the rectangle, below the pie chart.

  9. Seleccione el título del gráfico y escriba: Ventas de producto.Select the chart title and type: Product Sales.

  10. En la pestaña Inicio > Fuente, para el título:On the Home tab > Font, make the title:

    • Fuente Segoe UI Semibold.Font Segoe UI Semibold.
    • Size 12 pt.Size 12 pt.
    • Color Black.Color Black.
  11. Haga clic con el botón secundario en la leyenda y, a continuación, haga clic en Eliminar leyenda.Right click the legend, and then click Delete Legend.

    Nota

    Quitar la leyenda hace que el gráfico sea más legible si el gráfico es pequeño.Removing the legend makes the chart more readable when the chart is small.

    report-builder-free-form-column

  12. Seleccione el eje del gráfico y en el inicio* pestaña > número > moneda.Select the chart axis, and on the Home* tab > Number > Currency.

  13. Seleccione Disminuir decimales dos veces, de modo que el número muestre solo dólares sin centavos.Select Decrease Decimal two times, so the number shows just dollars and no cents.

    Para comprobar que los gráficos están dentro del rectánguloTo verify the charts are inside the rectangle

Puede usar rectángulos como contenedores para otros elementos de una página del informe.You can use rectangles as containers for other items on a report page. Obtenga más información sobre rectángulos como contenedores.Read more about rectangles as containers.

  1. Seleccione el rectángulo que ha creado y al que ha agregado los gráficos, anteriormente en esta lección.Select the rectangle you created and added the charts to, earlier in this lesson.

    En el panel Propiedades, la propiedad Name muestra el nombre del rectángulo.In the Properties pane, the Name property displays the name of the rectangle.

    report-builder-free-form-rectangle-name

  2. Haga clic en el gráfico circular.Click the pie chart.

  3. En el panel Propiedades , compruebe que la propiedad Parent contiene el nombre del rectángulo.In the Properties pane, verify that the Parent property contains the name of the rectangle.

    report-builder-free-form-pie-parent

  4. Haga clic en el gráfico de columnas y repita el paso 3.Click the column chart and repeat step 3.

    Nota

    Si los gráficos no están dentro del rectángulo, el informe representado no muestra los gráficos juntos.If the charts are not inside the rectangle, the rendered report does not display the charts together.

Para que los gráficos sean del mismo tamañoTo make the charts the same size

  1. Seleccione el gráfico circular, pulse la tecla CTRL y, después, seleccione el gráfico de columnas.Select the pie chart, press the Ctrl key, and then select the column chart.

  2. Con ambos gráficos seleccionados, haga clic con el botón derecho > Diseño > Igualar ancho.With both charts selected, right-click > Layout > Make Same Width.

    Nota

    El elemento en el que hace clic primero determina el ancho de todos los elementos seleccionados.The item you click first determines the width of all the selected items.

  3. Haga clic en Ejecutar para obtener la vista previa del informe.Click Run to preview the report.

El informe muestra ahora los datos de ventas resumidos en gráficos circulares y de columnas.The report now displays summary sales data in pie and column charts.

Pasos siguientesNext Steps

Esto concluye el tutorial sobre cómo crear un informe de forma libre.This concludes the tutorial for how to create a free-form report.

Para obtener más información sobre las listas, consulte:For more information about lists, see:

Para obtener más información sobre los diseñadores de consultas, consulte Diseñadores de consultas (Generador de informes) e Interfaz de usuario del Diseñador de consultas basado en texto (Generador de informes).For more information about query designers, see Query Designers (Report Builder) and Text-based Query Designer User Interface (Report Builder).

Vea tambiénSee Also

Tutoriales del Generador de informesReport Builder Tutorials