Quitar o eliminar un elemento o un proyecto

Se aplica a: síSQL Server (todas las versiones admitidas) SíAzure SQL Database SíInstancia administrada de Azure SQL síAzure Synapse Analytics síAlmacenamiento de datos paralelos

Los elementos de proyecto en los proyectos de SQL Server Management Studio son las consultas, las conexiones y los archivos varios. Se pueden quitar consultas y archivos varios del proyecto de una solución sin borrar los archivos almacenados. Quite un proyecto o un elemento que no sea útil para la solución actual, pero que desee incluir en otra solución.

Para quitar un elemento de un proyecto

  1. En el Explorador de soluciones, seleccione el elemento del proyecto que desea quitar.

  2. En el menú Editar , haga clic en Quitar.

  3. En el cuadro de diálogo de confirmación, haga clic en Quitar para quitar el elemento del proyecto.

Un elemento quitado aún se encuentra en el sistema de archivos. Por lo tanto, puede agregar ese elemento quitado a la solución original o a otra solución.

Para quitar un proyecto

  1. En el Explorador de soluciones, seleccione el proyecto que desea quitar.

  2. En el menú Editar , haga clic en Quitar.

  3. En el cuadro de diálogo de confirmación, haga clic en Aceptar para quitar el proyecto de la solución.

Un proyecto se puede eliminar de forma permanente, pero primero es necesario quitar todas las referencias a este de las soluciones de SQL Server Management Studio y, después, usar el Explorador de Microsoft Windows para eliminar de forma permanente los archivos asociados almacenados.

Para eliminar un proyecto

  1. En el Explorador de soluciones, quite el proyecto que desea eliminar de la solución.

  2. En el Explorador de Windows, busque y seleccione los archivos asociados al proyecto o elemento que desea eliminar.

  3. En el menú Archivo , haga clic en Eliminar.

Consulte también

Explorador de soluciones
Agregar nuevos elementos a un proyecto
Agregar elementos existentes a un proyecto