Ejecución, almacenamiento y exportación de un informeHow to run, save, and export a report

Se aplica a: System Center 2016 Operations ManagerApplies To: System Center 2016 - Operations Manager

Para ver un informe en Operations Manager, selecciónelo, escriba los parámetros necesarios y ejecútelo.You can view reports in Operations Manager by selecting it, entering the required parameters and executing it. Después de ejecutarlo, también puede guardar la configuración en un informe vinculado, que implementa ese informe con distintas configuraciones.Once you run it, you can also choose to save the configuration to a linked report, which deploys that report with different settings. Un informe se puede exportar a otro formato de archivo (como PowerPoint, Image, PDF, Microsoft Word o Microsoft Excel) para los usuarios de informes.You can export a report to another file format, such as PowerPoint, Image, PDF, Microsoft Word, or Microsoft Excel for your reporting users.

Para poder exportar o guardar los parámetros de un informe, antes hay que ejecutarlo.Before exporting or saving the report parameters, you must first run the report.

Para ejecutar un informe desde el panel InformesTo run a report from the Reporting pane

Haga lo siguiente para ejecutar un informe desde el área de trabajo Informes.Use the following procedure to run a report from the Reporting workspace. En este ejemplo, se ejecutará un informe de disponibilidad.In this example, you will run an availability report.

  1. Inicie sesión en el equipo con una cuenta que sea miembro del rol Operadores de informes de Operations Manager.Log on to the computer with an account that is a member of the Operations Manager Report Operators role.

  2. En la Consola del operador, haga clic en Informes.In the Operations console, click Reporting.

  3. En el área de trabajo Informes, expanda Informes y, luego, haga clic en Biblioteca de informes genéricos de Microsoft.In the Reporting workspace, expand Reporting and then click Microsoft Generic Report Library.

  4. En el panel Informes, haga clic con el botón derecho en uno de los informes (por ejemplo, Disponibilidad) y haga clic en Abrir.In the Reports pane, right-click one of the reports (for example, Availability) and then click Open.

  5. En la vista Informe, en el área Parámetro, haga clic en la flecha abajo en el cuadro Desde, elija Esta semana y, después, haga clic en Domingo.In the Report view, in the Parameter area, click the down arrow in the From box, point to This week, and then click Sunday.

  6. Haga clic en la flecha abajo del cuadro Hasta, elija Esta semana y, luego, haga clic en Sábado.Click the down arrow in the To box, point to Thisweek and then click Saturday.

  7. Haga clic en Usar horario laboral.Click Use business hours.

    Nota

    Puede especificar el período de tiempo del informe de forma más precisa con las opciones adicionales del área Parámetros.You can further specify the timeframe for the report in the additional options in the Parameter area.

  8. Haga clic en Agregar objeto.Click Add Object.

  9. En el cuadro de texto Nombre del objeto del cuadro de diálogo Agregar objeto, escriba el nombre de equipo de un equipo de cuya disponibilidad quiera informar y, luego, haga clic en Buscar.In the AddObject dialog box, in the ObjectName text box, type the computer name for a computer that you want to report availability, and then click Search.

  10. En la lista Elementos disponibles, haga clic en el equipo para el que quiera ejecutar un informe, haga clic en Agregar y, luego, en Aceptar.In the Availableitems list, click the computer you want to run a report for, click Add, and then click OK.

  11. Haga clic en Ejecutar para ver el informe de disponibilidad.Click Run to display the Availability Report.

  12. Para crear un informe más detallado, como un informe que muestre un gráfico para cada día, haga clic en el gráfico de barras horizontales en Seguimiento de disponibilidad.For a more detailed report, such as a report showing a graph for every day, click the horizontal bar graph under Availability Tracker.

  13. En la barra de herramientas, haga clic en Ver, seleccione Ir a y, luego, haga clic en Volver a informe primario para volver al informe original.In the toolbar, click View, point to GoTo, and then click Back to Parent Report to return to the original report.

  14. Haga clic en Cerrar para cerrar el informe.Click Close to close the report.

Almacenamiento de un informeHow to save a report

Cuando un informe se ejecuta, se puede guardar en Informes favoritos o en un módulo de administración.When you run a report, you can save the report to Favorite Reports or you can save a report into an existing management pack. Los informes que un usuario guarde en Informes favoritos estarán visibles exclusivamente para ese usuario.A report saved to Favorite Reports is only visible to you. Guardar un informe en un módulo de administración sin sellar resulta útil cuando es necesario compartir con los usuarios un informe que incluya un conjunto específico de parámetros.Saving a report to an unsealed management pack is useful if you need to share with report users that includes a specific set of parameters.

El siguiente procedimiento sirve para guardar un informe en un módulo de administración:The following steps outline the procedure for saving a report to a management pack:

  1. Ejecute un informe desde la biblioteca de informes genéricos o desde otro módulo de administración, como el módulo de administración de SQL Server.Run a report from the Generic Report Library or from another management pack, such as the SQL Server management pack. Especifique los parámetros que quiera para el informe y haga clic en Ejecutar.Specify the parameters you want to for the report and click Run.

  2. Cuando el informe se represente, confirme que contiene la información necesaria.When the report renders, validate that it contains the information you need.

  3. En el menú Archivo, haga clic en Guardar en módulo de administración.On the File menu, click Save to management pack.

  4. Siga las instrucciones del asistente para crear el informe.Follow the instructions in the wizard to save the report.

Cuando el asistente finalice, el módulo de administración se guarda en Operations Manager y, posteriormente, se implementa en el servidor de informes y se pone a disposición de todos los operadores de informes.After the wizard completes, the management pack is saved to Operations Manager and then later deployed to the report server and is made available for all report operators.

Nota

Tenga en cuenta lo siguiente al guardar informes:Be aware of the following when saving reports:

  • Los informes se pueden guardar en un módulo de administración desde Informes favoritos.Reports can be saved to a management pack from Favorite Reports.
  • Los informes no se pueden guardar en un módulo de administración desde Informes creados.Reports cannot be saved to a management pack from authored reports.

Los módulos de administración se pueden exportar e importar a otros grupos de administración; estos informes solo funcionarán si estos grupos de administración comparten el mismo almacenamiento de datos.Management packs can be exported and imported into other management groups and the reports will work only when these management groups share the same data warehouse.

Solo los usuarios que sean miembros del grupo de autorización pueden guardar informes en módulos de administración.Only users who are members of the authorization can save reports to management packs.

Exportación de un informeHow to export a Report

Después de ejecutar un informe, se puede exportar a distintos formatos compatibles con SQL Server Reporting Services.After a report has been run, you can export the report into one of several formats supported by SQL Server Reporting Services. Para obtener más información sobre qué formatos admite SQL Server Reporting Services, revise Exportación de informes.To learn about what formats are supported by SQL Server Reporting Services, please review Export Reports

Nota

Para poder ejecutar un informe, antes es necesario haber instalado informes de Operations Manager.Operations Manager Reporting must be installed before you can run a report.

Si quiere administrar y distribuir informes de forma segura, puede exportar informes a Microsoft Windows SharePoint Services, que ofrece administración de derechos digitales.If you want to manage and distribute reports securely, you can export reports to Microsoft Windows SharePoint Services, which offers digital rights management. Consulte con el administrador de seguridad de red.Consult your network security administrator.

  1. Una vez ejecutado un informe, en la barra de herramientas, haga clic en el menú Archivo, elija Exportar y, luego, haga clic en el formato en el que quiere exportar el archivo.After a report has been run, in the toolbar, click the File menu, point to Export, and then click the format you want to export the file to.

  2. En el cuadro de diálogo Guardar como, seleccione la carpeta en la que quiera guardar el informe y, luego, haga clic en Guardar.In the Save As dialog box, select the folder where you want to save the report, and then click Save.

Pasos siguientesNext steps