Error al intentar eliminar un directorio B2C en Azure AD: no se puede eliminar " <contoso> "
En este artículo se describe un problema en el que se produce un error cuando se intenta eliminar un directorio B2C en Azure Active Directory.
Versión del producto original: Azure Active Directory
Número de KB original: 3112170
Síntomas
En un entorno de Microsoft Azure Active Directory, configure un directorio B2C y, a continuación, intente eliminarlo. Sin embargo, recibe el siguiente mensaje de error:
No se puede eliminar ' <contoso> '
Los siguientes problemas impiden la eliminación del directorio:
El directorio contiene una o más aplicaciones agregadas por un usuario o administrador
Causa
Este problema se produce si las entidades de servicio de la aplicación B2C existentes (por ejemplo, CPIM, Ibiza portal y SSPR) bloquean la eliminación.
Solución
Para solucionar este problema, use Azure portal.
Paso 1: eliminar todas las aplicaciones que se enumeran en el panel de Azure AD B2C
Para ello, siga estos pasos:
Inicie sesión en Azure portal como administrador con acceso al directorio de Azure ad B2C.
Seleccione su nombre para mostrar en la esquina superior derecha y, a continuación, seleccione el directorio que es el directorio B2C.
Nota
Si solo tiene un directorio, el directorio de Azure AD B2C ya estará seleccionado.
Para encontrar la hoja de Azure AD B2C, seleccione el botón más servicios (>) en la esquina inferior izquierda y, a continuación, busque en "B2C".
Seleccione la B2C de Azure ad.
Seleccione todas las opciones de configuracióny, a continuación, seleccione aplicaciones.
Elimine todas las aplicaciones. Para ello, seleccione la aplicación, seleccione propiedadesy, a continuación, seleccione el botón eliminar .
Paso 2: eliminar el inquilino de Azure AD B2C
Para ello, siga estos pasos:
En el directorio de Azure AD B2C, busque y seleccione la hoja Azure Active Directory en Azure portal.
En el menú información general , seleccione eliminar directorio.
Siga las instrucciones del portal.