Error al intentar eliminar un directorio B2C en Microsoft Entra ID: No se puede eliminar "<contoso>"
En este artículo se describe un problema en el que se produce un error al intentar eliminar un directorio B2C en Microsoft Entra ID.
Versión del producto original: Microsoft Entra ID
Número de KB original: 3112170
Síntomas
En un entorno Microsoft Entra, configura un directorio B2C y, a continuación, intenta eliminarlo. Sin embargo, recibe el siguiente mensaje de error:
No se puede eliminar "<contoso>"
Los siguientes problemas impiden la eliminación del directorio:
El directorio contiene una o varias aplicaciones agregadas por un usuario o administrador
Causa
Este problema se produce si las entidades de servicio de aplicaciones B2C existentes (por ejemplo, CPIM, Ibiza Portal y SSPR) bloquean la eliminación.
Solución
Para solucionar este problema, use el Azure Portal.
Paso 1: Eliminación de todas las aplicaciones que aparecen en el panel de Azure AD B2C
Para ello, siga estos pasos:
Inicie sesión Azure Portal como administrador que tenga acceso al directorio de Azure AD B2C.
Seleccione el nombre para mostrar en la esquina superior derecha y, a continuación, seleccione el directorio que es el directorio B2C.
Nota:
Si solo tiene un directorio, ya se seleccionará el directorio de Azure AD B2C.
Para buscar la hoja Azure AD B2C, seleccione el botón Más servicios (>) en la esquina inferior izquierda y, a continuación, busque "B2C".
Seleccione Azure AD B2C.
Seleccione Todas las configuraciones y, a continuación, aplicaciones.
Elimine todas las aplicaciones. Para ello, seleccione la aplicación , propiedadesy, a continuación, seleccione el botón Eliminar .
Paso 2: Eliminación del inquilino de Azure AD B2C
Para ello, siga estos pasos:
En el directorio de Azure AD B2C, busque y seleccione la hoja Microsoft Entra ID en el Azure Portal.
En el menú Información general , seleccione Eliminar directorio.
Siga las instrucciones del portal.
Ponte en contacto con nosotros para obtener ayuda
Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.
Comentarios
https://aka.ms/ContentUserFeedback.
Próximamente: A lo largo de 2024 iremos eliminando gradualmente GitHub Issues como mecanismo de comentarios sobre el contenido y lo sustituiremos por un nuevo sistema de comentarios. Para más información, vea:Enviar y ver comentarios de