Error AADSTS50105: el usuario que ha iniciado sesión no está asignado a un rol para la aplicación.

En este artículo se proporciona una resolución del error de AADSTS50105 que se produce durante la autenticación federada con Microsoft Entra ID.

Nota:

¿Le resultó útil este artículo? Su opinión es importante para nosotros. Use el botón Comentarios de esta página para indicarnos lo bien que ha funcionado este artículo o cómo podemos mejorarlo.

Síntomas

Recibirá el siguiente mensaje de error al intentar iniciar sesión en una aplicación que se ha configurado para usar Microsoft Entra ID para la administración de identidades mediante el Sign-On único (SSO) basado en SAML:

Error AADSTS50105: el usuario que ha iniciado sesión no está asignado a un rol para la aplicación.

Causa

Al usuario no se le ha concedido acceso a la aplicación en Microsoft Entra ID. El usuario debe pertenecer a un grupo asignado a la aplicación o asignarse directamente.

Nota:

No se admiten grupos anidados y el grupo debe asignarse directamente a la aplicación.

Solución

Para asignar uno o más usuarios a una aplicación directamente, consulte Inicio rápido: Asignación de usuarios a una aplicación.

Más información

Para obtener una lista completa de los códigos de error de autenticación y autorización de Active Directory, consulte Microsoft Entra códigos de error de autenticación y autorización.

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.