Solucionar problemas del código de error 8023062C: restablecimiento o cambio de contraseña no seguro

En este artículo se describe cómo solucionar un error de escritura de contraseña que se produce cuando Azure AD Conectar intenta realizar un cambio o restablecimiento de contraseña en una configuración insegura. Esta situación se produce específicamente cuando Azure AD Conectar intenta realizar un cambio o restablecimiento de contraseña sin tener una conexión de seguridad de la capa de transporte (TLS) o capa de sockets seguros (SSL) de 128 bits.

Síntomas

Cuando un usuario o administrador intenta cambiar o restablecer una contraseña en Azure AD, se produce un error de escritura de contraseña en el directorio local y devuelve un código de error "8023062C (0x8023062c)" y el siguiente mensaje de error:

No se pudo establecer la contraseña porque el servidor no está configurado para la configuración insegura de las contraseñas, o se requiere una conexión TLS o SSL de 128 bits.

Causa

Microsoft Azure AD Conectar se ha configurado para no requerir que el tráfico del Protocolo ligero de acceso a directorios (LDAP) esté firmado y cifrado.

Solución

Asegúrese de que la configuración Firmar y cifrar tráfico LDAP está habilitada en tres lugares dentro del Administrador de servicios de sincronización siguiendo estos pasos:

  1. Abra el Synchronization Service manager. Para ello, abra el menú Inicio, vaya al grupo Azure AD Conectar y, a continuación, seleccione Servicio de sincronización.

  2. Seleccione la pestaña Conectores y, a continuación, seleccione el conector de Active Directory aplicable. En el panel Acciones , seleccione Propiedades.

  3. En el lado izquierdo del cuadro de diálogo Propiedades, seleccione Conectar al bosque de Active Directory y, a continuación, seleccione el botón Opciones. En el cuadro de diálogo Opciones de conexión, active Firmar y cifrar tráfico LDAP y, a continuación, seleccione Aceptar.

  4. En el lado izquierdo del cuadro de diálogo Propiedades , seleccione Configurar particiones de directorio. A continuación, en el panel Configurar particiones de directorio , seleccione una partición de directorio de la lista.

  5. En el grupo Configuración de conexión del controlador de dominio , seleccione el botón Opciones. En el cuadro de diálogo Opciones de conexión, active Firmar y cifrar tráfico LDAP y, a continuación, seleccione Aceptar.

  6. En el grupo Credenciales , compruebe si la opción Credenciales alternativas para esta partición de directorio está seleccionada. Si esa opción no está seleccionada, vaya al paso 8. De lo contrario, seleccione el botón Establecer credenciales y, a continuación, seleccione Opciones en el cuadro de diálogo Credenciales.

  7. En el cuadro de diálogo Opciones de conexión, active Firmar y cifrar tráfico LDAP y, a continuación, seleccione Aceptar dos veces para volver al cuadro de diálogo Propiedades.

  8. Seleccione Aceptar para guardar los cambios y volver al Administrador de servicios de sincronización.

  9. Seleccione Inicio, escriba services.msc y, a continuación , seleccione el complemento Servicios. Seleccione Microsoft Azure AD sincronización en la lista de servicios y, a continuación, seleccione el icono Reiniciar servicio.