Solución de SSPR_009 error: el administrador Azure AD sincronizada no puede restablecer la contraseña desde la nube
En este artículo se explica cómo solucionar un error de restablecimiento de contraseña que se produce cuando un usuario sincronizado que tiene un rol de administrador de Azure Active Directory (Azure AD) intenta restablecer su contraseña sin éxito.
Este escenario se produce después https://login.microsoftonline.com de que el usuario visite la página de inicio de sesión en y seleccione ¿No puede acceder a su cuenta ?****, ¿ Ha olvidado mi contraseña o restablezcala ahora? A continuación, el explorador redirige al usuario a la página de restablecimiento de contraseña de autoservicio (SSPR) en https://passwordreset.microsoftonline.com la que se inicia el proceso de SSPR. Este proceso requiere que el usuario escriba un código "captcha". Si la operación se realiza correctamente, la reescribición de contraseñas envía una solicitud de restablecimiento de contraseña para el usuario a un dominio de Active Directory local. Simultáneamente, SSPR establece la nueva contraseña en Azure AD. Si la operación no se realiza correctamente, se devuelve SSPR_009 error "SSPR_009". Si se produce el error, use este artículo para solucionar el problema.
Síntomas
Después de que un usuario sincronizado intente restablecer una contraseña sin éxito especificando un código captcha, el explorador muestra el siguiente mensaje de error:
No puede restablecer su propia contraseña porque el restablecimiento de contraseña no está activado para su organización.
SSPR_009: la organización no ha activado el restablecimiento de contraseña. Si es administrador, puede obtener más información en el artículo "Cómo habilitar el restablecimiento de contraseña ". Si no es administrador, puede proporcionar esta información al ponerse en contacto con el administrador.
Nota
Este escenario solo se produce para Azure AD usuarios que tienen asignado un rol Azure AD de administrador. El flujo de cambio o restablecimiento de contraseñas funciona según lo esperado para las cuentas estándar.
Causa
SSPR para administradores no está habilitado en el inquilino. SSPR para administradores (SSPR-A) fue la primera implementación de SSPR. Después de introducir SSPR para usuarios (SSPR-U), los usuarios podrían tener dos configuraciones independientes.
La implementación antigua de SSPR-A se usa cuando una cuenta de Azure AD tiene un rol de administrador, como administrador global o administrador de facturación. Sin embargo, la administración de SSPR en Azure Portal es solo para SSPR-U. Por lo tanto, es posible que SSPR-A no esté habilitado en el inquilino.
Solución
Habilite SSPR-A en el inquilino ejecutando el cmdlet De PowerShell Set-MsolCompanySettings , de la siguiente manera:
Set-MsolCompanySettings -SelfServePasswordResetEnabled $true