Solucionar retrasos después del primer inicio de sesión después de un cambio forzado de contraseña
En este artículo se describe cómo solucionar un problema de escritura escritura de contraseña cuando un usuario se ve obligado a cambiar su contraseña en el primer inicio de sesión.
Síntomas
Después de que un usuario haga un cambio de contraseña necesario en el primer inicio de sesión, recibirá este mensaje de advertencia:
La contraseña se actualizó correctamente, pero nuestros servidores tardaron un poco en ponerse al día. Intente iniciar sesión de nuevo en unos minutos.
Causa
Cuando un usuario se ve obligado a cambiar su contraseña en el primer inicio de sesión en Azure Active Directory (Azure AD), el proceso de escritura escritura de contraseña acepta la contraseña temporal para el inicio de sesión y se le pide que proporcione una nueva contraseña. La escritura por escritura de contraseña intenta cambiar la contraseña localmente y, a continuación, espera. Si la actualización local se realiza correctamente, la escritura de contraseña intenta cambiar la contraseña en Azure AD. Durante una operación de cambio de contraseña, la escritura de contraseña comprueba la contraseña actual y, a continuación, proporciona la nueva contraseña que se actualizará en el directorio respectivo.
Sin embargo, un problema de tiempo puede provocar esta advertencia si se produce un intento de iniciar sesión inmediatamente después de restablecer la contraseña de Active Directory local. Este problema se produce si el usuario debe cambiar la contraseña en la siguiente opción de inicio de sesión seleccionada y la autenticación de dominio está configurada para la autenticación de paso a través (PTA).
En este escenario, el usuario intenta iniciar sesión antes de que la sincronización de hash de contraseña termine de sincronizar la contraseña temporal con Azure AD. Pero como la PTA está configurada, la autenticación se redirige a Active Directory local. El usuario ahora puede iniciar sesión Azure AD correctamente y, a continuación, se ve obligado a cambiar la contraseña en el primer inicio de sesión. Si el cambio de contraseña se realiza correctamente, la escritura de contraseña actualiza la nueva contraseña en Active Directory local y en Azure AD. Sin embargo, el mensaje de inicio de sesión indica que "nuestros servidores se toman un poco de tiempo para ponerse al día". Esto se debe a que la contraseña temporal no coincide con la contraseña actual en Azure AD.
Solución
Después de que un administrador de Active Directory restablezca la contraseña local, Azure AD Conectar tarda al menos dos minutos en sincronizar esa contraseña temporal con Azure AD. Para evitar recibir este mensaje de advertencia, el usuario debe esperar al menos dos minutos para iniciar sesión y actualizar la contraseña. Esto proporciona tiempo para que la sincronización de hash de contraseña sincronice la contraseña temporal.