Error en diagnósticos de arranque de máquina virtual en Azure Portal: no se pudo obtener el contenido del registro

En este artículo se proporciona una solución a un problema en el que se produce el error "No se pudo obtener el contenido del registro" al ver una captura de pantalla de máquina virtual en la hoja Diagnósticos de arranque de la Azure Portal.

Versión original del producto: Máquina virtual que ejecuta Windows, máquina virtual que ejecuta Linux
Número de KB original: 4094480

Síntomas

Al intentar ver una captura de pantalla de máquina virtual en la hoja Diagnósticos de arranque de la Azure Portal, se produce un error y aparece la siguiente entrada registrada en el área de notificación:

No se pudo obtener el contenido del registro "<url> de registro" de la máquina virtual "/subscriptions/<SUBID>/resourceGroups/<RGNAME>/providers/Microsoft.Compute/virtualMachines/<VMNAME>". Mensaje de error: 'description: No se pudo completar la llamada RPC para el mensaje 'getExtendedInfoBlob': No se pudo completar la llamada RPC para la pila 'getExtendedInfoBlob': ###RPC_Exception### From RPC: Microsoft_Azure_Compute -> Microsoft_Azure_Storage (getExtendedInfoBlob) (La captura de Callstack no está habilitada. Use ?trace=diagnostics para habilitarlo). '

Causa

Este problema puede producirse por cualquiera de los siguientes motivos:

  • Virtual Machines que se ejecutan en Windows Server 2008 R2 o versiones anteriores no generan un informe de estado de máquina virtual. Por lo tanto, se espera que no se produzca ningún archivo SerialConsole.log en la cuenta de almacenamiento de Diagnósticos de arranque y verá el mensaje de error que se menciona en la sección "Síntomas". Para comprobar la versión del sistema operativo, abra una ventana del símbolo del sistema, escriba winver y presione Entrar. (Consulte la solución alternativa 1)

  • No se espera que las máquinas virtuales que tienen instalada una versión anterior del agente invitado de máquina virtual (anterior a la 2.7.1198.806) generen un informe de estado de máquina virtual. Por lo tanto, se espera que no se produzca ningún archivo SerialConsole.log en la cuenta de almacenamiento de Diagnósticos de arranque y verá el mensaje de error que se menciona en la sección "Síntomas". Para comprobar la versión del Agente invitado de máquina virtual, abra la C:\WindowsAzure\logs\WaAppAgent.log carpeta y, a continuación, busque lo siguiente:

    WindowsAzureGuestAgent a partir de . Versión 2.7.1198.802 (consulte la solución alternativa 2)

  • Es posible que se produzca un error en la generación automática del informe de mantenimiento de la máquina virtual por parte del agente invitado de la máquina virtual. Si esto ocurre, no se crea ningún archivo SerialConsole.log. Esto desencadena el mensaje de error que se menciona en la sección "Síntomas". Por ejemplo, este informe no se genera si hay SID sin resolver notificados como miembros en el grupo Administradores locales de la máquina virtual. Para buscar estos problemas, examine el C:\WindowsAzure\logs\TransparentInstaller.log archivo. (Consulte la solución alternativa 3)

Solución alternativa

Para solucionar este problema, pruebe los métodos siguientes.

Solución alternativa 1

Actualice el sistema operativo a una versión más reciente.

Solución alternativa 2

Actualice el agente invitado de máquina virtual mediante la instalación de la versión 2.7.1198.822.

Solución alternativa 3

Compruebe si el usuario asociado se eliminó del dominio.

También puede quitar los SID sin resolver (por ejemplo, S-1-5-21-XYZ-XYZ) del grupo Administradores locales.

Además, compruebe si tiene una directiva de dominio que bloquea el grupo Administradores locales o si se quitó la cuenta de administrador integrada (indicada por "0x80005004" en el registro del instalador transparente).

Solución alternativa 4

Si sospecha que un problema afecta al puerto serie en el host, puede intentar volver a implementar la máquina virtual para moverla a otro host.

Advertencia

Esta acción desencadena un reinicio de la máquina virtual.

Estado

Estamos trabajando en una solución a este problema. Nuestro objetivo es mejorar la detección de casos en los que no se genera el archivo SerialConsole.log y evitar que este error se vuelva demasiado intrusivo.

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