Error en el diagnóstico de arranque de VM en Azure Portal: no se pudo obtener el contenido del registro

En este artículo se proporciona una solución a un problema en el que se produce el error "no se pudo obtener el contenido del registro" cuando se ve una pantalla de máquina virtual capturada en la hoja de diagnóstico de arranque en el portal de Azure.

Versión del producto original:   Máquina virtual que ejecuta Windows, máquina virtual que ejecuta Linux
Número de KB original:   4094480

Síntomas

Cuando intenta ver una pantalla de máquina virtual capturada en la hoja de diagnósticos de arranque de Azure portal, se produce un error y ve la siguiente entrada registrada en el área de notificación:

No se pudo obtener el contenido del registro ' <log url> ' de la máquina virtual '/subscriptions/ <SUBID> /resourceGroups/ <RGNAME> /providers/Microsoft.Compute/virtualMachines/ <VMNAME> '. Mensaje de error: ' Descripción: no se pudo completar la llamada RPC para el mensaje ' getExtendedInfoBlob ': no se pudo completar la llamada RPC para la pila ' getExtendedInfoBlob ': # # #RPC_Exception# # # de rpc: Microsoft_Azure_Compute-> Microsoft_Azure_Storage (getExtendedInfoBlob) (la captura de la pila de llamadas no está habilitada. Use? Trace = Diagnostics para habilitarlo.) '

Causa

Este problema puede producirse por cualquiera de los siguientes motivos:

  • Las máquinas virtuales que se ejecutan en Windows Server 2008 R2 o versiones anteriores no producen un informe de mantenimiento de VM. Por lo tanto, se espera que no se genere ningún archivo SerialConsole. log en la cuenta de almacenamiento de diagnóstico de inicio y que vea el mensaje de error que se menciona en la sección "síntomas". Para comprobar la versión del sistema operativo, abra una ventana del símbolo del sistema, escriba winvery, a continuación, presione Entrar. (Consulte la solución 1)

  • Las máquinas virtuales que tienen instalada una versión anterior del agente invitado de VM (anterior a 2.7.1198.806) no tienen previsto generar un informe de mantenimiento de VM. Por lo tanto, se espera que no se genere ningún archivo SerialConsole. log en la cuenta de almacenamiento de diagnóstico de inicio y que vea el mensaje de error que se menciona en la sección "síntomas". Para comprobar la versión del agente invitado de la VM, abra la C:\WindowsAzure\logs\WaAppAgent.log carpeta y, a continuación, busque lo siguiente:

    Se inicia WindowsAzureGuestAgent. Versión 2.7.1198.802 (consulte la solución 2)

  • Es posible que se produzca un error en la generación automática del informe de mantenimiento de VM por parte del agente invitado de VM. Si esto ocurre, no se crea el archivo SerialConsole. log. Este es el mensaje de error que se menciona en la sección "síntomas". Por ejemplo, este informe no se genera si hay SID sin resolver notificados como miembros en el grupo de administradores locales de la máquina virtual.Para buscar estos problemas, examine el C:\WindowsAzure\logs\TransparentInstaller.log archivo. (Consulte la solución 3)

Solución alternativa

Para solucionar este problema, pruebe los métodos siguientes.

Solución alternativa 1

Actualice el sistema operativo a una versión más reciente.

Solución 2

Actualice el agente invitado de VM mediante la instalación de la versión 2.7.1198.822.

Solución 3

Compruebe si el usuario asociado se ha eliminado del dominio.

También puede quitar los SID sin resolver (por ejemplo, S-1-5-21-XYZ-XYZ) del grupo de administradores locales.

Compruebe también si tiene una directiva de dominio que bloquea el grupo de administradores locales o si se ha quitado la cuenta de administrador integrada (indicada por "0x80005004" en el registro de la instalación transparente).

Solución 4

Si sospecha que un problema afecta al puerto serie en el host, puede intentar volver a implementar la máquina virtual para moverla a un host diferente.

Advertencia

Esta acción desencadena el reinicio de la máquina virtual.

Estado

Estamos trabajando en una solución para este problema. Nuestro objetivo es mejorar la detección de casos en los que no se genera el archivo SerialConsole. log y para evitar que este error se convierta en demasiado intrusivo.