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Activación de Windows: id. de equipo cliente duplicado

Por lo general, se recomienda usar servidores de Azure Key Management Services (KMS) para activar máquinas virtuales (VM) Windows de Azure, incluso cuando Ventaja híbrida de Azure esté habilitado. Sin embargo, en casos específicos, dado que las restricciones de red pueden impedir que las máquinas virtuales se comuniquen con los servidores de KMS de Azure, puede usar un servidor KMS autohospedado para la activación. En este artículo se describe un problema de identificador de máquina cliente duplicado que se produce cuando se usa un servidor KMS autohospedado para la activación de Windows y se proporciona una solución.

Nota:

Este artículo solo se aplica cuando se usa un servidor KMS autohospedado para la activación. No se aplica cuando se usa Azure KMS para la activación.

Síntomas

Cuando se usa un servidor KMS autohospedado para la activación e intenta activar más de una máquina virtual con Windows Server, se produce un error en la activación después del período de evaluación y el servidor KMS autohospedado notifica el siguiente error en el Informe de identificadores de máquina de cliente duplicados:

El informe de id. de máquina de cliente duplicado ayuda a identificar las máquinas del entorno que ejecutan imágenes que no se generalizaron correctamente mediante la herramienta Sysprep antes de la implementación.
Note:
- KMS contará varios clientes de activación por volumen con el mismo CMID como un único cliente. Si esto hace que el número de clientes de KMS se quede por debajo del umbral mínimo, se producirá un error en la activación de KMS en su entorno.

Causa

  • El identificador de máquina cliente (CMID) se borra durante el proceso sysprep de la imagen de origen original. Sin embargo, si el proceso sysprep se desencadena con el parámetro SkipRearm establecido en 1 en lugar del valor predeterminado de 0, no se borrará el CMID. En este caso, todas las máquinas virtuales creadas a partir de esta imagen tendrán el mismo CMID.

  • Al crear máquinas virtuales a partir de Azure Marketplace, Azure Marketplace imágenes para Windows Server se han generalizado con el parámetro SkipRearm establecido en 1. Por lo tanto, las máquinas virtuales creadas a partir de la misma imagen de Windows Server tendrán el mismo CMID.

Confirmación de un CMID duplicado

Compruebe si las máquinas virtuales tienen el mismo CMID en función de la imagen de origen y la versión:

  1. Ejecute el siguiente comando en las máquinas virtuales problemáticas:

    cscript C:\Windows\System32\slmgr.vbs /dlv
    

    Este es un ejemplo de salida de comandos:

    Most recent activation information:
    Key Management Service client information
        Client Machine ID (CMID): <client-machine-ID>
        Registered KMS machine name: <KMS-machine-name>
    
  2. Compare las salidas del comando en las máquinas virtuales problemáticas y confirme si las máquinas virtuales tienen el mismo CMID.

Solución

  • En el caso de las máquinas virtuales problemáticas creadas a partir de una imagen personalizada, generalice o sysprep la máquina virtual original con el parámetro SkipRearm establecido en 0 para asegurarse de que el CMID se borra de la imagen.

  • Para las máquinas virtuales problemáticas que ya están implementadas, siga estos pasos:

    1. Ejecute el slmgr /rearm comando desde un símbolo del sistema con privilegios elevados.

    2. Reinicie la VM.

    3. Una vez que la máquina virtual esté en línea después del reinicio, ejecute el siguiente comando para confirmar que se ha cambiado el CMID:

      cscript C:\Windows\System32\slmgr.vbs /dlv
      
    4. Vuelva a desencadenar la activación.

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