La revisión de .NET Framework error con un error: se deniega el acceso o el archivo en uso
Este artículo le ayuda a resolver el problema en el que Microsoft .NET Framework errores de revisión cuando los ensamblados están en uso o bloqueados cuando se aplica una revisión.
Versión del producto original: .NET Framework
Número KB original: 2263996
Síntomas
Si un archivo de ensamblado de la caché global de acceso (GAC) se ha bloqueado o está en uso, puede provocar un error .NET Framework revisiones. Este problema puede agravarse por un error en la forma en que fusion controla la reversión y puede hacer que se eliminen los archivos. Esto dará como resultado que las aplicaciones administradas (aquellas aplicaciones que dependen de ensamblados de marco) no se puedan usar.
El registro MSI Verbose de revisión con error puede contener algo como esto:
'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\system.dll' debido a un error del sistema:Se deniega el acceso.
06/22/10 11:57:26 DDSet_Status: Dormir 100 ms...
MSI (s) (54!70) [11:57:26:738]: Producto: Microsoft .NET Framework 2.0 Service Pack 2 -- Hay un problema con este paquete de instalador de Windows.
Consulte el registro de instalación para obtener más información.
Hay un problema con este paquete Windows Installer.
Consulte el registro de instalación para obtener más información.
06/22/10 11:57:26 DDSet_CARetVal: 0
06/22/10 11:57:26 DDSet_Exit: InstallAssembly finalizó con el valor devuelto 1603
MSI (s) (54:94) [11:57:26:758]: El valor de directiva de usuario "DisableRollback" es 0
MSI (s) (54:94) [11:57:26:758]: El valor de directiva de máquina "DisableRollback" es 0
La acción finalizó 11:57:26: InstallExecute. Valor devuelto 3.
O bien:
02/22/10 08:38:32 DDSet_Status: 100 ms de sueño...
02/22/10 08:38:32 DDSet_Error: Error al instalar el ensamblado
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.EnterpriseServices.dll. IAssemblyCache->InstallAssembly() devuelto -2147024864.
02/22/10 08:38:32 DDSet_Error: Error al instalar el ensamblado
'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.EnterpriseServices.dll' debido a un error del sistema:
El proceso no puede tener acceso al archivo porque otro proceso lo está utilizando.
Causa
Si los ensamblados están en uso o bloqueados cuando se aplica una revisión, se producirá un error en la revisión.
Solución
Este problema se puede evitar garantizando que no se estén ejecutando procesos que puedan poner un bloqueo en los ensamblados.
Para detectar si se usan ensamblados, siga estos pasos:
Descargue procexp.exe para detectar los procesos que bloquean ensamblados.
Inicie procexp.exe y, a continuación, presione Ctrl+F para abrir la ventana Búsqueda del Explorador de procesos.
En el cuadro de texto Controlar o subcadena DLL, escriba Ensamblado y, a continuación, seleccione Buscar.
Todos los archivos enumerados podrían tener un impacto en la instalación de la revisión. Finalice todos los procesos enumerados o cierre las aplicaciones asociadas. Para ello, siga estos pasos:
Seleccione el nombre del proceso que desea finalizar en la ventana Búsqueda del Explorador de procesos para buscar el proceso.
Haga clic con el botón secundario en el nombre del proceso en el panel Proceso.
Seleccione Eliminar proceso para finalizar el proceso.