Las aplicaciones hospedadas en el explorador wpf (XBAP) pueden bloquearse durante la puesta en marcha

Este artículo le ayuda a resolver el problema en el que los XBAP de WPF pueden bloquearse durante la puesta en marcha.

Versión del producto original:   Microsoft .NET Framework 3.5 Service Pack 1
Número KB original:   972928

Síntoma

Los XBAP de WPF pueden bloquearse durante la puesta en marcha.

Causa

Una causa de este problema es que los registros de la interfaz de nivel del sistema están rotos. En particular, pueden faltar registros para las interfaces siguientes:

  • IID_IWebBrowser2
  • IID_IShellBrowser

Esto puede deberse a instalaciones o actualizaciones con errores, o a infecciones de malware.

Solución

Vuelva a registrar las interfaces rotas ejecutando los siguientes comandos:

regsvr32 %SystemRoot%\System32\actxprxy.dll
regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"

En el Windows de 64 bits, ejecute también los siguientes comandos:

regsvr32 %SystemRoot%\SysWOW64\actxprxy.dll
regsvr32 "%ProgramFiles(x86)%\Internet Explorer\ieproxy.dll"

En Windows XP y Windows Server 2003, estos comandos deben ejecutarse desde una cuenta de usuario con privilegios administrativos en el equipo.

En Windows Vista o posterior, estos comandos deben ejecutarse con privilegios elevados. Seleccione Iniciar todos los accesorios > de > programas. Haga clic con el botón secundario en Símbolo del sistema y seleccione Ejecutar como administrador. En el símbolo del sistema, ejecute los comandos.

Compruebe si se ha solucionado el problema. Si el problema se ha corregido, terminaste con esta sección. Si el problema no se soluciona, puede ponerse en contacto con el soporte técnico.