bloqueos del Visor de ayuda 2.0 de Visual Studio 2012

Este artículo le ayuda a resolver el problema de bloqueo del Visor de ayuda de Microsoft Visual Studio 2012.

Versión original del producto:   Visual Studio Premium 2012
Número de KB original:   2879007

Síntomas

Al iniciar la Ayuda en Visual Studio 2012 presionando F1 o eligiendo Ver Ayuda (CTRL+F1) en el menú Ayuda de la barra de herramientas estándar, puede encontrar un problema en el que se mostrará uno de los siguientes mensajes:

  • Mensaje de error 1

    CLR_EXCEPTION_System.IO.FileNotFoundException

  • Mensaje de error 2

    Windows no encuentra HlpViewer.exe. Asegúrese de escribir el nombre correctamente e inténtelo de nuevo.

Causa

Falta o daña el Visor de ayuda 2.0 o uno de sus componentes.

Solución

Para resolver este problema, debe cerrar todas las instancias de Visual Studio 2010, abrir el applet Programa y características del Panel de control, seleccionar la instancia instalada de Visual Studio 2012, seleccionar Cambiar y continuar con la opción Reparar.

Restablecer preferencias personales

Es posible que tenga que restablecer sus preferencias personales en el cuadro de diálogo HerramientasOpciones > , ya que reparar una aplicación sobrescribe esa configuración. Se recomienda conservar la configuración antes de continuar con la reparación. En el menú principal, seleccione Herramientas y, a continuación, seleccione Importar y exportar Configuración.