Error HTTP 403: error prohibido o HTTP 404: archivo no encontrado

Este artículo le ayuda a resolver los errores (error HTTP 403 y 404) que se producen al tener acceso a WebView o WebPort.

Versión del producto original:   Microsoft FRx WebPort
Número KB original:   965174

Síntomas

Los siguientes errores se producen al obtener acceso a FRx WebView o WebPort.

No está autorizado a ver esta página (error HTTP 403 - Prohibido)

O bien:

No se puede encontrar la página (error HTTP 404: archivo no encontrado)

Estos errores se producen al obtener acceso a WebView o WebPort.

Causa

El documento predeterminado (default.asp) en el directorio virtual WebPort dentro de Internet Information Services (IIS) se establece incorrectamente o falta en el directorio WebPort.

Solución

En el servidor web, compruebe la configuración predeterminada del documento.

  1. Abra el Administrador de IIS (Internet Information Services).
  2. Haga clic con el botón secundario en el directorio virtual WebPort y seleccione Propiedades.
  3. Haga clic en la pestaña Documentos.
  4. Seleccione cada documento y seleccione el botón Quitar.
  5. Seleccione el botón Agregar.
  6. Escriba Default.asp y seleccione Aceptar.
  7. Seleccione Aceptar de nuevo para volver a la pantalla principal de la consola de IIS.
  8. Ahora debería tener acceso al sitio WebPort.

Compruebe que el documento default.asp existe en el directorio WebPort del servidor. Si falta ese archivo, póngase en contacto con el proveedor de soporte técnico de FRx para recibir una nueva copia.

  • Si la instalación de WebPort no tiene aplicado el service pack FRx más reciente, aplique el service pack. Asegúrese de detener el servicio web y el proceso FRxPDFSvr antes de aplicar el service pack.

  • Si WebPort está instalado en un servidor Windows, compruebe que las páginas ASP están habilitadas en el servidor. A menos que esté seleccionado manualmente durante la instalación de Windows Server, páginas Active Server funcionalidad no estará disponible en el servidor.

Compruebe que las asignaciones de aplicaciones para las extensiones .asp y .asa están asignadas a asp.dll.

  1. Abra la consola de IIS (Administrador de Servicios de Internet).
  2. Haga clic con el botón secundario en el directorio virtual WebPort y seleccione Propiedades.
  3. Seleccione la pestaña Directorio virtual.
  4. Seleccione el botón Configuración en la sección Configuración aplicación.
  5. En la pestaña Asignaciones de la ventana Configuración de la aplicación, compruebe que las extensiones .asa y .asp están asignadas aasp.dll. Si no lo son, corrija la asignación.
  6. Seleccione Aceptar.