Se produce un error en CrmSecurity al intentar aprobar la dirección de correo electrónico de un registro de buzón en Microsoft Dynamics 365

En este artículo se proporciona una solución a un error que se produce al seleccionar el botón Aprobar Email en un registro de buzón en Microsoft Dynamics 365.

Se aplica a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4510938

Síntomas

Al seleccionar el botón Aprobar Email en un registro de buzón de correo, recibirá el siguiente error:

"Error
Error en CrmSecurity. Si se pone en contacto con el soporte técnico, proporcione los detalles técnicos."

Causa

Este error se produce si intenta aprobar el correo electrónico como un usuario que no tiene los dos roles necesarios siguientes:

  • Administrador global o administrador de Exchange en Office 365
  • Rol de seguridad administrador del sistema en Dynamics 365

Solución

De forma predeterminada, Dynamics 365 requiere que alguien que tenga los dos roles necesarios mencionados en la sección Causa realice la aprobación de una dirección de correo electrónico en Dynamics 365. El rol Administrador del sistema en Dynamics 365 o el rol de administrador de servicio Dynamics 365 en Office 365 no son suficientes para realizar esta acción. Para obtener más información, incluido cómo se puede deshabilitar este requisito, vea Cambios en la aprobación del buzón en Dynamics 365.

Más información

Si selecciona el botón Descargar archivo de registro , verá detalles como el ejemplo siguiente:

"Excepción no controlada: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=9.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.Web.HttpUnhandledException (0x80004005): Se produjo la excepción del tipo "System.Web.HttpUnhandledException". >--- Microsoft.Crm.CrmException: el correo electrónico example@contoso.com Queue: a5efd992-dbc6-48af-ad61-09e0258edb68 no coincide con UPN. El usuario 39ff663e-a75a-e811-a986-000d3a3672b5 debe ser un administrador global para aprobar el buzón en la <organización>.
at Microsoft.Crm.Dialogs.ApproveEmailAddressDialogPage.ConfigureForm()
at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
at Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e)
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(Contexto HttpContext)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously): Microsoft Dynamics CRM ha experimentado un error. Número de referencia para administradores o soporte técnico: #3A5E4FEADetail:
<OrganizationServiceFault xmlns:i="https://www.w3.org/2001/XMLSchema-instance" xmlns="https://schemas.microsoft.com/xrm/2011/Contracts">
<Id><. de ActivityId></ActivityId
<ErrorCode> **-2147220970** </ErrorCode>
<ErrorDetails xmlns:d2p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic" />
<Message>System.Web.HttpUnhandledException (0x80004005): se produjo la excepción del tipo "System.Web.HttpUnhandledException". >--- Microsoft.Crm.CrmException: **El correo electrónico example@contoso.com queue: a5efd992-dbc6-48af-ad61-09e0258edb68 no coincide con UPN. El usuario 39ff663e-a75a-e811-a986-000d3a3672b5 debe ser un administrador global para aprobar el buzón en la organización<>**.
at Microsoft.Crm.Dialogs.ApproveEmailAddressDialogPage.ConfigureForm()
at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
at Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e)
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(Contexto HttpContext)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously): Microsoft Dynamics CRM ha experimentado un error. Número de referencia para administradores o soporte técnico: #3A5E4FEA
<Marca de tiempo>2018-12-04T18:17:41.8971683Z</Timestamp
<ExceptionRetriable>false
<ExceptionSource i:nil="true" />
<InnerFault>
<Id><. de ActivityId></ActivityId
<ErrorCode> **-2147220906** </ErrorCode><ErrorDetails xmlns:d3p1="https://schemas.datacontract.org/2004/07/System.Collections.Generic" />
<Mensaje>La cola: el correo electrónico testdl@MyContosoDemo.onmicrosoft.com a5efd992-dbc6-48af-ad61-09e0258edb68 no coincide con UPN. El usuario 39ff663e-a75a-e811-a986-000d3a3672b5 debe ser un administrador global para aprobar el buzón en la <organización>.</Mensaje>
<Marca de tiempo>2018-12-04T18:17:41.8981705Z</Timestamp
<ExceptionRetriable>false</ExceptionRetriable>
<ExceptionSource i:nil="true" />
<InnerFault i:nil="true" />
<OriginalException i:nil="true" />
<TraceText i:nil="true" />
</InnerFault>
<OriginalException i:nil="true" />
<TraceText i:nil="true" />
</OrganizationServiceFault>"