No se puede autenticar el error de credenciales al configurar el Microsoft Dynamics CRM para el cliente de Outlook 2011

En este artículo se proporciona una solución para el problema de que no se puede configurar Microsoft Dynamics CRM para Microsoft Office Outlook mediante el Asistente para configuración debido al error No se puede conectar Microsoft Dynamics CRM un servidor porque no se pueden autenticar las credenciales.

Se aplica a:   Cliente Microsoft CRM para Microsoft Office Outlook, Microsoft Dynamics CRM 2011, Microsoft Business Solutions CRM Sales for Outlook
Número KB original:   2682528

Síntomas

Al intentar configurar Microsoft Dynamics CRM outlook mediante el Asistente para configuración, recibe el siguiente error:

No se puede conectar Microsoft Dynamics CRM servidor porque no podemos autenticar sus credenciales. Compruebe la conexión o póngase en contacto con el administrador para obtener más ayuda.

En el registro de configuración de Microsoft Dynamics CRM, (ubicación predeterminada: C:\Users \ <username> \AppData\Local\Microsoft\MSCRM\Logs\Crm50ClientConfig.log), verá un error similar al siguiente:

Error| Error al conectarse a la dirección URL: https://dev.crm.dynamics.com/XRMServices/2011/Discovery.svc
Excepción: Microsoft.Crm.Passport.IdCrl.IdCrlException: InitializeEx()
en Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.Initialize(String environment)
en Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.. ctor(Entorno de cadena)
en Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider ` 1.GetLogonManager()
en Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider ` 1.SignIn()
en Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory ` 1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
en Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credential credentials)
en Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)

Causa

Windows Live ID el servicio asistente de inicio de sesión no se está ejecutando.

Solución

Inicie o reinicie el asistente Windows Live ID Sign-In.

  1. Seleccione el botón De Windows y en Programas de búsqueda y archivos escriba Services.msc.

  2. Busque Windows Live ID asistente de inicio de sesión y compruebe que el tipo de inicio está establecido en Automático.

  3. Si el tipo de inicio no está establecido en Automático, haga lo siguiente:

    1. Haga doble clic en Windows Live ID Asistente para inicio de sesión.
    2. Cambie el tipo de inicio a Automático.
    3. Seleccione Inicio.
    4. Elija Aceptar.
  4. Si el tipo de inicio está establecido en Automático, compruebe que el estado está establecido en Iniciado. Si el estado no está establecido en Iniciado, haga lo siguiente:

    1. Seleccione el Windows Live ID de inicio de sesión.
    2. Haga clic con el botón secundario en él y vaya a Inicio.
  5. Si el tipo de inicio está establecido en Automático y el estado está establecido en Iniciado, haga lo siguiente:

    1. Seleccione el Windows Live ID de inicio de sesión.
    2. Haga clic con el botón secundario en él y vaya a Reiniciar.

Si experimenta algún error al intentar iniciar el Asistente para Windows Live ID inicio de sesión, intente desinstalar y reinstalar el servicio:

  1. Apunte al menú Inicio, seleccione Panel de control y seleccione Programas y características.
  2. Busque y haga clic con el botón secundario en Windows Live ID asistente de inicio de sesión. Seleccione desinstalar.
  3. Reinstale Windows Live ID de inicio de sesión.