No se puede conectar Microsoft Dynamics CRM servidor porque no se pueden autenticar las credenciales

En este artículo se proporciona una solución a un error que se produce al intentar configurar el cliente de Microsoft Dynamics CRM para Outlook con una organización de Dynamics CRM Online.

Se aplica a:   Microsoft Dynamics CRM
Número KB original:   2666080

Síntomas

Al intentar configurar el cliente Microsoft Dynamics CRM para Outlook con una organización de Dynamics CRM Online, se produce el siguiente error:

"No se puede conectar Microsoft Dynamics CRM servidor porque no podemos autenticar sus credenciales. Compruebe la conexión o póngase en contacto con el administrador para obtener más ayuda".

En el registro de configuración, se muestra el siguiente error:

Error| Error al conectarse a la dirección https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc URL: Excepción: Microsoft.Crm.CrmException: Error de inicio de sesión porque las credenciales no son válidas --->
Microsoft.Crm.Passport.IdCrl.IdCrlException: GetAuthState() - Estado de la solicitud:
en Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.LogonOrgId(String policy, String partner, LOGON_FLAG logonFlag)
en Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.Logon(String userName, String password, String partner, String policy, String& memberName)
en Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider ` 1.SignIn()
--- de seguimiento de la pila de excepciones ---
en Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory ` 1.RetrieveUserCredentialsAndSignIn(Uri endPoint, Credential credentials, Form parentWindow, Boolean retryOnError, IClientOrganizationContext context)
en Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory ` 1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
en Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credential credentials)
en Microsoft.Crm.Application.Outlook.Config. DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)

Causa

La causa de este problema se debe a que no se Windows Live ID verificación. Cuando se registra en un Windows Live ID y no usa una o una dirección de correo electrónico, deberá comprobar la dirección de correo electrónico antes de que se pueda usar para configurar el cliente de @outlook.com @live.com Microsoft Dynamics CRM para Outlook.

Solución

Después de crear su Windows Live ID, se envía un correo electrónico a la dirección de correo electrónico que creó como su Windows Live ID. Deberá iniciar sesión en esa cuenta de correo electrónico y seleccionar el vínculo del correo electrónico para comprobar la dirección de correo electrónico. Una vez completado, puede continuar con la configuración del Microsoft Dynamics CRM cliente para Outlook.