Hay un problema al comunicarse con el mensaje de error Microsoft Dynamics CRM servidor que se muestra al configurar el cliente de Microsoft Dynamics CRM para Outlook
En este artículo se proporciona una solución a un error que se produce al configurar el cliente de Microsoft Dynamics CRM para Outlook.
Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2834554
Síntomas
Cuando intenta configurar el cliente de Microsoft Dynamics CRM para Microsoft Office Outlook, recibe el siguiente mensaje de error:
Hay un problema al comunicarse con el servidor de Microsoft Dynamics CRM. Es posible que el servidor no esté disponible. Inténtelo de nuevo más tarde. Si el problema persiste, póngase en contacto con el administrador del sistema.
Error en el archivo Crm50ClientConfig.log:
Error| Excepción: se ha producido un error. Vuelva a intentar esta acción. Si el problema continúa, compruebe la comunidad de Microsoft Dynamics CRM para obtener soluciones o póngase en contacto con el administrador de Microsoft Dynamics CRM de la organización. Por último, puede ponerse en contacto con Soporte técnico de Microsoft. at Microsoft.Crm.MapiStore.DataStore.WaitInitialized()
en Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.InitializeMapiStoreForFirstTime()
en Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
en Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(Object stateInfo)
Error| Excepción: el servidor no pudo procesar la solicitud.
Causa
Este error puede producirse si intenta configurar el cliente de Microsoft Dynamics CRM para Outlook en un servidor de Microsoft Dynamics CRM que tiene una entrada incorrecta en la tabla ConfigSettings de la base de datos MSCRM_Config para la columna HelpServerUrl.
Resolución
Actualizar la configuración helpServerUrl a una dirección HTTP válida
Abra SQL Server Management Studio y conéctese a la instancia que hospeda Microsoft Dynamics CRM 2011.
Seleccione nueva consulta y ejecute una instrucción select para comprobar la configuración HelpServerUrl de la base de datos de MSCRM_Config para la tabla configsettings:
Use MSCRM_CONFIG go select HelpServerUrl from configsettings
Si los resultados no están en un formato HTTP, realice una copia de seguridad de la base de datos MSCRM_config y actualice la configuración con una consulta como la siguiente:
Use MSCRM_Config go update ConfigSettings set HelpServerUrl = 'https://<crmserver>/'