No podemos conectarnos al error de servidor de Microsoft Dynamics 365 al usar Microsoft Dynamics 365 App para Outlook

En este artículo se proporciona una resolución del problema por el que no puede usar Microsoft Dynamics 365 App para Outlook debido al error We're unable to connect to your Microsoft Dynamics 365 server (No podemos conectarnos al servidor de Microsoft Dynamics 365).

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4341413

Síntomas

Al intentar usar microsoft Dynamics 365 App para Outlook, recibe el siguiente mensaje:

"No podemos conectarnos al servidor de Microsoft Dynamics 365. Intente cerrar y volver a abrir la aplicación".

Si selecciona Mostrar más, puede ver el siguiente mensaje:

"Tiempo de espera del cargador de cliente"

Si usa la aplicación en Outlook Web Access (OWA), es posible que vea que aparece el siguiente mensaje en la parte inferior de la pantalla:

"¿Desea permitir el dynamics.com uso de almacenamiento adicional en el equipo?"

Si borra la caché del explorador Internet Explorer, este error puede parecer que se resuelve, pero finalmente se devuelve.

Causa

Microsoft es consciente de un problema en el que este error puede producirse porque Internet Explorer está configurado para limitar la cantidad de datos que se pueden almacenar en caché. Si está viendo la aplicación mediante Internet Explorer, esta puede ser la causa del error. Si encuentra este error con Outlook Desktop, Outlook siempre usa Internet Explorer para mostrar la aplicación.

Solución

Microsoft está trabajando en un cambio para evitar este problema. Mientras tanto, puede usar los pasos siguientes como una posible solución alternativa:

Opción 1: aumentar el límite de base de datos en las opciones de Internet Explorer

En función de la versión del sistema operativo, es posible que pueda cambiar el límite dentro de la configuración de Internet Explorer. Si usa Windows 10, esta opción no aparece y puede usar la opción 2 en su lugar.

  1. Abra Internet Explorer.
  2. En la esquina superior derecha, seleccione el icono de engranaje y, a continuación, seleccione Opciones de Internet.
  3. En la pestaña General de la sección Historial de exploración , seleccione Configuración.
  4. Seleccione la pestaña Cachés y bases de datos .
  5. Si ve una opción Notificarme cuando una base de datos o caché del sitio web supera , cambie el valor a 200 y seleccione Aceptar. Como alternativa, puede seleccionar dynamics.com en la lista de sitios web y, a continuación, seleccionar Superar límite. Si estas opciones no aparecen, continúe con la opción 2.
  6. Borre el historial y la memoria caché de Internet Explorer. Para obtener pasos detallados, consulte Ver y eliminar el historial de exploración en Internet Explorer.

Opción 2: aumentar el límite de base de datos dentro del registro

Importante

Esta sección contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Para aumentar el límite de almacenamiento en caché permitido, cree la siguiente entrada del Registro:

Subclave: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
Nombre: MaxTrustedDomainLimitInMB
Tipo: REG_DWORD
Datos: 200

Para crear esta entrada del Registro, siga estos pasos:

  1. Seleccione Inicio, haga clic en Ejecutar, escriba regedit, y luego seleccione Aceptar.

  2. Busque y seleccione la siguiente subclave del Registro. Si la ruta de acceso a esta ubicación no existe, es posible que tenga que crear las claves mencionadas:

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue

  3. Haga clic con el botón derecho en IndexedDBValue, seleccione Nuevo y, a continuación, seleccione Valor DWORD.

  4. En el cuadro Nuevo valor n.º 1 , escriba MaxTrustedDomainLimitInMB y presione Entrar.

  5. Haga clic con el botón derecho en MaxTrustedDomainLimitInMB y, a continuación, seleccione Modificar.

  6. Seleccione Decimal, escriba 200 y, a continuación, seleccione Aceptar.

  7. Salga del registro Editor y reinicie el equipo.

  8. Borre el historial y la memoria caché de Internet Explorer. Para obtener pasos detallados, consulte Ver y eliminar el historial de exploración en Internet Explorer.

Más información

Hay varias causas posibles para este error. Si esto no resuelve el problema, consulte el artículo siguiente para obtener soluciones posibles adicionales:

Error "No se puede conectar al servidor de Microsoft Dynamics 365" al usar Dynamics 365 App para Outlook