Error "No tiene una licencia" al configurar Microsoft Dynamics CRM para Microsoft Office Outlook

En este artículo se proporciona una resolución para que no tenga una licencia para usar Microsoft Dynamics CRM Online error que puede producirse al configurar Microsoft Dynamics CRM para Microsoft Office Outlook.

Se aplica a:   Microsoft Dynamics CRM
Número KB original:   3091628

Síntomas

Al intentar configurar Microsoft Dynamics CRM para Microsoft Office Outlook, recibe el siguiente mensaje de error:

No tiene una licencia para usar Microsoft Dynamics CRM Online. Póngase en contacto con el administrador de Office 365 para asignarle Microsoft Dynamics CRM licencia.

Causa

No se ha asignado una licencia Microsoft Dynamics CRM Online usuario a su cuenta de usuario.

Nota

Si tiene una suscripción existente de Office 365 y posteriormente agregó una suscripción Microsoft Dynamics CRM Online, no se asignará automáticamente una licencia de Microsoft Dynamics CRM Online al registro de usuario. Si su cuenta de usuario tiene el rol Administrador global o Administrador de servicios, todavía puede iniciar sesión en la aplicación web de Microsoft Dynamics CRM para realizar acciones administrativas, pero no puede crear registros como Cuentas, Contactos, Clientes potenciales, entre otros. Debe tener asignada una licencia Microsoft Dynamics CRM Online para conectarse correctamente Microsoft Dynamics CRM para Microsoft Office Outlook a la instancia Microsoft Dynamics CRM Online usuario. Dentro de la Microsoft Dynamics CRM Online web, puede navegar a Configuración Usuarios de seguridad y > > cambiar la vista a Usuarios de acceso administrativo. En esta vista se muestran los usuarios que tienen roles administrativos en el portal de Office 365 pero que no tienen asignada Microsoft Dynamics CRM Online licencia.

Solución

Inicie sesión en Office 365 Portal como un usuario con privilegios administrativos y asigne una Microsoft Dynamics CRM Online a su cuenta de usuario. Puede tardar unos minutos antes de que la información de licencia se sincronice de Office 365 a Microsoft Dynamics CRM Online.

Para obtener instrucciones detalladas sobre cómo asignar una licencia en Office 365, vea Agregar usuarios y asignar licencias al mismo tiempo.

Más información

Al seleccionar Detalles en el cuadro de diálogo de error o si ve el archivo de registro, se muestra el siguiente error:

Tiempo| Error| Excepción: al usuario no se le ha asignado ninguna licencia en Microsoft.Crm.Application.Outlook.Config. ServerInfo.RunServerDiagnostics()
en Microsoft.Crm.Application.Outlook.Config. ServerInfo.LoadUserInfo(IClientAuthProvider ` 1 orgAuthProvider)
en Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary, IClientAuthProvider ` 1 authenticatedProvider)
en Microsoft.Crm.Application.Outlook.Config. ServerForm.LoadDataToServerInfo()
en Microsoft.Crm.Application.Outlook.Config. ServerForm. <InitializeBackgroundWorkers> b__3(Remitente de objetos, DoWorkEventArgs e)
en System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
en System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argumento)