Error al cambiar la identidad de un grupo de aplicaciones mediante el Administrador de IIS desde un equipo remoto: Keyset no existe

Este artículo le ayuda a resolver un error (keyset no existe) que se produce cuando se cambia la identidad de un grupo de aplicaciones mediante el uso del Administrador de Microsoft Internet Information Services (IIS) desde un equipo remoto.

Versión original del producto:   Windows Server 2008, Windows Server 2008 R2
Número KB original:   977754

Síntomas

Imagine la siguiente situación:

  • En un servidor que ejecuta Windows Server 2008 o Windows Server 2008 R2, se habilita la administración remota para IIS.
  • El servidor tiene más de un grupo de aplicaciones configurado en IIS.
  • Uno de los grupos de aplicaciones está configurado para usar la identidad de usuario personalizada.
  • El Administrador de IIS se usa para conectarse al servidor como administrador desde un equipo remoto.

En este escenario, cuando intenta cambiar la identidad de cualquier grupo de aplicaciones, recibe el siguiente mensaje de error:

Se produjo un error al realizar esta operación.
Detalles:
Keyset no existe (excepción de HRESULT: 0x80090016)

Causa

La cuenta DE SERVICIO LOCAL es la cuenta de servicio del Servicio de administración web de IIS (también conocido como WMSvc). Este problema se produce porque la cuenta DE SERVICIO LOCAL no tiene acceso de lectura en la clave que se encuentra en la iisWasKey %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys carpeta.

A continuación se muestra el nombre de archivo de la iisWasKey clave:
76944fb33636aeddb9590521c2e8815a_GUID

Solución

Para resolver este problema, siga estos pasos:

  1. Busque la %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys carpeta.
  2. Haga clic con el botón secundario en 76944fb33636aeddb9590521c2e8815a_GUID archivo y, a continuación, seleccione Propiedades.
  3. Seleccione la pestaña Seguridad y, a continuación, seleccione Editar. Si se le pregunta si desea continuar la operación, seleccione Continuar. A continuación, la lista de nombres de grupo y nombres de usuario que tienen acceso a este archivo de clave aparece en el cuadro de diálogo Permisos.
  4. Seleccione Agregar. A continuación, aparece el cuadro de diálogo Seleccionar usuarios, equipos, cuentas de servicio o grupos.
  5. Escriba SERVICIO LOCAL y, a continuación, seleccione Comprobar nombres.
  6. Seleccione Aceptar.
  7. En la lista Nombres de usuario o grupo, seleccione SERVICIO LOCAL. Asegúrese de que la casilla De lectura esté activada en la lista Permisos para SERVICIO LOCAL.
  8. Seleccione Aceptar.

Más información

This problem is fixed in Windows Server 2008 Service Pack 2.