Configuration Manager clientes no reciben actualizaciones de software

En este artículo se corrige un problema en el que los clientes de Configuration Manager no pueden obtener actualizaciones desde el punto de actualización de software.

Versión original del producto: Configuration Manager (rama actual, versión 1702)
Número de KB original: 4041012

Síntoma

Después de instalar Configuration Manager rama actual, versión 1702, es posible que vea los síntomas siguientes:

  • Los clientes recién instalados no pueden obtener actualizaciones desde el punto de actualización de software. Esto también puede ocurrir si el punto de actualización de software se mueve a un servidor diferente después de la instalación de la versión 1702. Con el registro de cliente detallado habilitado, el archivo LocationServices.log contiene un valor vacío para la WSUSLocationReply entrada.
  • Algunos equipos se muestran en la consola como Estado desconocido.

Causa

A partir de Configuration Manager rama actual, versión 1702, los clientes usan grupos de límites para buscar un nuevo punto de actualización de software y para reservarse y encontrar un nuevo punto de actualización de software si ya no se puede acceder a su actual. Si instala un nuevo sitio que ejecuta la versión 1702 o posterior, debe asignar puntos de actualización de software a un grupo de límites para que los clientes puedan encontrarlos y usarlos.

Solución

Agregue el servidor que ejecuta el punto de actualización de software al grupo de límites de sitio predeterminado para los clientes. Puede agregar puntos de actualización de software individuales a distintos grupos de límites para controlar qué servidores puede encontrar un cliente. Para obtener más información, consulte puntos de actualización de software.

Para agregar el punto de actualización de software al grupo de límites, siga estos pasos:

  1. Cree un grupo de límites si no existe ninguno y agregue todas las máquinas cliente al grupo de límites con el punto de actualización de software como servidor de sitio.
  2. Ejecute el ciclo de evaluación & recuperación de directivas de máquina en el Configuration Manager.
  3. Compruebe el LocationServices.log en un equipo cliente para confirmar que el cliente puede conectarse al servidor de Windows Server Update Services (WSUS).

Nota:

Después de hacerlo, puede experimentar algunos tiempos de espera temporales si un gran número de clientes intenta conectarse al servidor WSUS. Esto también puede provocar un uso elevado de la CPU en el servidor WSUS. A medida que los clientes conectan el uso de CPU deben volver a la normalidad. Si el uso elevado de CPU persiste después de que todos los clientes estén conectados, consulte Solución de problemas de uso elevado de CPU en un servidor WSUS.