Configuration Manager consola muestra la versión de definición de Endpoint Protection obsoleta y la hora de última actualización

En este artículo se proporciona una solución para el problema que Configuration Manager consola muestra la versión de definición de Endpoint Protection obsoleta y la hora de última actualización mientras los clientes tienen instalada la versión más reciente de la definición.

Versión original del producto: Configuration Manager
Número de KB original: 4528414

Síntomas

Al usar Endpoint Protection junto con Configuration Manager, experimenta los siguientes problemas:

  • En la consola de Configuration Manager, abra el área de trabajo Activos y compatibilidad en el nodo Dispositivos. En ese área de trabajo, observará que las columnas Última versión de definición de Endpoint Protection y Hora de última actualización de Endpoint Protection muestran valores obsoletos para algunos dispositivos. Sin embargo, los clientes muestran que tienen aplicadas las versiones más recientes.
  • El tipo de tema 1901 (State_Topictype_Ep_Am_Health) no está registrado en StateMessage.log en los clientes.
  • Los siguientes mensajes de error se registran en ExternalEventAgent.log en los clientes:

PARSE XML para obtener la cadena de consulta SELECT * FROM MSFT_MPComputerStatus
...
Ejecute todas las acciones de inicialización para el cambio de directiva desde CCM_ExternalEventConfig.
No se pudo abrir la clave del Registro SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage\SyncStatus con 0x80070002 de error.
No se pudo abrir la clave del Registro SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage con 0x80070002 de error.
No se pudo cargar los valores anteriores de criterios de diferenciación ComputerStatusStateMessage con 0x80070002 de error.
No se pudo abrir la clave del Registro SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage\SyncStatus con 0x80070002 de error.
No se pudo abrir la clave del Registro SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage con 0x80070002 de error.
No se pudo cargar los valores anteriores de criterios de diferenciación InfectionStatusStateMessage con 0x80070002 de error.

Además, las siguientes claves del Registro no existen en el cliente:

  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\ComputerStatusStateMessage
  • HKLM\SOFTWARE\Microsoft\CCM\ExternalEventAgent\Criterias\Differentiation\InfectionStatusStateMessage

Causa

Este problema se produce porque la instancia de la MSFT_MpComputerStatus clase no existe en el root\Microsoft\ProtectionManagement espacio de nombres. El cliente consulta esta instancia para rellenar las claves del Registro relacionadas.

Solución

Para corregir el problema, ejecute el siguiente comando en los equipos cliente afectados para volver a registrar el ProtectionManagement proveedor:

Register-CimProvider -ProviderName ProtectionManagement -Namespace root\Microsoft\protectionmanagement -Path <path of ProtectionManagement.dll> -Impersonation True -HostingModel LocalServiceHost -SupportWQL -ForceUpdate

Nota:

En este comando, <la ruta de acceso de ProtectionManagement.dll> es el marcador de posición de la ruta de acceso de ProtectionManagement.dll. Por ejemplo:
C:\ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\ProtectionManagement.dll

Después de ejecutar este comando, se cumplen las condiciones siguientes:

  • La instancia de MSFT_MpComputerStatus se rellena en el espacio de root\Microsoft\ProtectionManagement nombres.
  • El tipo de tema 1901 se registra en StateMessage.log.
  • Se actualizan los valores afectados en la consola de Configuration Manager.

Más información

Windows Defender registros pueden ayudarle a identificar la causa principal de este problema. Por ejemplo, el siguiente fragmento de código de registro indica la presencia de una solución antivirus diferente:

2019-09-04T08:00:11.166Z [minifiltro] Acceso denegado al archivo: \ProgramData\Microsoft\Windows Defender\Platform\4.18.1907.4-0\Powershell\MSFT_MpComputerStatus.cdxml, from process '\Device\HarddiskVolume2\Program Files (x86)\Symantec\Symantec Endpoint Protection\14.0.3929.1200.105\Bin\ccSvcHst.exe' (PID: 3408)

Para recopilar registros de diagnóstico para Windows Defender, siga los pasos descritos en Recopilación de datos de diagnóstico de cumplimiento de actualizaciones para Windows Defender evaluación de AV.

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