Los trabajos de protección de varios servidores protegidos producen errores

Este artículo le ayuda a reparar los mensajes de errores sobre los detalles del trabajo con errores para varios servidores protegidos en el administrador de protección de datos (DPM).

Versión del producto original:   System Center Data Protection Manager
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Síntomas

Recibe uno o más de los mensajes de error siguientes sobre trabajos erróneos para varios servidores protegidos en System Center Data Protection Manager. Estos errores pueden producirse para varios tipos de trabajos, como la sincronización, los puntos de recuperación y la comprobación de coherencia.

Tipo: estado del punto de recuperación: error de Descripción: error inesperado durante la ejecución del trabajo. (ID 104 detalles: código de error interno: 0x80990A51)

Tipo: estado de copia de seguridad en cinta: error de Descripción: DPM no pudo comunicarse con el agente de protección en Server_name. com porque se denegó el acceso. (ID 42 Detalles: acceso denegado (0x80070005))

DPM no se pudo comunicar con el servicio agente de protección en ProtectedServer. contoso. local. (ID 308 detalles: el servidor RPC no está disponible (0x800706BA))

No se pudo realizar la operación del agente de protección porque DPM no se pudo comunicar con el servicio agente de protección en protected.server.contoso.com. (ID 308 detalles: el servidor RPC no está disponible (0x800706BA))

Tipo: estado de punto de recuperación: error de Descripción: el agente de protección de Server_name. com no pudo responder temporalmente debido a un estado inesperado. (ID 60 detalles: código de error interno: 0x809909B0)

El servicio DPM no se pudo comunicar con el agente de protección en ProtectedServer. contoso. local. (ID 52 detalles: el host remoto ha cerrado una conexión existente de forma forzada (0x80072746))

Causa

Este problema se produce si la red tiene una latencia alta o si la red está saturada con transferencias de datos. Cuando se cumplen estas condiciones, se retrasa el tráfico DCOM. Esto hace que los agentes agoten el tiempo de espera de forma intermitente.

Solución alternativa

Para solucionar este problema, habilite la limitación de DPM de 85 a 90 por ciento para asegurarse de que el ancho de banda está disponible para las llamadas DCOM. Puede habilitar el límite de ancho de banda para cada servidor protegido en la ficha agentes , en la ficha Administración .

Más información

Hay diferentes canales para el control y la información de datos que pasa entre el servidor DPM y un servidor protegido. La ruta de acceso de control usa el canal DCOM (RPC) y la ruta de acceso de los datos usa TCP/IP. Si la ruta de acceso a los datos satura completamente la red (incluso durante un breve período de tiempo), las llamadas DCOM pueden producir errores. Si se produce un error en las llamadas, se produce un error en el trabajo. Para evitar este problema, habilite la limitación de peticiones para los servidores protegidos a fin de limitar el uso de la red de la ruta de datos al 85 por ciento.

De forma predeterminada, la limitación no está habilitada en DPM porque la limitación requiere la calidad de servicio (QoS) que se va a instalar en el servidor DPM y en el servidor protegido.

Si la configuración del 85 por ciento no resuelve el problema por completo, aumente el nivel de limitación del servidor protegido que tiene el problema.

Si esta solución no resuelve el problema, es posible que el servidor DPM esté sobrecargado. Intente reorganizar los grupos de protección para que las copias de seguridad se escalonen o para que las sincronizaciones se produzcan en momentos escalonados.