Evento 1098: Error: 0xCAA5001C Token broker operation failed in Windows 10
En este artículo se proporciona ayuda para resolver un error 0xCAA5001C que se produce al acceder a la Microsoft Store para Empresas en un equipo basado en Windows 10.
Versión original del producto: Windows 10, versión 1903, Windows 10, versión 1809, Windows 10, versión 1709
Número KB original: 3196528
Síntomas
Después de iniciar sesión en un equipo basado en Windows 10, intentas acceder a la Microsoft Store para Empresas. Sin embargo, se produce un error en la autenticación de Azure Active Directory y algunos eventos se registran en el registro de Microsoft-Windows-AAD/Operational.
Además de la Microsoft Store para Empresas, este problema puede afectar a Enterprise State Roaming.
Causa
Este problema se produce si faltan permisos o atributos de propiedad en una o ambas de las siguientes claves del Registro:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\ Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
HKEY_USERS\S-1-5-21-299502267-1950408961-849522115-1818\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion \AppModel\SystemAppData\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
Nota
Hacer coincidir el SID notificado para el usuario en el identificador de evento 1098 con la ruta de acceso en HKEY_USERS. En este ejemplo, es S-1-5-21-299502267-1950408961-849522115-1818.
Solución
Para resolver este problema, siga estos pasos:
- Tomar posesión de la clave si es necesario (Propietario = SISTEMA).
- Corrija los permisos en estas claves del Registro habilitando la herencia (corregir una debería corregir ambos, a menos que varios usuarios inicien sesión en el mismo dispositivo):
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData\ Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
HKEY_USERS\S-1-5-21-299502267-1950408961-849522115-1818\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion \AppModel\SystemAppData\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\PSR
Tipo | Director | Access | Heredado de | Se aplica a |
---|---|---|---|---|
Permitir | S-1-15-2-1910091885-1573563583-1104941280-2418270861-3411158377-2822700936-2990310272 | Valor de consulta | Ninguno | Solo esta clave |
Permitir | SYSTEM | Control total | CURRENT_USER\Software\Clases\Configuración local\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Esta clave y subclaves |
Permitir | Cuenta de usuario de dominio ( user@contoso.com ) |
Control total | CURRENT_USER\Software\Clases\Configuración local\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Esta clave y subclaves |
Permitir | Administradores (COMPUTER\Administradores) | Control total | CURRENT_USER\Software\Clases\Configuración local\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Esta clave y subclaves |
Permitir | CREADOR PROPIETARIO | Control total | CURRENT_USER\Software\Clases\Configuración local\Software\Microsoft\Windows\CurrentVersion\AppModel\SystemAppData | Solo subclaves |
Nota
Si ve los permisos de la clave del Registro ~\PSR en HKEY_USERS SID}, el campo Heredado de muestra la herencia de la ruta de acceso { HKEY_USERS { SID}.
Si esto no resuelve el problema, considere la posibilidad de ejecutar el Monitor de procesos mientras realiza el método de autenticación para buscar ACCESO DENEGAdo en otras áreas del registro o del sistema de archivos que podrían estar causando el error de autenticación. Si detecta alguno, agrégrélos a este artículo.