Cómo ejecutar un script de inicio de sesión una vez cuando un nuevo usuario inicia sesión en Windows Server 2003

En este artículo se describe cómo configurar un script de inicio de sesión o un programa para que se ejecute una vez cuando un usuario inicie sesión en un equipo por primera vez.

Versión original del producto:   Windows Server 2003
Número KB original:   325347

Resumen

Importante

Este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad de él y asegúrese de comprender cómo restaurar el Registro si se produce un problema. Para obtener información sobre cómo hacer una copia de seguridad, restaurar y editar el Registro, vea la información del Registro de Windows para usuarios avanzados.

Estos pasos solo se aplican a los nuevos usuarios que nunca han iniciado sesión en el equipo. Si un usuario ya tiene un perfil de usuario local o un perfil móvil, el script o el programa no se ejecuta.

Configurar un script para que se ejecute una vez cuando un nuevo usuario inicia sesión

Advertencia

Si usa incorrectamente el Editor del Registro, puede causar problemas graves que pueden requerir la reinstalación del sistema operativo. Microsoft no puede garantizar que pueda resolver problemas que se den como resultado de usar incorrectamente el Editor del Registro. Use el Editor del Registro bajo su propia responsabilidad.

Cuando se instala un producto basado en Windows Server 2003, se crea el perfil de usuario predeterminado. La primera vez que un usuario inicia sesión, el perfil de usuario predeterminado se copia en el perfil del usuario.

Para configurar un script o programa para que se ejecute cuando un nuevo usuario inicie sesión, siga estos pasos:

  1. Haga clic en Inicio y, a continuación, en Ejecutar.

  2. En el cuadro Abrir, escriba regedit.exe y, a continuación, seleccione Aceptar.

  3. Busque la siguiente subclave en el Registro:
    HKEY_USERS

  4. En el menú Archivo, seleccione Cargar subárbol.

  5. En el cuadro de diálogo Cargar subárbol, busque el archivo Profilepath \Default User\Ntuser.dat, donde Profilepath es la ubicación del sistema de archivos del perfil de usuario predeterminado. Seleccione Abrir.

  6. En el cuadro de diálogo Cargar subárbol, escriba un nombre para el subárbol y, a continuación, seleccione Aceptar.

    Nota

    El archivo Ntuser.dat está oculto. Si no puede buscar o cargar el archivo Ntuser.dat, debe cambiar la configuración de la vista en el Explorador de Windows. Para ello, siga estos pasos:

    1. Seleccione Inicio y, a continuación, seleccione Explorador de Windows.
    2. Seleccione Herramientas y, a continuación, Opciones de carpeta.
    3. Seleccione la pestaña Ver.
    4. Haga clic para borrar la casilla Ocultar extensiones para tipos de archivo conocidos.
    5. Seleccione Mostrar archivos y carpetas ocultos y, a continuación, seleccione Aceptar.
  7. Busque la siguiente subclave en el Registro: HKEY_USERS\Test\Software\Microsoft\Windows\CurrentVersion\Runonce

    Nota

    Donde Test es el nombre que proporcionó al subárbol Ntuser.dat en el paso 6.

  8. En el menú Editar, seleccione Nuevo y, a continuación, seleccione Valor de cadena.

  9. En el panel derecho, haga doble clic en el nuevo valor.

  10. En el cuadro de diálogo Editar cadena, escriba la ruta de acceso completa y el nombre del archivo para el script de inicio de sesión o programa y, a continuación, seleccione Aceptar.

  11. En el panel izquierdo, seleccione el subárbol Prueba.

  12. En el menú Archivo, seleccione Descargar subárbol.

  13. Seleccione cuando se le pida que confirme que desea descargar el subárbol.

  14. Salga del editor del Registro. Este programa o script de inicio de sesión se ejecuta para un usuario que no tiene un perfil de usuario. Para ver los perfiles de usuario en el equipo local, siga estos pasos:

    1. Seleccione Inicio, elija Panel de control y, a continuación, seleccione Sistema.
    2. Seleccione la pestaña Avanzadas.
    3. En el área Perfiles de usuario, seleccione Configuración.
      Los perfiles de usuario aparecen en el cuadro de diálogo Perfiles de usuario.