Los servicios que dependen del servicio de ASP.NET no se inician después de actualizar a .NET Framework 4.0

En este artículo se proporciona una solución alternativa para un problema en el que los servicios que dependen del servicio de estado no se inician después de actualizar a ASP.NET Microsoft .NET Framework 4.0.

Versión original del producto:   Windows Server 2012 R2
Número KB original:   2963657

Síntomas

Imagine la siguiente situación:

  • Tiene un equipo que ejecuta Windows Server 2008 R2.
  • El ASP.NET estado de usuario se instala como parte de Internet Information Services (IIS).
  • Un servicio instalado depende del servicio ASP.NET estado de instalación.
  • Debe actualizar Microsoft .NET Framework 3.51 a .NET Framework 4.0.

En este escenario, observará que, después de actualizar .NET Framework, cualquier servicio que dependa del servicio de estado de ASP.NET no se inicia y genera el siguiente error:

Windows no pudo iniciar <service name> el servicio en <computer name> .

Error 1075: El servicio de dependencia no existe o se ha marcado para su eliminación.

También observará que el servicio ASP.NET estado de mantenimiento ya no aparece en la consola de administración de servicios.

Causa

Este es un problema conocido que se produce al actualizar .NET Framework.

Solución alternativa

Para evitar este problema, siga estos pasos:

  1. Abra la consola de administración de servicios (services.msc).

  2. Cambie a Manual el tipo de inicio de cualquier servicio que dependa del servicio de estado de ASP.NET y que esté establecido en Automático.

  3. En un símbolo del sistema administrativo, escriba el siguiente comando y, a continuación, presione ENTRAR:

    %SystemRoot%\ Microsoft.NET\Framework64\v4.0.30319 \aspnet_regiis /iru
    
  4. Reinicie el equipo.

  5. Vuelva a abrir la consola de administración de servicios (services.msc).

  6. Cambie a Automático el tipo de inicio del servicio o servicios que tenían el tipo de inicio cambiado en el paso 2, que dependen del servicio de estado de ASP.NET y que ahora tienen el tipo de inicio establecido en Manual. Reinicie el equipo y, a continuación, confirme que el problema se ha resuelto.