Se produce un error en el recurso de recurso compartido de archivos de clúster en un nodo de clúster de conmutación por error y el registro del clúster contiene el "estado 5. Tolerando..."

En este artículo se proporciona una solución a un problema por el que se produce un error en el recurso de recurso compartido de archivos de clúster en un nodo de clúster de conmutación por error.

Se aplica a: Windows Server 2012 R2
Número de KB original: 2867302

Síntomas

Imagine la siguiente situación:

  • En Windows Server 2008, 2008 R2 o 2012 se configura un clúster de conmutación por error de Windows con un servidor de archivos de alta disponibilidad.
  • Los nodos del clúster se configuran con un espacio de nombres separado en el que el DNS principal del equipo es suficiente no coincide con el dominio DNS del que es miembro.

En este escenario, puede observar que el servidor de archivos de alta disponibilidad funciona bien en algunos de los nodos del clúster, pero se produce un error coherente en otros. Al examinar el registro del clúster, verá algo similar a las siguientes entradas con la primera entrada que hace referencia al "estado 5. Tolerando...":

00001b6c.000008c8::<DateTime> WARN [RES] File <Server FileServer-(yoel-cluster)(Cluster Disk 6)>: Error en NetShareGetInfo(yoel-cluster, share2), estado 5. Tolerar...
00001b6c.000008c8::<DateTime> ERR [RES] File <Server FileServer-(yoel-cluster)(Cluster Disk 6)>: no hay un solo recurso compartido entre 1 recursos compartidos configurados en línea
00001b6c.000008c8::<DateTime> ERR [RES] File <Server FileServer-(yoel-cluster)(Cluster Disk 6)>: Error en la comprobación del sistema de archivos, número de recursos compartidos comprobados: 1, último estado del recurso compartido: 5.
00001b6c.000008c8::<DateTime> ERR [RES] File <Server FileServer-(yoel-cluster)(Cluster Disk 6):>Fileshares failed health check during online, status 5.

Causa

Uno o varios nodos del clúster de conmutación por error pueden contener entradas no coincidentes en la lista de búsqueda de sufijos DNS.

Solución

Para resolver el problema, compruebe que todos los nodos del clúster están configurados con la misma lista de búsqueda de sufijos DNS y que las entradas se enumeran en el mismo orden. La lista de búsqueda de sufijos DNS se puede modificar mediante los pasos siguientes:

  1. Abra la página de propiedades del adaptador de red.
  2. Abra la página de propiedades de Protocolo de Internet versión 4 (TCP/IPv4).
  3. Seleccione el botón Avanzado en la pestaña General.
  4. Seleccione la pestaña DNS.

Más información

Para obtener más información sobre la configuración y el uso de un espacio de nombres separado, consulte el vínculo siguiente:

Crear un espacio de nombres separado