La cola de impresoras puede bloquearse aleatoriamente en un equipo Windows Server que tenga instalada una impresora HP.

En este artículo se proporciona una solución a un problema por el que la cola de impresora se bloquea aleatoriamente en un equipo Windows Server que tiene instalada una impresora HP.

Se aplica a: Windows Server 2012 R2
Número de KB original: 947477

Síntomas

En un equipo basado en Windows Server que tenga instalada una impresora HP, la cola de impresión puede bloquearse aleatoriamente.

Causa

Este problema se produce debido a uno de los siguientes archivos:

  • Hpbmmon.dll (HP Master Monitor)
  • Hpzpi4wm.dll (procesador de impresión HP)
  • Hpzpp4wm.dll (procesador de impresión HP)
  • HPtcpMon.dll (monitor de puertos TCP de HP)

Solución

Para resolver este problema, póngase en contacto con el fabricante de terceros para obtener ayuda.

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Solución alternativa al problema causado por Hpbmmon.dll

Para solucionar este problema, quite hp master monitor. Para ello, siga estos pasos:

  1. Inicie el Editor del Registro.

  2. Busque y haga clic en la subclave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Master Monitordel Registro .

  3. En el menú Archivo , haga clic en Exportar.

  4. En el cuadro Nombre de archivo , escriba HPprinter y, a continuación, haga clic en Guardar.

    Nota:

    Si desea restaurar esta subclave del Registro, haga doble clic en el archivo HPprinter.reg que guarda en este paso.

  5. Haga clic con el botón derecho en la entrada del Registro de HP Master Monitor y, a continuación, haga clic en Eliminar.

  6. Haga clic en .

  7. Cierre el Editor del Registro y reinicie el equipo.

  8. Cambie el nombre del archivo Hpbmmon.dll a Hpbmmon.old. El archivo está en la ubicación C:\WINDOWS\system32\Hpbmmon.dll archivo.

Solución alternativa al problema causado por Hpzpi4wm.dll o Hpzpp4wm.dll

Nota:

Si esta impresora no funciona con WinPrint, es posible que los pasos siguientes no funcionen. Si se produce esta situación, póngase en contacto con HP para actualizar el procesador de impresión HPZPP4WM a la versión más reciente.

  1. Haga clic en Inicio y en Panel de control.
  2. Haga doble clic en Impresoras y faxes.
  3. Haga clic con el botón derecho en la impresora que desea usar y, a continuación, haga clic en Propiedades.
  4. Haga clic en la pestaña Opciones avanzadas y, a continuación, haga clic en Procesador de impresión.
  5. Haga clic en WinPrint en el cuadro Procesador de impresión , haga clic en RAW en el cuadro Tipo de datos predeterminado y, a continuación, haga clic en Aceptar dos veces.
  6. Cambie el nombre del archivo Hpzpi4wm.dll a Hpzpi4wm.old. El archivo está en la ubicación: C:\WINDOWS\system32\spool\drivers\w32x86\3\Hpzpi4wm.dll.
  7. Cambie el nombre del archivo Hpzpp4wm.dll a Hpzpp4wm.old. El archivo está en la ubicación: C:\WINDOWS\system32\spool\PRTPROCS\W32X86\Hpzpp4wm.dll.

Solución alternativa al problema causado por HPtcpMon.dll

  1. Inicie el Editor del Registro.

  2. Busque la siguiente subclave del Registro y haga clic en ella: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Standard TCP/IP Port.

  3. En el menú Archivo , haga clic en Exportar.

  4. En el cuadro Nombre de archivo , escriba HPprinter y, a continuación, haga clic en Guardar.

    Nota:

    Si desea restaurar esta subclave del Registro, haga doble clic en el archivo HPprinter.reg que guarda en este paso.

  5. Haga clic con el botón derecho en la entrada del Registro de puertos TCP/IP estándar de HP y, a continuación, haga clic en Eliminar.

  6. Haga clic en .

  7. Busque y haga clic en la subclave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Portdel Registro .

  8. Haga doble clic en Controlador y, a continuación, compruebe que el valor del cuadro Datos de valor está tcpmon.dll.

    Nota:

    Si la entrada del Registro de controladores no existe o su valor no está tcpmon.dll, cree la entrada del Registro de controladores y, a continuación, establezca su valor en tcpmon.dll. Para ello, siga estos pasos:

    1. En el menú Editar , seleccione Nuevo y, a continuación, haga clic en Valor de cadena.
    2. Escriba Driver y, a continuación, presione ENTRAR.
    3. Haga clic con el botón derecho en Controladory, a continuación, haga clic en Modificar.
    4. En el cuadro Datos de valor , escriba tcpmon.dll y, a continuación, haga clic en Aceptar.
  9. Cierre el Editor del Registro y reinicie el equipo.

  10. Cambie el nombre del archivo HPtcpMon.dll a HPtcpMon.old. El archivo está en la ubicación: C:\WINDOWS\system32\HPTcpMon.dll.

Más información

Los productos de otros fabricantes que se mencionan en este artículo han sido creados por compañías independientes de Microsoft. Microsoft no ofrece ninguna garantía, ya sea implícita o de otro tipo, sobre la confiabilidad o el rendimiento de dichos productos.