Entrenar modelos de AI en Azure Batch AITrain AI models in Azure Batch AI

Batch AI es un servicio administrado que permite a los científicos de datos y a los investigadores de AI entrenar modelos de AI y otros modelos de Machine Learning en clústeres de máquinas virtuales de Azure, incluidas las máquinas virtuales compatibles con GPU.Batch AI is a managed service that enables data scientists and AI researchers to train AI and other machine learning models on clusters of Azure virtual machines, including VMs with GPU support. Para ello, es necesario describir los requisitos del trabajo y dónde encontrar las entradas y almacenar las salidas. Batch AI se encargará del resto del proceso.You describe the requirements of your job, where to find the inputs and store the outputs, and Batch AI handles the rest. Más información sobre Azure Batch AI.Learn more about Azure Batch AI

Se integra con Visual Studio Tools para AI, lo que le permitirá escalar dinámicamente modelos de entrenamiento en Azure.It's integrated with Visual Studio Tools for AI so you can dynamically scale out training models in Azure. Después de haber instalado Visual Studio Tools para IA, podrá crear un proyecto de Python muy fácilmente con las recetas ya preparadas de la galería de ejemplos de Azure Machine Learning.Once you've installed Visual Studio Tools for AI, it's easy to create a new Python project using pre-made recipes in the Azure Machine Learning Sample Gallery.

  1. Inicie Visual Studio.Launch Visual Studio. Abra el Explorador de servidores; para ello, abra el menú AI Tools (Herramientas para IA) y elija Seleccionar un clústerOpen the Server Explorer by opening the AI Tools menu and choosing Select Cluster

    Selección de clúster

  2. Expanda AI Tools (Tools para AI).Expand AI Tools. Los recursos de Batch AI que tenga se detectarán automáticamente y aparecerán en el Explorador de servidores.Any Batch AI resources you have will be auto-detected and appear in the Server Explorer.

    Galería de ejemplos

  3. Seleccione Ver > Team Explorer... para abrir la ventana Team Explorer desde la que puede conectarse a GitHub o Azure DevOps, o bien clonar un repositorio.Select View > Team Explorer... to open the Team Explorer window in which you can connect to GitHub or Azure DevOps, or clone a repository.

    Ventana de Team Explorer en la que se muestra Azure DevOps, GitHub y la clonación de un repositorio

  4. En el campo de dirección URL en Repositorios GIT locales, escriba https://github.com/Microsoft/samples-for-ai, especifique una carpeta para los archivos clonados y haga clic en Clonar.In the URL field under Local Git Repositories, enter https://github.com/Microsoft/samples-for-ai, enter a folder for the cloned files, and select Clone.

    Tip

    La carpeta que especifique en Team Explorer es la carpeta específica para recibir los archivos clonados.The folder you specify in Team Explorer is the specific folder to receive the cloned files. A diferencia del comando git clone, al crear un clon en Team Explorer no se crea automáticamente una subcarpeta con el nombre del repositorio.Unlike the git clone command, creating a clone in Team Explorer does not automatically create a subfolder with the name of the repository.

  5. Cuando se complete la clonación, haga clic en Archivo > Abrir solución > Proyecto/Solución.When cloning is complete, click File > Open Solution > Project / Solution

    Galería de ejemplos

  6. Abra samples-for-ai\TensorFlowExamples\TensorFlowExamples.sln en el directorio en el que ha clonado el repositorio.Open samples-for-ai\TensorFlowExamples\TensorFlowExamples.sln in the directory you cloned the repository

    Galería de ejemplos

  7. Establezca el proyecto de MNIST como proyecto de inicio.Set MNIST project as the **Startup Project **

    Galería de ejemplos

  8. Haga clic con el botón derecho en el proyecto de MNIST y seleccione Enviar trabajo.**Right-click **MNIST project, Submit Job

    Galería de ejemplos

  9. Seleccione el clúster Azure Batch AI y haga clic en Importar.Select your Azure Batch AI cluster, then click Import. Seleccione el archivo AzureBatchAI_TF_MNIST.json para rellenar rápidamente algunos valores predeterminados, como qué imagen de Docker usar.Select the AzureBatchAI_TF_MNIST.json file to quickly populate some default values like which Docker Image to use. Luego, haga clic en Enviar.Then click Submit

    Galería de ejemplos