Remote DebuggingRemote Debugging

Puede depurar una aplicación de Visual Studio que se ha implementado en un equipo diferente.You can debug a Visual Studio application that has been deployed on a different computer. Para ello, use el depurador remoto de Visual StudioTo do so, you use the Visual Studio remote debugger.

Para obtener instrucciones sobre la depuración remota, vea estos temas.For in-depth instructions on remote debugging, see these topics.

EscenarioScenario VínculoLink
Azure App ServiceAzure App Service Depurador de instantáneas o depuración remota de ASP.NET en AzureSnapshot Debugger or Remote debug ASP.NET on Azure
Máquina virtual de AzureAzure VM Depuración remota de ASP.NET en AzureRemote debug ASP.NET on Azure
Azure Service FabricAzure Service Fabric Depurar una aplicación de Azure Service FabricDebug an Azure Service Fabric application
ASP.NETASP.NET Depuración remota de ASP.NET Core o ASP.NET de depuración remotaRemote debug ASP.NET Core or Remote Debug ASP.NET
C# o Visual BasicC# or Visual Basic Depuración remota de un proyecto de C# o Visual BasicRemote debug a C# or Visual Basic project
C++C++ Depuración remota de un proyecto de C++Remote debug a C++ project
Aplicaciones universales de Windows (UWP)Universal Windows Apps (UWP) Ejecutar aplicaciones para UWP en un equipo remoto o depuración de un paquete de aplicación instaladaRun UWP apps on a remote machine or Debug an installed app package

Si simplemente desea descargar e instalar al depurador remoto y no necesita todas las instrucciones adicionales para su escenario, siga los pasos descritos en este artículo.If you just want to download and install the remote debugger and don't need any additional instructions for your scenario, follow the steps in this article.

Descargue e instale las herramientas remotasDownload and Install the remote tools

  1. En el dispositivo o servidor máquina que desea depurar (en lugar de la máquina que ejecuta Visual Studio), obtenga la versión correcta de las herramientas remotas.On the device or server machine that you want to debug (rather than the machine running Visual Studio), get the correct version of the remote tools.

    VersiónVersion VínculoLink NotasNotes
    Visual Studio 2017 (versión más reciente)Visual Studio 2017 (latest version) Herramientas remotasRemote tools La versión más reciente de las herramientas remotas es compatible con todas las versiones de Visual Studio 2017.The latest version of the remote tools is compatible with all Visual Studio 2017 releases. Descargar siempre la versión que coincida con el sistema operativo del dispositivo (x 86, x64 o ARM64).Always download the version matching your device operating system (x86, x64, or ARM64). En Windows Server, vea desbloquear la descarga del archivo para obtener ayuda para descargar las herramientas remotas.On Windows Server, see Unblock the file download for help to download the remote tools.
    Visual Studio 2015Visual Studio 2015 Herramientas remotasRemote tools Herramientas remotas para Visual Studio 2015 están disponibles en My.VisualStudio.com.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. Si se le solicite, únase a la versión gratuita Visual Studio Dev Essentials programa o inicie sesión con su identificador de suscripción de Visual Studio.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. En Windows Server, vea desbloquear la descarga del archivo para obtener ayuda para descargar las herramientas remotas.On Windows Server, see Unblock the file download for help to download the remote tools.
    Visual Studio 2013Visual Studio 2013 Herramientas remotasRemote tools Descargar página de documentación de Visual Studio 2013Download page in Visual Studio 2013 documentation
    Visual Studio 2012Visual Studio 2012 Herramientas remotasRemote tools Descargar página de documentación de Visual Studio 2012Download page in Visual Studio 2012 documentation
  2. En la página de descarga, elija la versión de las herramientas que coincida con el sistema operativo (x86, x64, ARM o ARM64) y descargue las herramientas remotas.On the download page, choose the version of the tools that matches your operating system (x86, x64, ARM, or ARM64) and download the remote tools.

    Importante

    Se recomienda que instale la versión más reciente de las herramientas remotas para la versión de Visual Studio.We recommend that you install the most recent version of the remote tools for your release of Visual Studio. La versión más reciente (por ejemplo, 15,8) es compatible con versiones anteriores (por ejemplo, 15.0); Sin embargo, las versiones anteriores no son compatibles con versiones posteriores.The latest version (for example, 15.8) is compatible with earlier releases (for example, 15.0); however, earlier versions are not compatible with later releases. Además, debe instalar las herramientas remotas que tienen la misma arquitectura que el sistema operativo en el que desee instalarlo.In addition, you must install the remote tools that have the same architecture as the operating system on which you want to install it. En otras palabras, si desea depurar una aplicación de 32 bits en un equipo remoto ejecuta un sistema operativo de 64 bits, debe instalar la versión de 64 bits de las herramientas remotas en el equipo remoto.In other words, if you want to debug a 32-bit application on a remote computer running a 64-bit operating system, you must install the 64-bit version of the remote tools on the remote computer.

    Para depurar en Windows 10 en dispositivos ARM, elija la descarga de ARM64 disponible con la versión más reciente de las herramientas remotas.For debugging on Windows 10 on ARM devices, choose the ARM64 download available with the latest version of the remote tools. Los dispositivos Windows RT, elija la versión ARM, que solo está disponible en la descarga de Visual Studio 2015 RTW.For Windows RT devices, choose the ARM version, which is only available in the Visual Studio 2015 RTW download.

  3. Cuando haya terminado de descargar el archivo ejecutable, vaya a la sección siguiente y siga las instrucciones de configuración.When you have finished downloading the executable, go to the next section and follow setup instructions.

Si intenta copiar el depurador remoto (msvsmon.exe) en el equipo remoto y ejecutarlo, tenga en cuenta que el Asistente para configuración de Remote Debugger (rdbgwiz.exe) se instala solo al descargar la herramientas.If you try to copy the remote debugger (msvsmon.exe) to the remote computer and run it, be aware that the Remote Debugger Configuration Wizard (rdbgwiz.exe) is installed only when you download the tools. Es posible que deba usar al Asistente para configuración más adelante, especialmente si desea que el depurador remoto para ejecutarse como un servicio.You may need to use the wizard for configuration later, especially if you want the remote debugger to run as a service. Para obtener más información, consulte (opcional) configurar el depurador remoto como un servicio.For more information, see (Optional) Configure the remote debugger as a service.

Desbloquear la descarga de las herramientas remotas en Windows ServerUnblock the download of the remote tools on Windows Server

La configuración de seguridad predeterminada en Internet Explorer en Windows Server puede hacer mucho tiempo descargar los componentes, como las herramientas remotas.The default security settings in Internet Explorer on Windows Server can make it time-consuming to download components such as the remote tools.

  • Configuración de seguridad mejorada está habilitada en Internet Explorer, lo que evita tener que abrir los sitios Web y obtener acceso a recursos web, a menos que se permita explícitamente el dominio que contiene el recurso (es decir, de confianza).Enhanced Security Configuration is enabled on Internet Explorer, which prevents you from opening websites and accessing web resources unless the domain containing the resource is explicitly allowed (that is, trusted). Si bien puede deshabilitar a esta configuración, no se recomienda porque podrían presenta un riesgo de seguridad.Although you can disable this setting, we do not recommend it because it can presents a security risk.

  • En Windows Server 2016, un valor predeterminado en opciones de Internet > seguridad > Internet > Personalizar nivel > descargas también deshabilita las descargas de archivos.On Windows Server 2016, a default setting in Internet Options > Security > Internet > Custom Level > Downloads also disables file downloads. Si elige descargar las herramientas remotas directamente en Windows Server, debe habilitar la descarga de archivos.If you choose to download the remote tools directly on Windows Server, you must enable file download.

Para descargar las herramientas de Windows Server, se recomienda uno de los siguientes:To download the tools on Windows Server, we recommend one of the following:

  • Descargue las herramientas remotas en un equipo diferente, como el una ejecución de Visual Studio y, a continuación, copie el .exe archivo a Windows Server.Download the remote tools on a different computer such as the one running Visual Studio, and then copy the .exe file to Windows Server.

  • Ejecutar el depurador remoto desde un recurso compartido de archivos en el equipo de Visual Studio.Run the remote debugger from a file share on your Visual Studio machine.

  • Descargue las herramientas remotas directamente en Windows Server y acepte las indicaciones para agregar sitios de confianza.Download the remote tools directly on Windows Server and accept the prompts to add trusted sites. Sitios Web modernos suelen incluyen muchos recursos de terceros, por lo que esto puede dar lugar a una gran cantidad de mensajes.Modern websites often include many third-party resources, so this can result in a lot of prompts. Además, los vínculos de redirigida deba agregarse manualmente.In addition, any redirected links may need to be added manually. Puede agregar algunos de los sitios de confianza antes de comenzar la descarga.You can choose to add some of the trusted sites before beginning the download. Vaya a opciones de Internet > seguridad > sitios de confianza > sitios y agregue los siguientes sitios.Go to Internet Options > Security > Trusted Sites > Sites and add the following sites.

    • VisualStudio.Microsoft.comvisualstudio.microsoft.com
    • download.visualstudio.microsoft.comdownload.visualstudio.microsoft.com
    • acerca de: en blancoabout:blank

    Las versiones anteriores del depurador en my.visualstudio.com, agregue estos sitios adicionales para asegurarse de que ese inicio de sesión es correcta:For older versions of the debugger on my.visualstudio.com, add these additional sites to make sure that login is successful:

    • Microsoft.commicrosoft.com
    • go.microsoft.comgo.microsoft.com
    • download.microsoft.comdownload.microsoft.com
    • My.VisualStudio.commy.visualstudio.com
    • Login.microsoftonline.comlogin.microsoftonline.com
    • Login.Live.comlogin.live.com
    • Secure.aadcdn.microsoftonline-p.comsecure.aadcdn.microsoftonline-p.com
    • msft.STS.Microsoft.commsft.sts.microsoft.com
    • auth.GFX.msauth.gfx.ms
    • app.vssps.visualstudio.comapp.vssps.visualstudio.com
    • vlscppe.Microsoft.comvlscppe.microsoft.com
    • Query.prod.cms.RT.Microsoft.comquery.prod.cms.rt.microsoft.com

      Si elige agregar estos dominios al descargar las herramientas remotas y luego elija agregar cuando se le solicite.If you choose to add these domains while downloading the remote tools, then choose Add when prompted.

      Cuadro de diálogo de contenido bloqueado

      Al descargar el software, obtendrá algunas solicitudes adicionales para conceder permiso para cargar varios scripts de sitios web y recursos.When you download the software, you get some additional requests to grant permission to load various web site scripts and resources. En my.visualstudio.com, le recomendamos que agregue los dominios adicionales para asegurarse de que ese inicio de sesión es correcta.On my.visualstudio.com, we recommend that you add the additional domains to make sure that login is successful.

RequisitosRequirements

Sistemas operativos admitidosSupported Operating Systems

El equipo remoto debe ejecutarse en uno de los siguientes sistemas operativos:The remote computer must be running one of the following operating systems:

  • Windows 10 (no teléfonos)Windows 10 (not phone)

  • Windows 8 o 8.1 (no teléfonos)Windows 8 or 8.1 (not phone)

  • Windows 7 Service Pack 1Windows 7 Service Pack 1

  • Windows Server 2012 o Windows Server 2012 R2Windows Server 2012 or Windows Server 2012 R2

  • Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1Windows Server 2008 Service Pack 2, Windows Server 2008 R2 Service Pack 1

Nota

Windows Phone requiere una conexión USB para depurar (no requiere las herramientas remotas).Windows Phone requires a USB connection to debug (it does not require the remote tools).

Configuraciones de hardware compatiblesSupported Hardware Configurations

  • Procesador de 1.6 GHz o más rápido1.6 GHz or faster processor

  • 1 GB de RAM (1,5 GB si se ejecuta en una máquina virtual)1 GB of RAM (1.5 GB if running on a virtual machine)

  • 1 GB de espacio disponible en el disco duro1 GB of available hard disk space

  • Unidad de disco duro de 5400 RPM5400-RPM hard drive

  • Tarjeta de vídeo compatible con DirectX 9 con resolución de pantalla de 1024 x 768 o superiorDirectX 9-capable video card running at 1024 x 768 or higher display resolution

Configuración de redNetwork configuration

El equipo remoto y el equipo de Visual Studio deben estar conectados a través de una red, un grupo de trabajo, un grupo en el hogar o directamente mediante un cable Ethernet.The remote computer and the Visual Studio computer must be connected over a network, workgroup, or homegroup, or else connected directly through an Ethernet cable. No se admite la depuración entre dos equipos conectados a través de un servidor proxy.Debugging between two computers connected through a proxy is not supported. Depuración mediante una conexión de ancho de banda bajo, por ejemplo, acceso telefónico a Internet, o una latencia alta o a través de Internet entre países no se recomienda y puede ser un error o inaceptablemente bajo.Debugging over a high latency or low bandwidth connection, such as dialup Internet, or over the Internet across countries is not recommended and may fail or be unacceptably slow.

(Opcional) Para ejecutar al depurador remoto desde un recurso compartido de archivos(Optional) To run the remote debugger from a file share

Puede encontrar el depurador remoto (msvsmon.exe) en un equipo con Visual Studio Community, Professional o Enterprise ya instalado.You can find the remote debugger (msvsmon.exe) on a computer with Visual Studio Community, Professional, or Enterprise already installed. En algunos escenarios, la manera más fácil de configurar la depuración remota es ejecutar al depurador remoto (msvsmon.exe) desde un recurso compartido de archivos.For some scenarios, the easiest way to set up remote debugging is to run the remote debugger (msvsmon.exe) from a file share. Para conocer las limitaciones de uso, consulte la página de Ayuda del depurador remoto (Ayuda > uso en el depurador remoto).For usage limitations, see the remote debugger's Help page (Help > Usage in the remote debugger).

  1. Buscar msvsmon.exe en el directorio que coincida con su versión de Visual Studio.Find msvsmon.exe in the directory matching your version of Visual Studio. Para Visual Studio Enterprise 2017:For Visual Studio Enterprise 2017:

    Programa archivos (x86) \Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x86\msvsmon.exe

    Programa archivos (x86) \Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exeProgram Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\Remote Debugger\x64\msvsmon.exe

  2. Recurso compartido de la Remote Debugger carpeta en el equipo de Visual Studio.Share the Remote Debugger folder on the Visual Studio computer.

  3. En el equipo remoto, ejecute msvsmon.exe desde la carpeta compartida.On the remote computer, run msvsmon.exe from the shared folder. Siga el instrucciones de instalación.Follow the setup instructions.

Sugerencia

Para la instalación de línea de comandos y referencia de línea de comandos, consulte la página de ayuda para msvsmon.exe escribiendo msvsmon.exe /? en la línea de comandos en el equipo con Visual Studio instalada (o vaya a Ayuda > usoen el depurador remoto).For command line installation and command line reference, see the Help page for msvsmon.exe by typing msvsmon.exe /? in the command line on the computer with Visual Studio installed (or go to Help > Usage in the remote debugger).

Configurar el depurador remotoSet up the remote debugger

Debe tener permisos administrativos en el equipo remoto.You must have administrative permissions on the remote computer.

  1. Busque la aplicación Depurador remoto.Locate the Remote Debugger application. (Busque msvsmon.exe en la ubicación donde se haya instalado o abra el menú Inicio y busque Remote Debugger.)(Find msvsmon.exe in the location where it has been installed, or open the Start menu and search for Remote Debugger.)

    Si se ejecuta el depurador remoto en un servidor remoto, puede haga clic en la aplicación del depurador remoto y elegir ejecutar como administrador.If you are running the remote debugger on a remote server, you can right-click the Remote Debugger app and choose Run as administrator. Si no se está ejecutando en un servidor remoto, simplemente inícielo con normalidad.If you are not running it on a remote server, just start it normally.

  2. Al iniciar las herramientas remotas por primera vez (o antes de que se haya configurado), el configuración de depuración remota aparece el cuadro de diálogo.When you start the remote tools for the first time (or before you have configured it), the Remote Debugging Configuration dialog box appears.

    RemoteDebuggerConfWizardPageRemoteDebuggerConfWizardPage

  3. Si la API de servicio de Windows no está instalada (que solo se produce en Windows Server 2008 R2), elija el instalar botón.If the Windows Service API is not installed (which happens only on Windows Server 2008 R2), choose the Install button.

  4. Seleccione los tipos de red en los que desea usar las herramientas remotas.Select the network types you want use the remote tools on. Debe seleccionar al menos un tipo de red.At least one network type must be selected. Si los equipos están conectados a través de un dominio, debe elegir el primer elemento.If the computers are connected through a domain, you must choose the first item. Si los equipos están conectados a través de un grupo de trabajo o un grupo en el hogar, debe elegir el segundo o tercer elemento según corresponda.If the computers are connected through a workgroup or homegroup, you need to choose the second or third item as appropriate.

  5. Elija Configurar depuración remota para configurar el firewall e iniciar la herramienta.Choose Configure remote debugging to configure the firewall and start the tool.

  6. Cuando se completa la configuración, aparecerá la ventana del depurador remoto.When configuration is complete, the Remote Debugger window appears.

    RemoteDebuggerWindowRemoteDebuggerWindow

    El depurador remoto ahora está esperando una conexión.The remote debugger is now waiting for a connection. Tome nota del nombre del servidor y número de puerto que se muestra, porque debe coincidir con la configuración que posteriormente, usar en Visual Studio.Make a note of the server name and port number that is displayed, because this must match the configuration you later use in Visual Studio.

    Cuando haya terminado la depuración y la necesidad de detener el depurador remoto, haga clic en archivo > salida en la ventana.When you are finished debugging and need to stop the remote debugger, click File > Exit on the window. Puede reiniciarlo desde el iniciar menú o desde la línea de comandos:You can restart it from the Start menu or from the command line:

    <Directorio de instalación del depurador remoto >\< x86, x64, ARM, ARM64 o Appx > \msvsmon.exe.<Remote debugger installation directory>\<x86, x64, ARM, ARM64, or Appx>\msvsmon.exe.

Configurar al depurador remotoConfigure the remote debugger

Puede cambiar algunos aspectos de la configuración del depurador remoto tras iniciarlo por primera vez.You can change some aspects of the configuration of the remote debugger after you have started it for the first time.

  • Si necesita agregar permisos para otros usuarios se conecten al depurador remoto, elija Herramientas > permisos.If you need to add permissions for other users to connect to the remote debugger, choose Tools > Permissions. Debe tener privilegios de administrador para conceder o denegar permisos.You must have administrator privileges to grant or deny permissions.

    Importante

    Puede ejecutar al depurador remoto bajo una cuenta de usuario que difiere de la cuenta de usuario que está usando en el equipo de Visual Studio, pero debe agregar la cuenta de usuario diferente a los permisos del depurador remoto.You can run the remote debugger under a user account that differs from the user account you are using on the Visual Studio computer, but you must add the different user account to the remote debugger's permissions.

    Como alternativa, puede iniciar el depurador remoto desde la línea de comandos con el / allow <username > parámetro: msvsmon /Allow < username@computer>.Alternatively, you can start the remote debugger from the command line with the /allow <username> parameter: msvsmon /allow <username@computer>.

  • Si necesita cambiar el modo de autenticación o el número de puerto o especificar un valor de tiempo de espera para las herramientas remotas: elija Herramientas > opciones.If you need to change the Authentication mode or the port number, or specify a timeout value for the remote tools: choose Tools > Options.

    Para obtener una lista de los números de puerto que usa de forma predeterminada, consulte Remote Debugger Port Assignments.For a listing of the port numbers used by default, see Remote Debugger Port Assignments.

    Advertencia

    Puede elegir ejecutar las herramientas remotas en el Modo sin autenticación, aunque se recomienda no usar este modo.You can choose to run the remote tools in No Authentication mode, but this mode is strongly discouraged. No hay ninguna seguridad de red cuando se ejecuta en este modo.There is no network security when you run in this mode. Elija el modo sin autenticación solo si está seguro de que la red no presenta riesgos de tráfico malintencionado u hostil.Choose the No Authentication mode only if you are sure that the network is not at risk from malicious or hostile traffic.

(Opcional) Configurar al depurador remoto como servicio(Optional) Configure the remote debugger as a service

Para la depuración en ASP.NET y otros entornos de servidor, debe ejecutar al depurador remoto como administrador o, si desea que siempre en ejecución, ejecute al depurador remoto como un servicio.For debugging in ASP.NET and other server environments, you must either run the remote debugger as an Administrator or, if you want it always running, run the remote debugger as a service.

Si desea configurar al depurador remoto como un servicio, siga estos pasos.If you want to configure the remote debugger as a service, follow these steps.

  1. Busque el Asistente para configuración del depurador remoto (rdbgwiz.exe).Find the Remote Debugger Configuration Wizard (rdbgwiz.exe). (Esta es una aplicación independiente del Depurador remoto). Está disponible solo cuando se instalan las herramientas remotas.(This is a separate application from the Remote Debugger.) It is available only when you install the remote tools. No se instala con Visual Studio.It is not installed with Visual Studio.

  2. Inicie el asistente para la configuración.Start running the configuration wizard. Cuando aparezca la primera página, haga clic en Siguiente.When the first page comes up, click Next.

  3. Active la casilla Ejecutar el depurador remoto de Visual Studio 2015 como servicio .Check the Run the Visual Studio 2015 Remote Debugger as a service checkbox.

  4. Agregue el nombre de la cuenta de usuario y la contraseña.Add the name of the user account and password.

    Es posible que deba agregar el iniciar sesión como un servicio directamente a esta cuenta de usuario (buscar directiva de seguridad Local (secpol.msc) en el iniciar ventana o página (o tipo secpol en un símbolo del sistema).You may need to add the Log on as a service user right to this account (Find Local Security Policy (secpol.msc) in the Start page or window (or type secpol at a command prompt). Cuando aparezca la ventana, haga doble clic en Asignación de derechos de usuarioy, a continuación, busque Iniciar sesión como servicio en el panel derecho.When the window appears, double-click User Rights Assignment, then find Log on as a service in the right pane. Haga doble clic en ella.Double-click it. Agregue la cuenta de usuario para el propiedades ventana y haga clic en Aceptar).Add the user account to the Properties window and click OK). Haga clic en Siguiente.Click Next.

  5. Seleccione el tipo de red con el que desea que se comuniquen las herramientas remotas.Select the type of network that you want the remote tools to communicate with. Debe seleccionar al menos un tipo de red.At least one network type must be selected. Si los equipos están conectados a través de un dominio, debe elegir el primer elemento.If the computers are connected through a domain, you should choose the first item. Si los equipos están conectados a través de un grupo de trabajo o un grupo en el hogar, debe elegir el segundo o tercer elemento.If the computers are connected through a workgroup or homegroup, you should choose the second or third items. Haga clic en Siguiente.Click Next.

  6. Si se puede iniciar el servicio, se mostrará el mensaje Completó correctamente el Asistente para configuración de Visual Studio Remote Debugger.If the service can be started, you will see You have successfully completed the Visual Studio Remote Debugger Configuration Wizard. Si no se puede iniciar el servicio, se mostrará el mensaje Error al completar el Asistente para la configuración de Visual Studio Remote Debugger.If the service cannot be started, you will see Failed to complete the Visual Studio Remote Debugger Configuration Wizard. La página también proporciona algunas sugerencias para conseguir que se inicie el servicio.The page also gives some tips to follow to get the service to start.

  7. Haga clic en Finalizar.Click Finish.

    En este momento, el depurador remoto se ejecuta como servicio.At this point the remote debugger is running as a service. Puede comprobarlo si va a Panel de Control > servicios y buscando depurador remoto de Visual Studio 2015.You can verify this by going to Control Panel > Services and looking for Visual Studio 2015 Remote Debugger.

    Se puede detener e iniciar el servicio del depurador remoto de Panel de Control > servicios.You can stop and start the remote debugger service from Control Panel > Services.

Configurar la depuración con símbolos remotosSet Up Debugging with Remote Symbols

Puede depurar su código con los símbolos que se generan en el equipo de Visual Studio.You should be able to debug your code with the symbols you generate on the Visual Studio computer. El rendimiento del depurador remoto es mucho mejor cuando se usan símbolos locales.The performance of the remote debugger is much better when you use local symbols. Si debe usar símbolos remotos, deberá indicar al monitor de depuración remota que busque símbolos en el equipo remoto.If you must use remote symbols, you need to tell the remote debugging monitor to look for symbols on the remote machine.

A partir de Visual Studio 2013 Update 2, puede usar el siguiente modificador de línea de comandos de msvsmon para usar símbolos remotos para código administrado: Msvsmon /FallbackLoadRemoteManagedPdbsStarting in Visual Studio 2013 Update 2, you can use the following msvsmon command-line switch to use remote symbols for managed code: Msvsmon /FallbackLoadRemoteManagedPdbs

Para obtener más información, consulte la Ayuda de depuración remota (presione F1 en la ventana del depurador remoto, o haga clic en Ayuda > uso).For more information, please see the remote debugging help (press F1 in the remote debugger window, or click Help > Usage). Puede encontrar más información en remoto cargar cambios de símbolos .NET en Visual Studio 2012 y 2013You can find more information at .NET Remote Symbol Loading Changes in Visual Studio 2012 and 2013

Vea tambiénSee also