Introducción a la plantilla de proyecto de VSIXGet started with the VSIX Project template

Puede usar la plantilla de proyecto de VSIX para crear una extensión o para una extensión existente para la implementación del paquete.You can use the VSIX Project template to create an extension or to package an existing extension for deployment. La plantilla de proyecto de VSIX tiene las versiones de Visual Basic y Visual C# y se instala como parte del SDK de Visual Studio.The VSIX Project template has both Visual Basic and Visual C# versions, and is installed as part of the Visual Studio SDK.

La plantilla de proyecto de VSIX solo consta de un source.extension.vsixmanifest archivo, que contiene información acerca de la extensión y los recursos se incluye.The VSIX Project template just consists of a source.extension.vsixmanifest file, which contains information about the extension and the assets it ships.

Para buscar la plantilla de proyecto VSIX, debe instalar el SDK de Visual Studio.To find the VSIX project template, you must install the Visual Studio SDK. Para obtener más información, consulte SDK de Visual Studio.For more information, see Visual Studio SDK.

Implementar una plantilla de proyecto personalizado mediante la plantilla de proyecto de VSIXDeploy a Custom Project Template using the VSIX Project template

Los pasos siguientes muestran cómo usar el proyecto VSIX para empaquetar una plantilla de proyecto que se puede compartir con otros desarrolladores o cargar en la Galería de Visual Studio.The following steps show how to use the VSIX project to package a project template that you can share with other developers or upload to the Visual Studio Gallery.

  1. Crear una plantilla de proyecto.Create a project template.

    1. Abra el proyecto desde el que se va a crear una plantilla.Open the project from which to create a template. Este proyecto puede ser de cualquier tipo de proyecto.This project can be of any project type.

    2. En el menú Proyecto, haga clic en Exportar plantilla.On the Project menu, click Export Template. Complete los pasos del asistente.Complete the steps of the wizard.

      Un .zip archivo se crea en %USERPROFILE%\My Documents\Visual Studio <versión > \My Exported Templates\.A .zip file is created in %USERPROFILE%\My Documents\Visual Studio <version>\My Exported Templates\.

  2. Crear un proyecto VSIX vacío.Create an empty VSIX project.

    En el menú Archivo , haga clic en Nuevo y, a continuación, haga clic en Proyecto.On the File menu, click New and then click Project. Seleccione Visual Basic o Visual C#.Select either Visual Basic or Visual C#. En el nodo seleccionado, seleccione extensibilidady, a continuación, seleccione proyecto VSIX.Under the selected node, select Extensibility, and then select VSIX Project.

  3. Agregar el .zip archivo al proyecto.Add the .zip file to the project. Establezca su Copy to Output Directory propiedad Copy Always.Set its Copy to Output Directory property to Copy Always.

  4. En el el Explorador de soluciones, haga doble clic en el source.extension.vsixmanifest archivo para abrirlo en el el Diseñador de manifiestos VSIXy, a continuación, realice los cambios siguientes:In the Solution Explorer, double-click the source.extension.vsixmanifest file to open it in the VSIX Manifest Designer, and then make the following changes:

    • Establecer el Product Name campo mi plantilla de proyecto.Set the Product Name field to My Project Template.

    • Establecer el Id. de producto campo MyProjectTemplate - 1.Set the Product ID field to MyProjectTemplate - 1.

    • Establecer el autor campo Fabrikam.Set the Author field to Fabrikam.

    • Establecer el descripción campo mi plantilla de proyecto.Set the Description field to My project template.

    • En el activos sección, agregue un Microsoft.VisualStudio.ProjectTemplate tipo y establecer su ruta de acceso en el nombre de la .zip archivo.In the Assets section, add a Microsoft.VisualStudio.ProjectTemplate type and set its path to the name of the .zip file.

  5. Guarde y cierre el source.extension.vsixmanifest archivo.Save and close the source.extension.vsixmanifest file.

  6. Compile el proyecto.Build the project.

  7. En el directorio de resultados, haga doble clic en el .vsix archivo.In the output directory, double-click the .vsix file.

  8. Un instalador de VSIX aparece el cuadro de mensaje.A VSIX Installer message box appears. Siga las instrucciones para instalar la extensión.Follow the instructions to install the extension.

  9. Cierre Visual Studio y, a continuación, vuelva a abrirlo.Close Visual Studio and then re-open it.

  10. Seleccione extensiones y actualizaciones (en el herramientas menú) y seleccione el plantillas categoría.Select Extensions and Updates (on the Tools menu) and select the Templates category. Debe ser una de las extensiones disponibles mi plantilla de proyecto.One of the available extensions should be My Project Template.

  11. La plantilla de proyecto nuevo aparece en la nuevo proyecto cuadro de diálogo en el mismo lugar que la plantilla de proyecto original.The new project template appears in the New Project dialog in the same place as the original project template. Por ejemplo, si ha creado una plantilla denominada VB consola desde una aplicación de consola de Visual Basic, VB consola aparece en el mismo panel, como Visual Basic aplicación de consolaplantilla.For example, if you created a template named VB Console from a Visual Basic console application, VB Console appears in the same pane as the Visual Basic Console Application template.

Para especificar la ubicación de la plantilla en el cuadro de diálogo nuevo proyectoTo specify the location of the template in the New Project Dialog box

  1. Las carpetas de plantillas se encuentran en el {ruta de instalación de Visual Studio} \Common7\IDE\ProjectTemplates y * \Common7\IDE\ItemTemplates {ruta de instalación de Visual Studio}} directorios.Template folders are located in the {Visual Studio Installation Path}\Common7\IDE\ProjectTemplates and *{Visual Studio Installation Path}\Common7\IDE\ItemTemplates} directories. Las secciones de nivel de los nombres de la parte superior del nuevo proyecto cuadro de diálogo no coinciden exactamente con los nombres de las carpetas de plantilla.The names of the top level sections in the New Project dialog do not exactly match the names of the template folders. Si difieren, use el nombre de la carpeta de plantillas.Where they differ, use the name of the template folder.

    Cambiar el .vsix extensión al archivo .zipy, a continuación, abra el archivo.Change the .vsix file extension to .zip, and then open the file.

  2. Cree una carpeta con el mismo nombre que la sección de la nuevo proyecto la plantilla debe aparecer en el cuadro de diálogo.Create a new folder with the same name as the section of the New Project dialog the template should appear in.

  3. Si la plantilla que se va a aparecer en una subsección, cree una subcarpeta del mismo nombre.If the template is to appear in a subsection, create a subfolder of the same name.

  4. Mover la plantilla .zip archivo a la carpeta nueva.Move the template .zip file into the new folder.

  5. Cambiar el .zip extensión .vsix.Change the .zip extension to .vsix.

  6. Abra el manifiesto VSIX.Open the VSIX manifest.

  7. En el manifiesto de VSIX, actualice el activos ruta de acceso de la plantilla de forma que apunte a la raíz del árbol del directorio que contiene el archivo de plantilla.In the VSIX manifest, update the Asset path of the template so that it points to the root of the directory tree that contains the template file. Por ejemplo, si la plantilla está en \CSharp\Windows, la referencia debe apuntar a \CSharp.For example, if the template is in \CSharp\Windows, the reference should point to \CSharp.