Tutorial: Crear una aplicación de Shell aislado básicaWalkthrough: Creating a Basic Isolated Shell Application

Este tutorial muestra cómo crear una solución de shell aislado, personalizar la ventana de herramienta ayuda-acerca y crear un programa de instalación que instala el shell aislado.This walkthrough shows how to create an isolated shell solution, customize the Help About tool window, and create a setup program that installs the isolated shell.

Requisitos previosPrerequisites

Para seguir este tutorial, debe instalar el SDK de Visual Studio.To follow this walkthrough, you must install the Visual Studio SDK. Para obtener más información, consulte SDK de Visual Studio.For more information, see Visual Studio SDK. Para implementar el shell aislado, también debe usar el paquete redistribuible de Visual Studio Shell (aislado).To deploy the isolated shell, you must also use the Visual Studio Shell (Isolated) Redistributable Package.

Crear una solución de Shell aisladoCreating an Isolated Shell Solution

Esta sección muestra cómo usar la plantilla de proyecto de Visual Studio Shell aislado para crear una solución de shell aislado.This section shows how to use the Visual Studio Shell Isolated project template to create an isolated shell solution. La solución contiene los proyectos siguientes:The solution contains the following projects:

  • El nombresolución. Proyecto de AboutBoxPackage, que le permite personalizar la apariencia de la ayuda/acerca de cuadro.The SolutionName.AboutBoxPackage project, which allows you to customize the appearance of the Help/About box.

  • El proyecto ShellExtensionsVSIX, que contiene el archivo source.extension.vsixmanifest que define los diferentes componentes de la aplicación de shell aislado.The ShellExtensionsVSIX project, which contains the source.extension.vsixmanifest file that defines the different components of the isolated shell application.

  • El nombresolución proyecto, que genera el archivo ejecutable que invoca la aplicación de shell aislado.The SolutionName project, which produces the executable file that invokes the isolated shell application. Este proyecto contiene la carpeta de personalización de Shell, que permite personalizar la apariencia y comportamiento de la aplicación de shell aislado.This project contains the Shell Customization folder, which allows you to customiz the appearance and behavior of the isolated shell application.

  • El nombresolución proyecto de interfaz de usuario, que genera un ensamblado satélite que define los comandos de menú activo y cadenas localizables.The SolutionName UI project, which produces a satellite assembly that defines active menu commands and localizable strings.

Para crear una solución básica de shell aisladoTo create a basic isolated shell solution

  1. Abra Visual Studio y cree un nuevo proyecto.Open Visual Studio and create a new project.

  2. En el nuevo proyecto ventana, expanda otros tipos de proyectos y, a continuación, extensibilidad.In the New Project window, expand Other Project Types and then Extensibility. Seleccione el Visual Studio Shell aislado plantilla de proyecto.Select the Visual Studio Shell Isolated project template.

  3. Denomine el proyecto MyVSShellStub y especifique una ubicación.Name the project MyVSShellStub and specify a location. Asegúrese de que crear directorio para la solución está activada y, a continuación, haga clic en Aceptar.Make sure that Create directory for solution is checked, and then click OK.

    Aparece la nueva solución en el Explorador de soluciones.The new solution appears in Solution Explorer.

  4. Compile la solución y empiece a depurar la aplicación de shell aislado.Build the solution and start debugging the isolated shell application.

    Aparece el shell aislado de Visual Studio.The Visual Studio isolated shell appears. Lee de la barra de título MyVSShellStub.The title bar reads MyVSShellStub. El icono de la barra de título se genera a partir de \MyVSShellStub\Resource Files\ApplicationIcon.ico.The title bar icon is generated from \MyVSShellStub\Resource Files\ApplicationIcon.ico.

Personalizar el nombre de la aplicación y el iconoCustomizing the Application Name and Icon

Puede que desee definir la marca de la aplicación mediante el nombre de su empresa y su logotipo en la barra de título.You may want to brand your application by using the name of your company and its logo in the title bar. Los pasos siguientes muestran cómo cambiar el nombre y el icono que se muestran en la barra de título de la aplicación personalizada cambiando el archivo de definición de paquete, MyVSShellStub.Application.pkgdef.The following steps show how to change the name and icon that are displayed in the custom application title bar by changing the package definition file, MyVSShellStub.Application.pkgdef.

Para personalizar el nombre de la aplicación y el iconoTo customize the application name and icon

  1. En el proyecto MyVSShellStub, abra \Shell Customization\MyVSShellStub.Application.pkgdef.In the MyVSShellStub project, open \Shell Customization\MyVSShellStub.Application.pkgdef.

  2. Cambiar el AppName valor del elemento para "AppName" = "Editor de música de Fabrikam"Change the AppName element value to "AppName"="Fabrikam Music Editor"

  3. Para cambiar el icono de la aplicación, copie un icono diferente en el directorio \MyVSShellStub\MyVSShellStub\MyVSShellStub.To change the application icon, copy a different icon to the \MyVSShellStub\MyVSShellStub\MyVSShellStub\ directory. Cambie el nombre del archivo de ApplicationIcon.ico existente ApplicationIcon1.ico.Rename the existing ApplicationIcon.ico file to ApplicationIcon1.ico. Cambie el nombre del nuevo archivo ApplicationIcon.ico.Rename the new file to ApplicationIcon.ico.

  4. Compile la solución y comience la depuración.Build the solution and start debugging. El shell aislado aparece el IDE.The isolated shell IDE appears. La barra de título tiene su nuevo icono junto a las palabras Fabrikam música Editor.The title bar has your new icon next to the words Fabrikam Music Editor.

Personalizar la página principal del explorador Web predeterminadoCustomizing the Default Web Browser Home Page

Esta sección muestra cómo cambiar la página de inicio predeterminada de la explorador Web ventana cambiando el archivo de definición de paquete.This section shows how to change the default home page of the Web Browser window by changing the package definition file.

Para personalizar la página principal del explorador Web predeterminadoTo customize the default Web Browser home page

  1. En el archivo MyVSShellStub.Application.pkgdef, cambie la DefaultHomePage valor del elemento a "http://www.microsoft.com".In the MyVSShellStub.Application.pkgdef file, change the DefaultHomePage element value to "http://www.microsoft.com".

  2. Recompile el proyecto MyVSShellStub.Rebuild the MyVSShellStub project.

  3. Compile la solución y comience la depuración.Build the solution and start debugging.

  4. En Vista > otras ventanas, haga clic en explorador Web.In View > Other Windows, click Web Browser. El explorador Web ventana muestra la página principal de Microsoft Corporation.The Web Browser window displays the Microsoft Corporation home page.

Quitar el comando de impresiónRemoving the Print Command

El archivo .vsct en un proyecto de la interfaz de usuario de shell aislado consta de un conjunto de declaraciones del formulario <Define name=No_ elemento>, donde elemento es uno de los comandos y menús estándar de Visual Studio.The .vsct file in an isolated shell UI project consists of a set of declarations of the form <Define name=No_Element>, where Element is one of the standard Visual Studio menus and commands.

Si se hace referencia a una declaración, se excluye ese menú o el comando de shell aislado.If a declaration is uncommented, that menu or command is excluded from the isolated shell. Por el contrario, si se hace referencia a una declaración, el menú o el comando se incluye en el shell aislado.Conversely, if a declaration is commented, the menu or command is included in the isolated shell.

En los pasos siguientes, se quite el comentario de comando de impresión en el archivo .vsct.In the following steps, you uncomment print command in your .vsct file.

Para quitar el comando de impresiónTo remove the print command

  1. Compruebe que la impresión comando aparece en el archivo menú en la aplicación de shell aislado.Verify that the Print command appears on the File menu in the isolated shell application.

  2. En el proyecto MyVSShellStubUI, abra \Resource Files\MyVSShellStubUI.vsct para su edición.In the MyVSShellStubUI project, open \Resource Files\MyVSShellStubUI.vsct for editing.

  3. Quite el comentario de esta línea:Uncomment this line:

    <!-- <Define name="No_PrintChildrenCommand"/> -->  
    
  4. Esto quita el comando de impresión.This removes the print command.

  5. Empiece a depurar la aplicación de shell aislado.Start debugging the isolated shell application. Compruebe que la archivo > Imprimir comando ha desaparecido.Verify that the File > Print command is gone.

Quitar características de Shell aisladoRemoving Features from the Isolated Shell

Puede quitar algunos de los paquetes que se cargan con Visual Studio editando el archivo de .pkgundef si no desea que las características de la aplicación de shell aislado personalizado.You can remove some of the packages that are loaded with Visual Studio by editing the .pkgundef file if you do not want those features in your custom isolated shell application. Especifique el paquete en una de las subclaves de la clave del registro de $RootKey$ \Packages.You specify the package in one of the subkeys of the $RootKey$\Packages registry key.

Nota

Para obtener las características de GUID de Visual Studio, consulte paquete GUID de características de Visual Studio.To find the GUIDs of Visual Studio features, see Package GUIDs of Visual Studio Features.

El siguiente procedimiento muestra cómo quitar el XML editor desde el shell aislado.The following procedure shows how to remove the XML editor from the isolated shell.

Para quitar el editor XMLTo remove the XML editor

  1. Abra el archivo MyVSShellStub.pkgundef en la carpeta de Shell personalización del proyecto MyVSShellStub.Open the MyVSShellStub.pkgundef file in the Shell Customization folder of the MyVSShellStub project.

  2. Elimine la línea siguiente:Uncomment the following line:

    [$RootKey$ \Packages\{87569308-4813-40a0-9cd0-d7a30838ca3f}][$RootKey$\Packages\{87569308-4813-40a0-9cd0-d7a30838ca3f}]

  3. Recompile la solución e iniciar la depuración de shell aislado.Rebuild the solution and start debugging the isolated shell. Abra un archivo XML, por ejemplo, \MyVSShellStub\MyVSShellStub\MyVSShellStubUI\MyVSShellStubUI.vsct.Open an XML file,for example, \MyVSShellStub\MyVSShellStub\MyVSShellStubUI\MyVSShellStubUI.vsct. Compruebe que no se colorean las palabras clave XML en el archivo y que escriba "<" en una línea no mostrar información sobre herramientas XML.Verify that the XML keywords in the file are not colorized and that typing "<" on a line does not bring up XML tooltips.

Personalizar la ayuda/acerca de cuadroCustomizing the Help/About box

Puede personalizar la ayuda/acerca de cuadro, que se crea como parte de la plantilla de proyecto de shell aislado.You can customize the Help/About box, which is created as part of the isolated shell project template.

Para personalizar el nombre de la empresaTo customize the company name

  1. El nombre de la empresa, la información de copyright, la versión del producto y la descripción de producto se encuentran en el proyecto MyVSShellStub.AboutBoxPackage, en el archivo \Properties\AssemblyInfo.cs.The company name, copyright information, product version, and product description are found in the MyVSShellStub.AboutBoxPackage project, in the \Properties\AssemblyInfo.cs file. Abra este archivo.Open this file.

  2. Cambiar el AssemblyCompany valor a Fabrikam, el AssemblyProduct y AssemblyTitle valores a Fabrikam música Editory el AssemblyCopyright valor a Copyright © Fabrikam 2015:Change the AssemblyCompany value to Fabrikam, the AssemblyProduct and AssemblyTitle values to Fabrikam Music Editor, and the AssemblyCopyright value to Copyright © Fabrikam 2015:

    [assembly: AssemblyTitle("Fabrikam Music Editor")]  
    [assembly: AssemblyDescription("")]  
    [assembly: AssemblyConfiguration("")]  
    [assembly: AssemblyCompany("Fabrikam")]  
    [assembly: AssemblyProduct("Fabrikam Music Editor")]  
    [assembly: AssemblyCopyright("Copyright © Fabrikam 2015")] [assembly: AssemblyCompany("Fabrikam")]  
    [assembly: AssemblyProduct("Fabrikam Music Editor ")]  
    [assembly: AssemblyCopyright("Copyright © Fabrikam 2015")]  
    
  3. Para agregar una descripción del producto, cambie la AssemblyDescription valor la descripción del editor de música de Fabrikam.:To add a description of the product, change the AssemblyDescription value to The description of Fabrikam Music editor.:

    [assembly: AssemblyDescription("The description of Fabrikam Music editor.")]  
    
  4. Inicie la depuración y en la aplicación de shell aislado, abra el Ayuda > acerca de cuadro.Start debugging and in the isolated shell application, open the Help > About box. Debería ver las cadenas modificadas.You should see the changed strings. El título de la ayuda/acerca de cuadro es el mismo que el AssemblyTitle valor en AssemblyInfo.cs.The title of the Help/About box is the same as the AssemblyTitle value in AssemblyInfo.cs.

  5. Las propiedades de la ayuda/acerca propio cuadro se encuentran en el archivo MyVSShellStub.AboutBoxPackage\AboutBox.xaml.The properties of the Help/About box itself are found in the MyVSShellStub.AboutBoxPackage\AboutBox.xaml file. Para cambiar el ancho de la ayuda/acerca de cuadro, vaya a la AboutDialogStyle bloquear y establezca el Width propiedad a 200:To change the width of the Help/About box, go to the AboutDialogStyle block and set the Width property to 200:

    <Style x:Key="AboutDialogStyle" TargetType="Window">  
        <Setter Property="Height" Value="Auto" />  
        <Setter Property="Width" Value="200" />  
        <Setter Property="ShowInTaskbar" Value="False" />  
        <Setter Property="ResizeMode" Value="NoResize" />  
        <Setter Property="WindowStyle" Value="SingleBorderWindow" />  
        <Setter Property="SizeToContent" Value="Height" />  
    </Style>  
    
  6. Recompile la solución e iniciar la depuración de shell aislado.Rebuild the solution and start debugging the isolated shell. La ayuda/acerca de cuadro debe ser aproximadamente cuadrado.The Help/About box should be approximately square.

Antes de implementar la aplicación de Shell aisladoBefore You Deploy the Isolated Shell Application

La aplicación de shell aislado puede instalarse en cualquier equipo que tenga el paquete redistribuible de Visual Studio Shell (aislado).Your isolated shell application can be installed on any computer that has the Visual Studio Shell (Isolated) Redistributable Package. Para obtener más información sobre el paquete redistribuible, vea el descargas de extensibilidad de Visual Studio sitio Web.For more information about the redistributable package, see the Visual Studio Extensibility Downloads website.

Implementar la aplicación de Shell aisladoDeploying the Isolated Shell Application

Implementar la aplicación de shell aislado en un equipo de destino mediante la creación de un proyecto de instalación.You deploy your isolated shell application to a target computer by creating a setup project. Debe especificar estas cosas:You must specify these things:

  • El diseño de las carpetas y archivos en el equipo de destino.The layout of the folders and files on the target computer.

  • Las condiciones de inicio que garantizan que .NET Framework y Visual Studio shell en tiempo de ejecución que están instaladas en el equipo de destino.The launch conditions that guarantee that the .NET Framework and the Visual Studio shell runtime are installed on the target computer.

    En el siguiente procedimiento debe instalar InstallShield Limited Edition en el equipo.In the following procedure you will need to install InstallShield Limited Edition on your computer.

Para crear el proyecto de instalaciónTo create the setup project

  1. En el Explorador de soluciones, haga clic en el nodo de la solución y, a continuación, haga clic en Agregar nuevo proyecto.In Solution Explorer, right-click the solution node and then click Add New Project.

  2. En el nuevo proyecto cuadro de diálogo, expanda otros tipos de proyectos y, a continuación, seleccione el programa de instalación e implementación.In the New Project dialog box, expand Other Project Types and then select Setup and Deployment. Seleccione la plantilla de InstallShield.Select the InstallShield template. Asigne al nuevo proyecto MySetup y, a continuación, haga clic en Aceptar.Name the new project MySetup and then click OK.

  3. Si ya está instalado InstallShield Limited Edition, continúe con el paso siguiente.If InstallShield Limited Edition is already installed, continue to the next step.

    Si ya no está instalado InstallShield Limited Edition, aparece la página de descarga de InstallShield.If InstallShield Limited Edition is not already installed, the InstallShield download page appears. Siga las instrucciones para descargar e instalar el producto, elige la versión de InstallShield que sea compatible con su versión de Visual Studio.Follow the instructions to download and install the product, choosing the version of InstallShield that is compatible with your version of Visual Studio. Debe decidir si desea registrar la instalación de InstallShield o usar como versión de evaluación.You must decide whether to register your installation of InstallShield or use it as an evaluation. Debe reiniciar Visual Studio después de completar la instalación.You must restart Visual Studio after you complete the installation.

    Importante

    Debe iniciar Visual Studio como administrador antes de crear un proyecto de InstallShield.You must start Visual Studio as an administrator before you create an InstallShield project. Si no lo hace, obtendrá un error al compilar el proyecto.If you do not do so, you will get an error when you build the project.

    Los pasos siguientes muestran cómo configurar el proyecto de instalación.The next steps show how to configure the setup project.

Importante

Asegúrese de que ha creado la configuración de lanzamiento del proyecto shell aislado de al menos una vez antes de configurar el proyecto de instalación.Make sure that you have built the release configuration of your isolated shell project at least once before you configure the setup project.

Para configurar el proyecto de instalaciónTo configure the setup project

  1. En el el Explorador de soluciones, en la MySetup proyecto, elija Asistente para proyectos.In the Solution Explorer, under the MySetup project, choose Project Assistant. En la fila inferior de la Asistente para proyectos ventana, elija información de la aplicación.On the bottom row of the Project Assistant window, choose Application Information. Escriba Fabrikam como nombre de su compañía y Fabrikam música Editor como el nombre de la aplicación.Enter Fabrikam as your company name and Fabrikam Music Editor as your application name. Elija la flecha hacia delante en la parte inferior derecha de la Asistente para proyectos.Choose the forward arrow at the bottom right of the Project Assistant.

  2. Seleccione en requiere la aplicación cualquier software que estén instalados en el equipo? y, a continuación, seleccione paquete completo de Microsoft .NET Framework 4.5.Select Yes under Does your application require any software to be installed on the machine? and then select Microsoft .NET Framework 4.5 Full Package.

  3. Elija la archivos de la aplicación situado en la parte inferior de la ventana y asegúrese de que el Fabrikam música Editor se selecciona la carpeta.Choose the Application Files button at the bottom of the window, and make sure that the Fabrikam Music Editor folder is selected.

  4. Elija la agregar archivos botón.Choose the Add Files button. En el agregar archivos diálogo cuadro, agregue los siguientes archivos desde el MyVSShellStub\Release carpeta:In the Add Files dialog box, add the following files from the MyVSShellStub\Release folder:

    1. MyVSShellStub.exe.configMyVSShellStub.exe.config

    2. DebuggerProxy.dllDebuggerProxy.dll

    3. DebuggerProxy.dll.manifestDebuggerProxy.dll.manifest

    4. MyVSShellStub.pkgdefMyVSShellStub.pkgdef

    5. MyVSShellStub.pkgundefMyVSShellStub.pkgundef

    6. MyVSShellStub.winprfMyVSShellStub.winprf

    7. Splash.bmpSplash.bmp

  5. Haga clic en el agregar resultados del proyecto botón y agregue MyVSShellStub/primario salida.Click the Add Project Outputs button and add MyVSShellStub/Primary Output. Haga clic en Aceptar.Click OK.

  6. En el panel izquierdo, bajo equipo de destino, haga clic en el Fabrikam música Editor [INSTALLDIR] nodo y agregue un nueva carpeta denominado extensiones.In the left pane, under Destination Computer, right-click the Fabrikam Music Editor [INSTALLDIR] node and add a New Folder named Extensions.

  7. Haga clic en el extensiones en el panel izquierdo y agregue una nueva carpeta denominada aplicación.Right-click the Extensions node in the left pane and add a new folder named Application.

  8. Seleccione el aplicación carpeta y haga clic en el agregar resultados del proyecto , a continuación, seleccione el resultado principal del proyecto MyVSShellStub.AboutBoxPackage.Select the Application folder and click the Add Project Outputs button, then select the primary output from the MyVSShellStub.AboutBoxPackage project.

  9. Haga clic en el agregar archivos botón y desde la carpeta \MyVSShellStub\Release\Extensions\Application, agregue los siguientes archivos:Click the Add Files button and from the \MyVSShellStub\Release\Extensions\Application\ folder add the following files:

    • MyVSShellStub.AboutBoxPackage.pkgdefMyVSShellStub.AboutBoxPackage.pkgdef

    • MyVSShellStub.Application.pkgdefMyVSShellStub.Application.pkgdef

  10. Haga clic en el Fabrikam música Editor [INSTALLDIR] en el panel izquierdo y agregue una nueva carpeta denominada 1033.Right-click the Fabrikam Music Editor [INSTALLDIR] node in the left pane and add a new folder named 1033.

  11. Seleccione la carpeta 1033 y, a continuación, haga clic en el agregar resultados del proyecto botón y seleccione el resultado principal del proyecto MyVSShellStubUI.Select the 1033 folder and then click the Add Project Outputs button, and select the primary output from the MyVSShellStubUI project.

  12. Mover a la accesos directos a aplicaciones ventana.Move to the Application Shortcuts window.

  13. Haga clic en New para crear un acceso directo y seleccione \Fabrikam\Fabrikam Music Editor\MyVSShellStub.Primary Output [ProgramFilesFolder].Click New to create a shortcut and select [ProgramFilesFolder]\Fabrikam\Fabrikam Music Editor\MyVSShellStub.Primary Output.

  14. Mover a la entrevista de la instalación panel.Move to the Installation Interview pane.

  15. Establece todos los elementos en No.Set all items to No.

  16. En el Explorador de soluciones, en el proyecto MySetup, abra definir los requisitos de instalación y las acciones \ requisitos.In Solution Explorer, in the MySetup project, open Define Setup Requirements and Actions \ Requirements. El requisitos abre la ventana.The Requirements window opens.

  17. Haga clic en requisitos de sistema de Software y seleccione crear nueva condición iniciar.Right click System Software Requirements and select Create New Launch Condition. El Asistente de búsqueda de sistema aparece.The System Search Wizard appears.

  18. En el ¿qué desea buscar? panel, elija entrada del registro en la lista desplegable y haga clic en siguiente.In the What do you want to find? pane, choose Registry Entry in the drop-down list and click Next.

  19. En el cómo desea buscar lo? panel, seleccione HKEY_LOCAL_MACHINE como la raíz del registro.In the How do you want to look for it? pane, select HKEY_LOCAL_MACHINE as the registry root. Escriba SOFTWARE\Wow6432Node\Microsoft\DevDiv\vs\Servicing\14.0\isoshell para sistemas de 64 bits o SOFTWARE\Microsoft\DevDiv\vs\Servicing\14.0\isoshell para sistemas de 32 bits y escriba instalar como el valor del registro.Enter SOFTWARE\Wow6432Node\Microsoft\DevDiv\vs\Servicing\14.0\isoshell for 64-bit systems or SOFTWARE\Microsoft\DevDiv\vs\Servicing\14.0\isoshell for 32-bit systems, and enter Install as the registry value. Haga clic en Siguiente.Click Next.

  20. En el ¿qué desea hacer con el valor? panel, escriba este producto requiere la 2015 aislado Shell redistribuible de Visual Studio esté instalado.In the What do you want to do with the value? pane, enter This product requires the Visual Studio 2015 Isolated Shell Redistributable to be installed. como el texto de presentación y haga clic en finalizar.as the display text and click Finish.

  21. Vuelva a generar la solución de shell aislado para crear el proyecto de instalación.Rebuild the isolated shell solution to create the setup project.

    Puede encontrar el archivo setup.exe en la carpeta siguiente:You can find the setup.exe file in the following folder:

    \MyVSShellStub\MySetup\MySetup\Express\SingleImage\DiskImages\DISK1\MyVSShellStub\MySetup\MySetup\Express\SingleImage\DiskImages\DISK1

Probar el programa de instalaciónTesting the Installation Program

Para probar el programa de instalación, copie el archivo setup.exe en un equipo diferente y ejecutar el archivo ejecutable de instalación.To test the setup, copy the setup.exe file to a different computer and run the Setup executable. Debe ser capaz de ejecutar la aplicación de shell aislado.You should be able to run the isolated shell application.