Introducción a Visual Studio y UnityGet started with Visual Studio and Unity

Nota

En esta guía se da por supuesto que ya tiene instalado Unity con el programa de Unity Hub.This guide assumes you already have installed Unity using the Unity Hub program. Si no está familiarizado con Unity, se recomienda visitar Unity Learn y completar primero la ruta de aprendizaje de Unity Essentials .If you are new to Unity, we recommend visiting Unity Learn and complete the Unity Essentials learning path first.

Instalación de la compatibilidad de Unity con Visual StudioInstall Unity support for Visual Studio

Visual Studio Tools para Unity es una extensión gratuita que proporciona compatibilidad para escribir y depurar C# y mucho más.Visual Studio Tools for Unity is a free extension that provides support for writing and debugging C# and more. Visite la Introducción a Tools para Unity para obtener una lista completa de lo que incluye las extensiones.Visit the Tools for Unity overview for a complete list of what the extensions includes.

Nota

Esta guía de instalación es para Visual Studio.This installation guide is for Visual Studio. Si usa Visual Studio Code, visite la documentación de desarrollo de Unity con vs Code.If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

  1. Descargue el instalador de Visual Studioo ejecútelo si ya está instalado.Download the Visual Studio installer, or run it if already installed.

  2. Haga clic en Modificar (si ya está instalado) o en Instalar (si es una nueva instalación) para la versión de Visual Studio que prefiera.Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. En la pestaña cargas de trabajo , desplácese hasta la sección juegos y seleccione la carga de trabajo desarrollo de juegos con Unity .On the Workloads tab, scroll to the Gaming section and select the Game development with Unity workload.

    Cuadro de carga de trabajo desarrollo de juegos con Unity en el instalador

Nota

Esta guía de instalación es para Visual Studio para Mac.This installation guide is for Visual Studio for Mac. Si usa Visual Studio Code, visite la documentación de desarrollo de Unity con vs Code.If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

Tools para Unity se incluye con la instalación de Visual Studio para Mac y no se requiere ningún paso de instalación independiente.Tools for Unity is included with the installation of Visual Studio for Mac and no separate installation steps are required. Puede comprobarlo en el menú extensiones de Visual Studio para Mac > > desarrollo de juegos .You can verify this in the Visual Studio for Mac > Extensions > Game Development menu. Las herramientas de Visual Studio para Mac para Unity deben estar habilitadas.Visual Studio for Mac Tools for Unity should be enabled.

Vista del administrador de extensiones que muestra Visual Studio para Mac Tools para Unity habilitado

Buscar actualizacionesCheck for updates

Se recomienda mantener Visual Studio y Visual Studio para Mac actualizados para que tenga las correcciones de errores, las características y la compatibilidad con Unity más recientes.It's recommended to keep Visual Studio and Visual Studio for Mac updated so you have the latest bug fixes, features, and Unity support. Esto no requiere una actualización de las versiones de Unity.This doesn't require an update of Unity versions.

  1. Haga clic en el menú ayuda > buscar actualizaciones .Click the Help > Check for Updates menu.

    El menú buscar actualizaciones en Visual Studio 2019

  2. Si hay una actualización disponible, el Instalador de Visual Studio mostrará una nueva versión.If there is an update available, the Visual Studio Installer will show a new version. Haga clic en el botón Actualizar.Click the Update button.

  1. Haga clic en la Visual Studio para Mac > menú buscar actualizaciones... para abrir el cuadro de diálogo actualización de Visual Studio .Click the Visual Studio for Mac > Check for Updates... menu to open the Visual Studio Update dialog.
  2. Si hay una actualización disponible, haga clic en el botón instalar .If there is an update available, click the Install button.

Configuración de Unity para usar Visual StudioConfigure Unity to use Visual Studio

De forma predeterminada, Unity ya debe estar configurado para usar Visual Studio o Visual Studio para Mac como editor de scripts.By default, Unity should already be configured to use Visual Studio or Visual Studio for Mac as a script editor. Puede confirmarlo o cambiar el editor de scripts externo a una versión específica de Visual Studio desde el editor de Unity.You can confirm this or change the external script editor to a specific version of Visual Studio from the Unity Editor.

  1. En el editor de Unity, seleccione el menú Editar preferencias de > .In the Unity Editor, select the Edit > Preferences menu..

  2. Seleccione la pestaña herramientas externas a la izquierda.Select the External Tools tab on the left.

  3. La lista desplegable Editor de script externo proporciona una manera de elegir distintas instalaciones de Visual Studio.The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. También puede hacer clic en examinar... en la lista desplegable para agregar una versión que no esté en la lista.You can also click Browse... from the dropdown list to add an unlisted version.

    Menú de preferencias de herramientas externas en el editor de Unity en Windows

  4. Si Examinar... estaba seleccionado, vaya al directorio Common7/IDE dentro del directorio de instalación de Visual Studio y seleccione devenv.exe.If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. A continuación, haga clic en abrir.Then, click Open.

  5. Después de que Visual Studio se ha seleccionado en la lista External Script Editor (Editor de scripts externo), confirme que la casilla Editor Attaching (Asociación de editor) está activada.Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. Cierre el cuadro de diálogo Preferencias para completar el proceso de configuración.Close the Preferences dialog to complete the configuration process.

  1. En el editor de Unity, seleccione el menú de preferencias de > Unity .In the Unity Editor, select the Unity > Preferences menu..

  2. Seleccione la pestaña herramientas externas a la izquierda.Select the External Tools tab on the left.

  3. La lista desplegable Editor de script externo proporciona una manera de elegir distintas instalaciones de Visual Studio.The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. También puede hacer clic en examinar... en la lista desplegable para agregar una versión que no esté en la lista.You can also click Browse... from the dropdown list to add an unlisted version.

    Menú de preferencias de herramientas externas en el editor de Unity en macOS

  4. Cierre el cuadro de diálogo Preferencias para completar el proceso de configuración.Close the Preferences dialog to complete the configuration process.

Pasos siguientesNext steps

Para obtener información sobre cómo trabajar con el proyecto de Unity y depurarlo en Visual Studio, visite uso de Visual Studio Tools para Unity.To learn how to work with and debug your Unity project in Visual Studio, visit Using Visual Studio Tools for Unity.