Uso de Visual Studio Tools para UnityUse Visual Studio Tools for Unity

En esta sección aprenderá a utilizar las características de productividad e integración de Visual Studio Tools para Unity y cómo utilizar al depurador de Visual Studio para el desarrollo en Unity.In this section, you'll learn how to use Visual Studio Tools for Unity's integration and productivity features, and how to use the Visual Studio debugger for Unity development.

Abrir scripts de Unity en Visual StudioOpen Unity scripts in Visual Studio

Una vez que Visual Studio se establece como el editor externo para Unity, al hacer doble clic en un script del editor de Unity se iniciará automáticamente o se cambiará a Visual Studio y se abrirá el script elegido.Once Visual Studio is set as the external editor for Unity, double-clicking a script from the Unity editor will automatically launch or switch to Visual Studio and open the chosen script.

Como alternativa, puede abrir Visual Studio sin ningún script abierto en el editor de código fuente seleccionando el menú activos > abrir proyecto de C# en Unity.Alternatively, you can open Visual Studio with no script open in the source editor by selecting the Assets > Open C# Project menu in Unity.

Abrir el proyecto de C# en Visual Studio

Abra el proyecto de C# en Visual Studio para Mac

Acceso a la documentación de UnityUnity documentation access

Puede acceder rápidamente a la documentación de creación de scripts de Unity desde Visual Studio.You can access the Unity scripting documentation quickly from Visual Studio. Si Visual Studio Tools para Unity no encuentra localmente la documentación de la API, intentará encontrarla en línea.If Visual Studio Tools for Unity doesn't find the API documentation locally, it will try to find it online.

  • En Visual Studio, resalte o coloque el cursor sobre la API de Unity sobre la que quiere obtener información y, después, presione Ctrl+Alt+M , Ctrl+HIn Visual Studio, highlight or place the cursor over the Unity API you want to learn about, then press Ctrl+Alt+M , Ctrl+H
  • También puede usar el menú ayuda > referencia de API de Unity en lugar del KeyBinding.You can also use the Help > Unity API Reference menu instead of the keybinding. Menú de referencia de la API de Unity en Visual StudioThe Unity API Reference menu in Visual Studio
  • En Visual Studio para Mac, resalte o coloque el cursor sobre la API de Unity sobre la que desea obtener información y, a continuación, presione cmd + 'In Visual Studio for Mac, highlight or place the cursor over the Unity API you want to learn about, then press Cmd+'
  • También puede usar el menú ayuda > referencia de API de Unity en lugar del KeyBinding.You can also use the Help > Unity API Reference menu instead of the keybinding. Menú de referencia de la API de Unity en Visual Studio para MacThe Unity API Reference menu in Visual Studio for Mac

IntelliSense para mensajes de API de UnityIntellisense for Unity API Messages

La integridad del código de IntelliSense facilita la implementación de mensajes de la API de Unity en scripts de MonoBehaviour y ayuda a conocer cómo funciona esta API.Intellisense code-completion makes it easy to implement Unity API messages in MonoBehaviour scripts, and assists with learning the Unity API. Para usar IntelliSense para mensajes de Unity:To use IntelliSense for Unity messages:

  1. Coloque el cursor en una nueva línea dentro del cuerpo de una clase que se derive de MonoBehaviour.Place the cursor on a new line inside the body of a class that derives from MonoBehaviour.

  2. Comience a escribir el nombre de un mensaje de Unity, como OnTriggerEnter.Begin typing the name of a Unity message, such as OnTriggerEnter.

  3. Una vez que haya escrito las letras " ontri ", aparece una lista de sugerencias de IntelliSense.Once the letters " ontri " have been typed, a list of IntelliSense suggestions appears.

Uso de IntelliSense en Visual Studio

  1. La selección de la lista se puede cambiar de tres maneras:The selection on the list can be changed in three ways:

    • Con las teclas de flecha arriba y abajo.With the Up and Down arrow keys.

    • Al hacer clic con el mouse en el elemento deseado.By clicking with the mouse on the desired item.

    • Al seguir escribiendo el nombre del elemento deseado.By continuing to type the name of the desired item.

  2. IntelliSense puede insertar el mensaje de Unity seleccionado, incluidos todos los parámetros necesarios:IntelliSense can insert the selected Unity message, including any necessary parameters:

    • Al presionar Tab.By pressing Tab.

    • Al presionar Entrar.By pressing Enter.

    • Al hacer doble clic en el elemento seleccionado.By double-clicking the selected item.

Inserción de mensajes de Unity de IntelliSense en Visual Studio

Asistente de scripting de MonoBehavior de UnityUnity MonoBehavior scripting wizard

Puede usar al asistente de MonoBehavior para ver una lista de todos los métodos de API de Unity e implementar rápidamente una definición vacía.You can use the MonoBehavior wizard to view a list of all the Unity API methods and quickly implement an empty definition. Esta característica, especialmente con la opción Generar comentarios de método habilitada, es útil si todavía está aprendiendo lo que está disponible en la API de Unity.This feature, particularly with the Generate method comments option enabled, is helpful if you are still learning what's available in the Unity API.

Para crear definiciones vacías de método MonoBehavior con el asistente de MonoBehavior, siga estos pasos:To create empty MonoBehavior method definitions with the MonoBehavior wizard:

  1. En Visual Studio, coloque el cursor donde quiera que se inserten los métodos y, después, presione Ctrl+Mayús+M para iniciar el asistente de MonoBehavior.In Visual Studio, position the cursor where you want the methods to be inserted, then press Ctrl+Shift+M to launch the MonoBehavior wizard. En Visual Studio para Mac, presione cmd + Shift + M.In Visual Studio for Mac, press Cmd+Shift+M.

  2. En la ventana Crear métodos de script , marque la casilla junto al nombre de cada método que quiere agregar.In the Create script methods window, mark the checkbox next to the name of each method you want to add.

  3. Use la lista desplegable Versión de marco de trabajo para seleccionar la versión que desee.Use the Framework version dropdown to select your desired version.

  4. De forma predeterminada, los métodos se insertan en la posición del cursor.By default, the methods are inserted at the position of the cursor. Como alternativa, puede elegir insertarlos después de cualquier método que esté ya implementado en la clase si cambia el valor de la lista desplegable Punto de inserción por la ubicación que desee.Alternatively, you can choose to insert them after any method that's already implemented in your class by changing the value of the Insertion point dropdown to the location you want.

  5. Si quiere que el asistente genere los comentarios de los métodos que ha seleccionado, marque la casilla Generar comentarios de métodos.If you want the wizard to generate comments for the methods you selected, mark the Generate method comments checkbox. Estos comentarios están diseñados para ayudarlo a entender cuando se llama al método y cuáles son sus responsabilidades generales.These comments are meant to help you understand when the method is called and what its general responsibilities are.

  6. Seleccione el botón Aceptar para salir del asistente e insertar los métodos en el código.Choose the OK button to exit the wizard and insert the methods into your code.

Cuadro de diálogo del asistente de monobehavior en Visual Studio.

El cuadro de diálogo Asistente de monobehavior en Visual Studio para Mac.

Explorador de proyectos de UnityUnity Project Explorer

El Explorador de proyectos de Unity muestra todos los archivos de proyecto y directorios de Unity de la misma manera que el Editor de Unity.The Unity Project Explorer shows all of your Unity project files and directories in the same way that the Unity Editor does. La experiencia es diferente a navegar por los scripts de Unity con el Explorador de soluciones de Visual Studio normal, que los organiza en proyectos y una solución generada por Visual Studio.This is different than navigating your Unity scripts with the normal Visual Studio Solution Explorer, which organizes them into projects and a solution generated by Visual Studio.

  • En el menú principal de Visual Studio, seleccione Ver > Explorador de proyectos de Unity.On the main Visual Studio menu, choose View > Unity Project Explorer. Método abreviado de teclado: Alt + Shift + E  ver la ventana Explorador de proyectos de Unity.Keyboard shortcut: Alt+Shift+E View the Unity Project Explorer window.
  • En Visual Studio para Mac, el Panel de solución se comporta automáticamente de esta manera cuando se abre un proyecto de Unity.In Visual Studio for Mac, the Solution Pad automatically behaves like this when a Unity project is opened.

Depuración de UnityUnity debugging

Visual Studio Tools para Unity permite depurar scripts de editor y juego del proyecto de Unity mediante el potente depurador de Visual Studio.Visual Studio Tools for Unity lets you debug both editor and game scripts for your Unity project using Visual Studio's powerful debugger.

Depuración en el editor de UnityDebug in the Unity editor

Iniciar depuraciónStart debugging

  1. Conecte Visual Studio a Unity haciendo clic en el botón Reproducir llamado Attach to Unity (Asociar a Unity), o use el método abreviado de teclado F5.Connect Visual Studio to Unity by clicking the Play button labeled Attach to Unity , or use the keyboard shortcut F5. Haga clic en Reproducir en Visual StudioClick Play in Visual Studio
  1. Conecte Visual Studio a Unity al hacer clic en el botón Reproducir o escriba Comando + Entrar o F5.Connect Visual Studio to Unity by clicking the Play button, or type Command + Return , or F5. Haga clic en reproducir en Visual Studio para MacClick Play in Visual Studio for Mac
  1. Vaya a Unity y haga clic en el botón Reproducir para ejecutar el juego en el editor.Switch to Unity and click the Play button to run the game in the editor.

Haga clic en reproducir en Unity en Windows

Haga clic en reproducir en Unity en macOS

  1. Cuando se ejecuta el juego en el editor de Unity mientras se está conectado a Visual Studio, cualquier punto de interrupción detectado detiene la ejecución del juego y muestra la línea de código donde el juego alcanza el punto de interrupción en Visual Studio.When the game is running in the Unity editor while connected to Visual Studio, any breakpoints encountered will pause execution of the game and bring up the line of code where the game hit the breakpoint in Visual Studio.

Detener depuraciónStop debugging

Haga clic en el botón Detener en Visual Studio o use el método abreviado de teclado MAYÚS+F5.Click the Stop button in Visual Studio, or use the keyboard shortcut Shift + F5. Haga clic en Detener en Visual StudioClick Stop in Visual Studio

Haga clic en el botón Detener de Visual Studio para Mac o presione Mayús + Comando + Entrar.Click the Stop button in Visual Studio for Mac, or press Shift + Command + Return. Haga clic en detener en Visual Studio para MacClick Stop in Visual Studio for Mac

Para más información sobre la depuración en Visual Studio, consulte Primer vistazo al depurador de Visual Studio.To learn more about debugging in Visual Studio, see First look at the Visual Studio Debugger.

Asociar a Unity y reproducirAttach to Unity and Play

Para mayor comodidad, puede cambiar el botón Attach to Unity (Asociar a Unity) al modo Attach to Unity and Play (Asociar a Unity y reproducir).For added convenience, you can change the Attach to Unity button to Attach to Unity and Play mode.

  1. Haga clic en la pequeña flecha abajo junto al botón Attach to Unity (Asociar a Unity).Click the small down arrow next to the Attach to Unity button.
  2. Seleccione Attach to Unity and Play (Asociar a Unity y reproducir) en el menú desplegable.Select Attach to Unity and Play from the dropdown menu. Adjuntar y reproducir en Visual StudioAttach and play in Visual Studio

El botón Reproducir pasa a llamarse Attach to Unity and Play (Asociar a Unity y reproducir).The play button becomes labeled Attach to Unity and Play. Al hacer clic en este botón o usar el método abreviado de teclado F5 ahora se cambia automáticamente al editor de Unity y se ejecuta el juego en el editor; también se asocia el depurador de Visual Studio.Clicking this button or using the keyboard shortcut F5 now automatically switches to the Unity editor and runs the game in the editor, in addition to attaching the Visual Studio debugger.

El inicio de la depuración y la reproducción del editor Unity se pueden llevar a cabo en un solo paso directamente desde Visual Studio para Mac eligiendo la configuración Asociar a Unity y jugar.Starting debugging and playing the Unity editor can be completed in a single step directly from Visual Studio for Mac by choosing the Attach to Unity and Play configuration.

Seleccione asociar a Unity y reproducir en Visual Studio para Mac

Nota

Si inició la depuración con la configuración de adjuntar a Unity y reproducir , el botón detener también detendrá el editor de Unity.If you started debugging using the Attach to Unity and Play configuration, the Stop button will also stop the Unity Editor.

Depuración de las compilaciones del reproductor de UnityDebug Unity player builds

Puede depurar las compilaciones de desarrollo de reproductores de Unity con Visual Studio.You can debug development builds of Unity players with Visual Studio.

Habilitación de la depuración de scripts en un reproductor de UnityEnable script debugging in a Unity player

  1. En Unity, seleccione File > Build Settings (Archivo > Configuración de compilación) para abrir la configuración de compilación.In Unity, open the Build Settings by selecting File > Build Settings.

  2. En la ventana de configuración de compilación, marque las casillas Development Build (Compilación de desarrollo) y Script Debugging (Depuración de scripts).In the Build Settings window, mark the Development Build and Script Debugging checkboxes.

    Establezca la configuración de compilación de Unity para la depuración.Configure the Unity build settings for debugging.

Selección de una instancia de Unity a la que asociar el depuradorSelect a Unity instance to attach the debugger to

  • En el menú principal de Visual Studio, elija Depurar > Asociar depurador de Unity.In Visual Studio, on the main menu, choose Debug > Attach Unity Debugger.

    Asocie el depurador de Unity.Attach the debugger of Unity.

    En el cuadro de diálogo Seleccionar instancia de Unity se muestra información sobre cada instancia de Unity a la que puede conectarse.The Select Unity Instance dialog displays some information about each Unity instance that you can connect to.

    Elija una instancia de Unity a la que conectarse.Choose an instance of Unity to connect to.

    ProyectoProject

    El nombre del proyecto de Unity que se está ejecutando en esta instancia de Unity.The name of the Unity project that's running in this instance of Unity.

    Equipo Nombre del equipo o dispositivo en el que se está ejecutando esta instancia de Unity.Machine The name of the computer or device that this instance of Unity is running on.

    Tipo Editor si esta instancia de Unity se está ejecutando como parte del Editor de Unity; Reproductor si esta instancia de Unity es un reproductor independiente.Type Editor if this instance of Unity is running as part of the Unity Editor; Player if this instance of Unity is a stand-alone player.

    Puerto Número de puerto del socket UDP a través del que se está comunicando esta instancia de Unity.Port The port number of the UDP socket that this instance of Unity is communicating over.

Importante

Dado que Visual Studio Tools para Unity y la instancia de Unity se comunican a través de un socket de red UDP, el Firewall puede necesitar regla para permitirlo.Because Visual Studio Tools for Unity and the Unity instance are communicating over a UDP network socket, your firewall may need rule to allow it. Si es necesario, es posible que vea un símbolo del sistema, tendrá que autorizar la conexión para que VSTU y Unity puedan comunicarse.If needed, you may see a prompt, you'll have to authorize the connection so that VSTU and Unity can communicate.

  • En Visual Studio para Mac, en el menú superior, elija ejecutar > asociar al proceso.In Visual Studio for Mac, on the top menu, choose Run > Attach to Process.
  • En el cuadro de diálogo asociar al proceso , seleccione la opción depurador de Unity en el menú desplegable del depurador en la parte inferior.In the Attach to Process dialog, select Unity Debugger option in the Debugger drop-down menu at the bottom.
  • Seleccione una instancia de Unity en la lista y haga clic en el botón adjuntar .Select a Unity instance from the list and click the Attach button.

Depurar un archivo DLL en un proyecto de UnityDebug a DLL in your Unity project

Muchos desarrolladores de Unity están escribiendo componentes de código como archivos DLL externos para que la funcionalidad que desarrollan pueda compartirse fácilmente con otros proyectos.Many Unity developers are writing code components as external DLLs so that the functionality they develop can be easily shared with other projects. Visual Studio Tools para Unity facilita la depuración sin problemas del código de estos archivos DLL con otro código de su proyecto de Unity.Visual Studio Tools for Unity makes it easy to debug code in these DLLs seamlessly with other code in your Unity project.

Nota

En este momento, Visual Studio Tools para Unity solo admite archivos DLL administrados.At this time, Visual Studio Tools for Unity only supports managed DLLs. No admite la depuración de archivos DLL de código nativo, como los escritos en C++.It does not support debugging of native code DLLs, such as those written in C++.

Tenga en cuenta que el escenario descrito aquí supone que tiene el código fuente, es decir, que está desarrollando o reutilizando su propio código o que tiene el código fuente de una biblioteca de terceros y planea implementarlo en su proyecto de Unity como un archivo DLL.Note that the scenario described here assumes that you have the source code—that is, you are developing or re-using your own first-party code, or you have the source code to a third-party library, and plan to deploy it in your Unity project as a DLL. Este escenario no describe la depuración de un archivo DLL del que usted no dispone el código fuente.This scenario does not describe debugging a DLL for which you do not have the source code.

Para depurar un proyecto de archivo DLL administrado utilizado en su proyecto de UnityTo debug a managed DLL project used in your Unity project

  1. Agregue su proyecto DLL existente a la solución de Visual Studio generada por Visual Studio Tools para Unity.Add your existing DLL project to the Visual Studio solution generated by Visual Studio Tools for Unity. Con menor frecuencia, puede que inicie un nuevo proyecto DLL administrado para que contenga componentes de código en su proyecto de Unity. De ser así, puede agregar un nuevo proyecto DLL administrado a la solución de Visual Studio en su lugar.Less commonly, you might be starting a new managed DLL project to contain code components in your Unity project; if that's the case, you can add a new managed DLL project to the Visual Studio solution instead.

    Agregar el proyecto DLL existente a la solución.Add your existing DLL project to the solution.

    En ambos casos, Visual Studio Tools para Unity mantiene la referencia del proyecto, aunque tenga que volver a generar los archivos de proyecto y solución, para que solo tenga que realizar estos pasos una vez.In either case, Visual Studio Tools for Unity maintains the project reference, even if it has to regenerate the project and solution files again, so you only need to perform these steps once.

  2. Haga referencia al perfil de .NET Framework de Unity correcto en el proyecto DLL.Reference the correct Unity framework profile in the DLL project. En Visual Studio, en las propiedades del proyecto DLL, establezca la propiedad Framework de destino en la versión de .NET Framework de Unity que esté usando.In Visual Studio, in the DLL project's properties, set the Target framework property to the Unity framework version you're using. Esta es la Biblioteca de clases base de Unity que coincide con la compatibilidad con la API que su proyecto tiene definido como destino, como las bibliotecas de clases base completas, micro o web de Unity.This is the Unity Base Class Library that matches the API compatibility that your project targets, such as the Unity full, micro, or web base class libraries. Esto impide que el archivo DLL llame a métodos de .NET Framework que existan en otros niveles de compatibilidad o marcos de trabajo, pero que podrían no existir en la versión de .NET Framework de Unity que esté utilizando.This prevents your DLL from calling framework methods that exist in other frameworks or compatibility levels, but which might not exist in the Unity framework version you're using.

Nota

Lo siguiente solo es necesario si usa el entorno de ejecución heredado de Unity.The following is only required if you are using Unity's legacy runtime. Si usa el nuevo entorno de ejecución de Unity, ya no necesita usar los perfiles 3.5 dedicados.If you are using the new Unity runtime, you don't need to use those dedicated 3.5 profiles anymore. Use un perfil .NET 4.x compatible con su versión de Unity.Use a .NET 4.x profile compatible with your Unity version.

Establezca como plataforma de destino de DLL la plataforma Unity.Set the DLL's target framework to Unity framework.

  1. Copie el archivo DLL en la carpeta Activos del proyecto de Unity.Copy the DLL to your Unity project's Asset folder. En Unity, son activos los archivos que se empaquetan e implementan junto con la aplicación de Unity para que se puedan cargar en tiempo de ejecución.In Unity, assets are files that are packaged and deployed together with your Unity app so that they can be loaded at run-time. Puesto que los archivos DLL se vinculan en tiempo de ejecución, se deben implementar como recursos.Since DLLs are linked at run time, DLLs must be deployed as assets. Para que los archivos DLL se implementen como activos, el Editor de Unity necesita que se coloquen en la carpeta Activos del proyecto Unity.To be deployed as an asset, the Unity Editor requires the DLLs to be put inside the Assets folder in your Unity project. Puede hacer esto de dos formas:There are two ways you can do this:

    • Modificar la configuración de compilación del proyecto DLL para que incluya una tarea integrada a posteriori que copie los archivos DLL y PDB de salida de la carpeta de salida en la carpeta Activos del proyecto de Unity.Modify the build settings of your DLL project to include a post-built task that copies the output DLL and PDB files from its output folder to the Assets folder of your Unity project.

    • Modificar la configuración de compilación del proyecto DLL para establecer la carpeta de salida como la carpeta Activos del proyecto de Unity.Modify the build settings of your DLL project to set its output folder to be the Assets folder of your Unity project. Tanto los archivos DLL como PDB se colocarán en la carpeta Activos.Both DLL and PDB files will be placed in the Assets folder.

    Los archivos PDB son necesarios para la depuración porque contienen símbolos de depuración de los archivos DLL y asignan el código del archivo DLL a su forma de código fuente.The PDB files are needed for debugging because they contain the DLL's debugging symbols, and map the DLL code to its source code form. Si tiene como destino el entorno de ejecución heredado, Visual Studio Tools para Unity usará información de los archivos DLL y PDB para crear un archivo DLL.MDB, que es el formato de símbolo de depuración utilizado por el motor de scripting heredado de Unity.If you are targeting the legacy runtime, Visual Studio Tools for Unity will use information from the DLL and PDB to create a DLL.MDB file, which is the debug symbol format used by the legacy Unity scripting engine. Si tiene como destino el entorno de ejecución nuevo y usa archivos PDB portátiles, Visual Studio Tools para Unity no intentará realizar ninguna conversión de símbolo, porque el entorno de ejecución de Unity nuevo puede consumir archivos PDB portátiles de manera nativa.If you are targeting the new runtime, and using Portable-PDB, Visual Studio Tools for Unity will not try to do any symbol conversion as the new Unity runtime is able to natively consume Portable-PDBs.

    Puede encontrar más información sobre la generación de PDB aquí.More information about PDB generation can be found here. Si tiene como destino el entorno de ejecución nuevo, asegúrese de que la opción "Información de depuración" esté establecida en "Portátil" para así generar de manera adecuada archivos PDB portátiles.If you are targeting the new runtime, please make sure that "Debugging Information" is set to "Portable", in order to properly generate Portable-PDB. Si tiene como destino el entorno de ejecución heredado, debe usar "Full" (Completo).If you are targeting the legacy runtime, you need to use "Full".

  2. Depure el código que ha creado.Debug your code. Ahora puede depurar el código fuente de archivos DLL junto con el código fuente del proyecto de Unity y utilizar todas las características de depuración a las que está acostumbrado, como los puntos de interrupción y ejecutar código paso a paso.You can now debug your DLL source code together with your Unity project's source code, and use all the debugging features you are used to, such as breakpoints and stepping through code.

Métodos abreviados de tecladoKeyboard shortcuts

Puede acceder rápidamente a las herramientas de Unity para la funcionalidad de Visual Studio mediante el uso de los métodos abreviados de teclado.You can quickly access the Unity Tools for Visual Studio functionality by using their keyboard shortcuts. Este es un resumen de los métodos abreviados disponibles.Here's a summary of the shortcuts that are available.

ComandoCommand Acceso directoShortcut Nombre de comando de acceso directoShortcut command name
Abrir el asistente de MonoBehaviorOpen the MonoBehavior Wizard Ctrl+Mayús+MCtrl+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Abrir el Explorador de proyectos de UnityOpen the Unity Project Explorer Alt+Mayús+EAlt+Shift+E View.UnityProjectExplorerView.UnityProjectExplorer
Acceder a la documentación de UnityAccess Unity documentation Ctrl+Alt+M, Ctrl+HCtrl+Alt+M, Ctrl+H Help.UnityAPIReferenceHelp.UnityAPIReference
Adjuntar a depurador de Unity (reproductor o editor)Attach to Unity debugger (player or editor) sin valor predeterminadono default Debug.AttachUnityDebuggerDebug.AttachUnityDebugger

Si no le gusta el valor predeterminado, puede cambiar las combinaciones de teclas de método abreviado.You can change the shortcut key combinations if you don't like the default. Para obtener información sobre cómo cambiarlo, vea Identificar y personalizar métodos abreviados de teclado en Visual Studio.For information on how to change it, see Identify and customize keyboard shortcuts in Visual Studio.

ComandoCommand Acceso directoShortcut Nombre de comando de acceso directoShortcut command name
Abrir el asistente de MonoBehaviorOpen the MonoBehavior Wizard Cmd + Desplazamiento + MCmd+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Acceder a la documentación de UnityAccess Unity documentation Cmd + 'Cmd+' Help.UnityAPIReferenceHelp.UnityAPIReference

Si no le gusta el valor predeterminado, puede cambiar las combinaciones de teclas de método abreviado.You can change the shortcut key combinations if you don't like the default. Para obtener información sobre cómo cambiarlo, vea personalizar el IDE.For information on how to change it, see Customizing the IDE.