Cómo: Actualizar plantillas existentesHow to: Update existing templates

Después de crear una plantilla y comprimir los archivos en un archivo .zip, es posible que desee modificarla.After you create a template and compress the files into a .zip file, you may want to modify the template. Puede hacerlo al cambiar los archivos de la misma de forma manual o al exportar una nueva plantilla de un proyecto basado en la plantilla.You can do this by manually changing the files in the template, or by exporting a new template from a project that is based on the template.

Uso del Asistente para exportar plantillas para actualizar una plantilla de proyectoUsing the Export Template Wizard to update an existing project template

Visual Studio proporciona un Asistente para exportar plantillas que se puede usar para actualizar una plantilla:Visual Studio provides an Export Template Wizard that can be used to update an existing template:

  1. Abra el cuadro de diálogo Nuevo proyecto eligiendo Archivo > Nuevo > Proyecto.Open the New Project dialog box by choosing File > New > Project.

  2. Seleccione la plantilla que quiera actualizar, escriba un nombre y una ubicación para el proyecto y elija Aceptar.Select the template that you want to update, enter a name and location for your project, and choose OK.

  3. Modifique el proyecto en Visual Studio.Modify the project in Visual Studio.

  4. En el menú Proyecto, elija Exportar plantilla.On the Project menu, choose Export Template.

    Se abre el Asistente para exportar plantillas.The Export Template Wizard opens.

  5. Siga las indicaciones del asistente para exportar la plantilla como un archivo .zip.Follow the prompts in the wizard to export the template as a .zip file.

  6. (Opcional) Para agregar la plantilla al cuadro de diálogo Nuevo proyecto, coloque el archivo .zip en este directorio: %USERPROFILE%\Documentos\Visual Studio <versión>\Templates\ProjectTemplates.(Optional) To add the template to the New Project dialog box, place the .zip file in the following directory: %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates. Tendrá que completar este paso si no ha seleccionado la opción Importar la plantilla automáticamente en Visual Studio del Asistente para exportar plantillas.You'll need to perform this step if you did not select the option Automatically import the template into Visual Studio in the Export Template Wizard.

  7. Elimine el archivo .zip de la plantilla antigua.Delete the old template .zip file.

Actualizar manualmente una plantilla existenteManually update an existing template

Para actualizar una plantilla sin usar el Asistente para exportar plantillas, modifique los archivos del archivo .zip comprimido.You can update an existing template without using the Export Template Wizard, by modifying the files in the compressed .zip file.

Para actualizar manualmente una plantilla existenteTo manually update an existing template

  1. Busque el archivo .zip que contiene la plantilla.Locate the .zip file that contains the template. Las plantillas de proyecto del usuario están en %USERPROFILE%\Documentos\Visual Studio <versión>\Templates\ProjectTemplates.User project templates are located at %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates.

  2. Extraiga el archivo .zip.Extract the .zip file.

  3. Modifique o elimine los archivos de plantilla actuales, o agregue nuevos archivos a la plantilla.Modify or delete the current template files, or add new files to the template.

  4. Abra, modifique y guarde el archivo XML .vstemplate para controlar el comportamiento actualizado o los nuevos archivos.Open, modify, and save the .vstemplate XML file to handle updated behavior or new files.

    Para obtener más información sobre el esquema .vstemplate, vea Referencia de esquema de plantilla de Visual Studio (Extensibilidad).For more information about the .vstemplate schema, see Visual Studio template schema reference (extensibility). Para más información sobre lo que se puede parametrizar en los archivos de origen, vea Parámetros de plantilla.For more information about what you can parameterize in the source files, see Template parameters.

  5. Seleccione los archivos en la plantilla y, desde el menú contextual, elija Enviar a > Carpeta comprimida (en zip).Select the files in your template, and from the right-click or context menu, and choose Send to > Compressed (zipped) folder.

    Los archivos seleccionados se comprimen en un archivo .zip.The files that you selected are compressed into a .zip file.

  6. Coloque el nuevo archivo .zip en el mismo directorio que el antiguo.Put the new .zip file in the same directory as the old .zip file.

  7. Elimine los archivos de plantilla extraídos y el archivo .zip de plantilla antiguo.Delete the extracted template files and the old template .zip file.

Vea tambiénSee also