Administrar herramientas externasManage external tools

Se puede llamar a herramientas externas desde Visual Studio mediante el menú Herramientas.You can call external tools from inside Visual Studio by using the Tools menu. Algunas herramientas predeterminadas están disponibles en el menú Herramientas, pero se puede personalizar el menú al agregar otros archivos ejecutables propios.A few default tools are available from the Tools menu, and you can customize the menu by adding other executables of your own.

Herramientas disponibles en el menú HerramientasTools available on the Tools menu

El menú Herramientas contiene varios comandos integrados, como:The Tools menu contains several built-in commands, including:

Agregar nuevas herramientas al menú HerramientasAdd new tools to the Tools menu

Puede agregar una herramienta externa para que aparezca en el menú Herramientas.You can add an external tool to appear on the Tools menu.

  1. Para abrir el cuadro de diálogo Herramientas externas, elija Herramientas > Herramientas externas.Open the External Tools dialog box by choosing Tools > External Tools.

  2. Haga clic en Agregar y, después, rellene la información.Click Add, and then fill in the information. Por ejemplo, la entrada siguiente hace que el Explorador de Windows se abra en el directorio del archivo que tiene abierto en Visual Studio:For example, the following entry causes Windows Explorer to open at the directory of the file you currently have open in Visual Studio:

    • Título: Open File LocationTitle: Open File Location

    • Comando: explorer.exeCommand: explorer.exe

    • Argumentos: /root, "$(ItemDir)"Arguments: /root, "$(ItemDir)"

    Cuadro de diálogo Herramientas externas

Lo siguiente es una lista completa de los argumentos que se pueden utilizar al definir una herramienta externa:The following is a full list of arguments that can be used when defining an external tool:

nombreName ArgumentoArgument DescripciónDescription
Ruta de acceso del elementoItem Path $(ItemPath)$(ItemPath) Nombre de archivo completo del archivo actual (unidad + ruta de acceso + nombre de archivo).The complete file name of the current file (drive + path + file name).
Directorio del elementoItem Directory $(ItemDir)$(ItemDir) Directorio del archivo actual (unidad + ruta de acceso).The directory of the current file (drive + path).
Nombre de archivo del elementoItem File Name $(ItemFilename)$(ItemFilename) Nombre de archivo del archivo actual (nombre de archivo).The file name of the current file (file name).
Extensión del elementoItem Extension $(ItemExt)$(ItemExt) Extensión del nombre de archivo del archivo actual.The file name extension of the current file.
Línea actualCurrent Line $(CurLine)$(CurLine) Posición de línea actual del cursor en la ventana de código.The current line position of the cursor in the code window.
Columna actualCurrent Column $(CurCol)$(CurCol) Posición de columna actual del cursor en la ventana de código.The current column position of the cursor in the code window.
Texto actualCurrent Text $(CurText)$(CurText) Texto seleccionado.The selected text.
Ruta de acceso de destinoTarget Path $(TargetPath)$(TargetPath) Nombre de archivo completo del elemento que se va a compilar (unidad + ruta de acceso + nombre de archivo).The complete file name of the item to be built (drive + path + file name).
Directorio de destinoTarget Directory $(TargetDir)$(TargetDir) Directorio del elemento que se va a compilar.The directory of the item to be built.
Nombre de destinoTarget Name $(TargetName)$(TargetName) Nombre de archivo del elemento que se va a compilar.The file name of the item to be built.
Extensión de destinoTarget Extension $(TargetExt)$(TargetExt) Extensión del nombre de archivo del elemento que se va a compilar.The file name extension of the item to be built.
Directorio binarioBinary Directory $(BinDir)$(BinDir) Ubicación final del archivo binario que se va a compilar (definida como unidad + ruta de acceso).The final location of the binary that is being built (defined as drive + path).
Directorio del proyectoProject Directory $(ProjectDir)$(ProjectDir) Directorio del proyecto actual (unidad + ruta de acceso).The directory of the current project (drive + path).
Nombre de archivo del proyectoProject File Name $(ProjectFileName)$(ProjectFileName) Nombre de archivo del proyecto actual (unidad + ruta de acceso + nombre de archivo).The file name of the current project (drive + path + file name).
Directorio de la soluciónSolution Directory $(SolutionDir)$(SolutionDir) Directorio de la solución actual (unidad + ruta de acceso).The directory of the current solution (drive + path).
Nombre de archivo de la soluciónSolution File Name $(SolutionFileName)$(SolutionFileName) Nombre de archivo de la solución actual (unidad + ruta de acceso + nombre de archivo).The file name of the current solution (drive + path + file name).

Note

La barra de estado del IDE muestra las variables Línea actual y Columna actual para indicar dónde se encuentra el punto de inserción en el Editor de código activo.The IDE status bar displays the Current Line and Current Column variables to indicate where the insertion point is located in the active Code Editor. La variable Texto actual devuelve el texto o el código seleccionado en esa ubicación.The Current Text variable returns the text or code selected at that location.

Vea tambiénSee also