Personalizar el IDE de Visual StudioPersonalize the Visual Studio IDE

Puede personalizar Visual Studio de varias maneras para que se ajuste mejor a su propio estilo de desarrollo y a sus requisitos.You can personalize Visual Studio in various ways to best support your own development style and requirements. Muchos de los valores se traspasan a las distintas instancias de Visual Studio —consulte Configuración sincronizada.Many of your settings roam with you across Visual Studio instances—see Synchronized settings. En este artículo se describen brevemente las diferentes personalizaciones y se indica dónde encontrar más información.This article briefly describes different personalizations and where you can find more information.

Note

Este tema se aplica a Visual Studio para Windows.This topic applies to Visual Studio on Windows. En el caso de Visual Studio para Mac, vea Personalización del IDE de Visual Studio para Mac.For Visual Studio for Mac, see Customize the Visual Studio for Mac IDE.

Configuración predeterminadaDefault settings

Puede elegir una colección predeterminada de opciones que optimice Visual Studio para el tipo de desarrollo.You can choose a default collection of settings that optimizes Visual Studio for your type of development. Para obtener más información, vea Configuración del entorno.For more information, see Environment settings.

Opciones generales de entornoGeneral environment options

Muchas opciones de personalización se exponen en el cuadro de diálogo Opciones del entorno.Many personalization options are exposed through the Environment Options dialog box. Hay dos maneras de acceder a este cuadro de diálogo:There are two ways to access this dialog box:

  • En la barra de menús, elija Herramientas > Opciones y, si todavía no está expandido, expanda el nodo Entorno.On the menu bar, choose Tools > Options, and if it's not already expanded, expand the Environment node.

  • Presione Ctrl+Q, escriba entorno en el cuadro de búsqueda y elija Entorno --> General en los resultados.Press Ctrl+Q, type environment in the search box, and then choose Environment > General from the results.

Tip

Cuando aparezca el cuadro de diálogo Opciones, puede presionar F1 para obtener ayuda sobre las distintas opciones en esa página.When the Options dialog box appears, you can press F1 for help on the various settings on that page.

Temas de color de entornoEnvironment color themes

Para cambiar el tema de color entre claro, oscuro y azul, escriba entorno en el cuadro de búsqueda y elija Entorno > General.To change the color theme between light, dark and blue, type environment in the search box, and then choose Environment > General. En el cuadro de diálogo Opciones, cambie la opción Tema de color.In the Options dialog box, change the Color theme option.

Para cambiar las opciones de color en el editor, escriba entorno en el cuadro de búsqueda y elija Entorno > Fuentes y colores.To change colorization options in the editor, type environment in the search box, and then choose Environment > Fonts and Colors. Consulte Configuración de los Cambiar fuentes y colores.See How to: Change fonts and colors.

Puede cambiar el uso de mayúsculas en el menú principal y alternar entre tipo título ("Archivo") y Todo mayúsculas ("ARCHIVO").You can change the main menu casing between Title Case ("File") and All Caps ("FILE"). Escriba entorno en el cuadro de búsqueda, seleccione Entorno > General y cambie la opción Aplicar tipografía de título a la barra de menús.Type environment in the search box, select Environment > General, and then change the Apply title case styling to menu bar option.

Personalización de menús y barras de herramientasCustomize menus and toolbars

Para agregar o quitar elementos de menú o barra de herramientas, vea Cómo: Personalizar menús y barras de herramientas.To add or remove menu or toolbar items, see How to: Customize menus and toolbars.

Página de inicioStart page

Para crear una página de inicio personalizada para usted y su equipo, vea Personalizar la página de inicio.To create a custom start page for you and your team, see Customize the Start page.

Diseños de ventanaWindow layouts

Puede definir y guardar varios diseños de ventana y cambiar entre ellos.You can define and save multiple window layouts and switch between them. Por ejemplo, puede definir un diseño para añadir el código y otra para la depuración.For example, you can define one layout for coding and one for debugging. Para organizar las posiciones y el comportamiento de las ventanas y guardar los diseños personalizados, vea Personalizar los diseños de ventana.To arrange window positions and behavior and save custom layouts, see Customize window layouts.

Herramientas externasExternal tools

Puede personalizar el menú Herramientas para iniciar herramientas externas.You can customize the Tools menu to launch external tools. Para obtener más información, vea Administrar herramientas externas.For more information, see Manage external tools.

Vea tambiénSee also