Inicio rápido: uso del editor de códigoQuickstart: Use the code editor

En esta introducción de 10 minutos al editor de código, se agrega código a un archivo para ver algunas de las formas en que Visual Studio hace que escribir y comprender el código (así como desplazarse por él) sea más fácil.In this 10-minute introduction to the code editor in Visual Studio, we'll add code to a file to look at some of the ways that Visual Studio makes writing, navigating, and understanding code easier.

Si todavía no ha instalado Visual Studio, vaya a la página de descargas de Visual Studio para instalarlo de forma gratuita.If you haven't already installed Visual Studio, go to the Visual Studio downloads page to install it for free.

En este inicio rápido se presupone que ya está familiarizado con un lenguaje de programación.This quickstart assumes you're already familiar with a programming language. Si no lo está, le sugerimos que primero lea guías de inicio rápido de programación, como para crear una aplicación web con Python o C#, o bien crear una aplicación de consola con Visual Basic o C++.If you aren't, we suggest you look at one of the programming quickstarts first, such as create a web app with Python or C#, or create a console app with Visual Basic or C++.

Crear un archivo de códigoCreate a new code file

Empezaremos creando un archivo y agregándole código.Start by creating a new file and adding some code to it.

  1. Abra Visual Studio y, en el menú Archivo de la barra de menús, elija Nuevo > Archivo.Open Visual Studio, and from the File menu on the menu bar, choose New > File.

  2. En el cuadro de diálogo Nuevo archivo, en la categoría General, elija Clase de Visual C# y, después, elija Abrir.In the New File dialog box, under the General category, choose Visual C# Class, and then choose Open.

    Se abre un archivo nuevo en el editor con el esqueleto de una clase de C#.A new file opens in the editor with the skeleton of a C# class. (Observe que no es necesario crear un proyecto de Visual Studio completo para aprovechar algunas de las ventajas que ofrece el editor de código; lo único que se necesita es un archivo de código).(Notice that we don't have to create a full Visual Studio project to gain some of the benefits that the code editor offers; all you need is a code file!)

    Archivo de código de C# en Visual Studio

Uso de fragmentos de códigoUse code snippets

Visual Studio proporciona fragmentos de código muy prácticos que pueden servir para generar bloques de código de uso común de forma rápida y sencilla.Visual Studio provides useful code snippets that you can use to quickly and easily generate commonly used code blocks. Existen fragmentos de código disponibles para diferentes lenguajes de programación, como C#, Visual Basic y C++.Code snippets are available for different programming languages including C#, Visual Basic, and C++. Vamos a agregar el fragmento de código de C# void Main a nuestro archivo.Let's add the C# void Main snippet to our file.

  1. Coloque el cursor justo encima de la llave de cierre final } en el archivo y escriba los caracteres svm (que es el acrónimo de static void Main —no se preocupe demasiado si no sabe lo que significa).Place your cursor just above the final closing brace } in the file, and type the characters svm (which stands for static void Main—don't worry too much if you don't know what that means).

    Aparece un cuadro de diálogo emergente con información sobre el fragmento de código svm.A pop-up dialog box appears with information about the svm code snippet.

    IntelliSense para fragmento de código en Visual Studio

  2. Presione la tecla TAB dos veces para insertar el fragmento de código.Press Tab twice to insert the code snippet.

    Verá cómo la firma del método static void Main() se agrega al archivo.You see the static void Main() method signature get added to the file. El método Main() es el punto de entrada de las aplicaciones de C#.The Main() method is the entry point for C# applications.

Los fragmentos de código disponibles varían según el lenguaje de programación.The available code snippets vary for different programming languages. Para ver los fragmentos de código disponibles para el lenguaje, seleccione Editar > IntelliSense > Insertar fragmento de código y luego elija la carpeta del lenguaje.You can look at the available code snippets for your language by choosing Edit > IntelliSense > Insert Snippet, and then choosing your language's folder. En C#, la lista tiene el siguiente aspecto:For C#, the list looks like this:

Lista de fragmentos de código de C#

La lista incluye fragmentos de código para crear una clase, un constructor, un bucle for, una instrucción if o switch, etc.The list includes snippets for creating a class, a constructor, a for loop, an if or switch statement, and more.

Marcar código como comentarioComment out code

La barra de herramientas, que es la fila de botones debajo de la barra de menús de Visual Studio, puede ayudar a mejorar la productividad mientras se codifica.The toolbar, which is the row of buttons under the menu bar in Visual Studio, can help make you more productive as you code. Por ejemplo, puede alternar el modo de finalización de IntelliSense (IntelliSense es una ayuda de codificación que muestra una lista de métodos coincidentes, entre otras cosas), aumentar o reducir una sangría de línea o comentar el código que no quiere compilar.For example, you can toggle IntelliSense completion mode (IntelliSense is a coding aid that displays a list of matching methods, amongst other things), increase or decrease a line indent, or comment out code that you don't want to compile. En esta sección se comenta algún código.In this section, we'll comment out some code.

Barra de herramientas del editor

  1. Pegue el siguiente código en el cuerpo del método Main().Paste the following code into the Main() method body.

    // _words is a string array that we'll sort alphabetically
    string[] _words = {
        "the",
        "quick",
        "brown",
        "fox",
        "jumps"
    };
    
    string[] morewords = {
        "over",
        "the",
        "lazy",
        "dog"
    };
    
    IEnumerable<string> query = from word in _words
                                orderby word.Length
                                select word;
    
  2. No se usa la variable morewords, pero puede que sí se haga más adelante, así que no se elimina por completo.We're not using the morewords variable, but we may use it later so we don't want to completely delete it. En su lugar, lo que haremos será convertir esas líneas en comentarios.Instead, let's comment out those lines. Seleccione toda la definición de morewords hasta el punto y coma final, y luego haga clic en el botón Marcar como comentario las líneas seleccionadas en la barra de herramientas.Select the entire definition of morewords to the closing semi-colon, and then choose the Comment out the selected lines button on the toolbar. Si prefiere usar el teclado, presione Ctrl+K, Ctrl+C.If you prefer to use the keyboard, press Ctrl+K, Ctrl+C.

    Botón Marcar como comentario

    Los caracteres de comentario de C# // se agregan al principio de cada línea seleccionada para marcar el código como comentario.The C# comment characters // are added to the beginning of each selected line to comment out the code.

Contraer bloques de códigoCollapse code blocks

No se quiere ver el constructor vacío de Class1 generado, así que se contrae para despejar la vista del código.We don't want to see the empty constructor for Class1 that was generated, so to unclutter our view of the code, let's collapse it. Seleccione el pequeño cuadro gris con el signo menos que se ve en el margen de la primera línea del constructor.Choose the small gray box with the minus sign inside it in the margin of the first line of the constructor. Si prefiere usar el teclado, coloque el cursor en cualquier lugar en el código del constructor y presione Ctrl+M, Ctrl+M.Or, if you're a keyboard user, place the cursor anywhere in the constructor code and press Ctrl+M, Ctrl+M.

Botón para contraer de esquematización

El bloque de código se contrae para mostrar únicamente la primera línea seguida de un botón de puntos suspensivos (...).The code block collapses to just the first line, followed by an ellipsis (...). Para expandir el bloque de código de nuevo, haga clic en el mismo cuadro gris (que ahora tiene un signo más) o presione CTRL+M, CTRL+M otra vez.To expand the code block again, click the same gray box that now has a plus sign in it, or press Ctrl+M, Ctrl+M again. Esta característica se denomina Esquematización y es especialmente útil cuando se contraen métodos muy largos o clases enteras.This feature is called Outlining and is especially useful when you're collapsing long methods or entire classes.

Ver definiciones de símbolosView symbol definitions

Gracias al editor de Visual Studio, es muy sencillo inspeccionar la definición de un tipo, método, etc. Una forma consiste en ir al archivo que contiene la definición, por ejemplo, seleccionando Ir a definición en cualquier lugar donde se haga referencia al símbolo.The Visual Studio editor makes it easy to inspect the definition of a type, method, etc. One way is to navigate to the file that contains the definition, for example by choosing Go to Definition anywhere the symbol is referenced. Otra más rápida aún (y que no desplaza el enfoque del archivo en el que está trabajando) es usar Ver la definición.An even quicker way that doesn't move your focus away from the file you're working in is to use Peek Definition. Vamos a ver la definición del tipo string.Let's peek at the definition of the string type.

  1. Haga clic con el botón derecho en cualquier instancia de string y elija Ver la definición en el menú de contenido.Right-click on any occurrence of string and choose Peek Definition from the content menu. O bien, presione Alt+F12.Or, press Alt+F12.

    Se abrirá una ventana emergente con la definición de la clase String.A pop-up window appears with the definition of the String class. Puede desplazarse dentro de la ventana emergente o incluso ver la definición de otro tipo desde el código inspeccionado.You can scroll within the pop-up window, or even peek at the definition of another type from the peeked code.

    Ventana Ver la definición

  2. Para cerrar la ventana de definición inspeccionada, seleccione el pequeño cuadro con una "x" en la esquina superior derecha de la ventana emergente.Close the peeked definition window by choosing the small box with an "x" at the top right of the pop-up window.

Usar IntelliSense para completar palabrasUse IntelliSense to complete words

IntelliSense es un recurso impagable cuando se escribe código.IntelliSense is an invaluable resource when you're coding. Así, puede mostrar información sobre los miembros disponibles de un tipo o detalles de los parámetros para las distintas sobrecargas de un método.It can show you information about available members of a type, or parameter details for different overloads of a method. IntelliSense puede servir también para completar una palabra después de escribir una serie de caracteres y, así, eliminar cualquier tipo de ambigüedad.You can also use IntelliSense to complete a word after you type enough characters to disambiguate it. Se va a agregar una línea de código para imprimir las cadenas ordenadas en la ventana de la consola, que es el lugar estándar para la salida del programa.Let's add a line of code to print out the ordered strings to the console window, which is the standard place for output from the program to go.

  1. Empiece a escribir el siguiente código debajo de la variable query:Below the query variable, start typing the following code:

    foreach (string str in qu
    

    Verá cómo IntelliSense muestra Información rápida sobre el símbolo query.You see IntelliSense show you Quick Info about the query symbol.

    Finalización de palabras de IntelliSense en Visual Studio

  2. Presione Tab para insertar el resto de la palabra query por medio de la funcionalidad de finalización de palabras de IntelliSense.To insert the rest of the word query by using IntelliSense's word completion functionality, press Tab.

  3. Termine el bloque de código de modo que se parezca al siguiente código.Finish off the code block to look like the following code. Puede incluso practicar usando de nuevo fragmentos de código; para ello, escriba cw y, después, presione la tecla TAB dos veces para generar el código Console.WriteLine.You can even practice using code snippets again by entering cw and then pressing Tab twice to generate the Console.WriteLine code.

    foreach (string str in query)
    {
       Console.WriteLine(str);
    }
    

Refactorizar un nombreRefactor a name

Nadie crea código correctamente la primera vez y una de las cosas que probablemente se tengan que cambiar es el nombre de una variable o un método.Nobody gets code right the first time, and one of the things you might have to change is the name of a variable or method. Vamos a probar la funcionalidad de refactorización de Visual Studio para cambiar el nombre de la variable _words a words.Let's try out Visual Studio's refactor functionality to rename the _words variable to words.

  1. Coloque el cursor sobre la definición de la variable _words, haga clic con el botón derecho y elija Cambiar nombre en el menú contextual, o bien presione Ctrl+R, Ctrl+R.Place your cursor over the definition of the _words variable, and choose Rename from the right-click or context menu, or press Ctrl+R, Ctrl+R.

    Se abre un cuadro de diálogo emergente Cambiar nombre en la parte superior derecha del editor.A pop-up Rename dialog box appears at the top right of the editor.

  2. Escriba el nombre deseado, words.Enter the desired name words. Observe que la referencia a words en la consulta también cambia automáticamente de nombre.Notice that the reference to words in the query is also automatically renamed. Antes de presionar ENTRAR, active la casilla Incluir comentarios del cuadro emergente Cambiar nombre.Before you press Enter, select the Include comments checkbox in the Rename pop-up box.

    Cambiar nombre (cuadro de diálogo)

  3. Presione ENTRAR.Press Enter.

    Ambas instancias de words han cambiado de nombre, así como la referencia a words en el comentario de código.Both occurrences of words have been renamed, as well as the reference to words in the code comment.

Pasos siguientesNext steps

Ha completado este inicio rápido sobre el editor de Visual Studio.You've completed this Quickstart for the Visual Studio editor. A continuación, podría probar algunos de los otros tutoriales para el entorno de desarrollo de Visual Studio.Next, you might try out some of the other Quickstarts for the Visual Studio development environment.

Vea tambiénSee also