Guía de inicio rápido: primer vistazo al IDE de Visual StudioQuickstart: First look at the Visual Studio IDE

En esta introducción al entorno de desarrollo integrado (IDE) de Visual Studio, de 5 a 10 minutos de duración, pasaremos por algunas de las ventanas, menús y otras funciones de la interfaz de usuario.In this 5-10 minute introduction to the Visual Studio integrated development environment (IDE), we'll take a tour of some of the windows, menus, and other UI features.

Si todavía no ha instalado Visual Studio, vaya a la página de descargas de Visual Studio para instalarlo de forma gratuita.If you haven't already installed Visual Studio, go to the Visual Studio downloads page to install it for free.

Página de inicioStart Page

Probablemente lo primero que verá después de iniciar Visual Studio sea la página de inicio.The first thing you'll see after you launch Visual Studio is most likely the Start Page. La página de inicio está diseñada como un "concentrador" para ayudarle a encontrar los comandos y archivos de proyecto que necesita más rápidamente.The Start Page is designed as a "hub" to help you find the commands and project files you need faster. La sección Recientes muestra los proyectos y las carpetas en las que ha trabajado recientemente.The Recent section displays projects and folders you've worked on recently. En Nuevo proyecto, puede hacer clic en un vínculo para abrir el cuadro de diálogo Nuevo proyecto o bien en Abrir para abrir un proyecto o una carpeta de código existentes.Under New project, you can click a link to bring up the New Project dialog box, or under Open, you can open an existing code project or folder. A la derecha hay una fuente con las últimas noticias del desarrollador.On the right is a feed of the latest developer news.

Página de inicio en Visual Studio

Si cierra la página de inicio y quiere verla de nuevo, puede volver a abrirla desde el menú Archivo.If you close the Start Page and want to see it again, you can reopen it from the File menu.

Menú Archivo en Visual Studio

Crear un proyectoCreate a project

Para seguir examinando las características de Visual Studio, se va a crear un nuevo proyecto.To continue exploring Visual Studio's features, let's create a new project.

  1. En la página de inicio, en el cuadro de búsqueda de Nuevo proyecto, escriba console para filtrar la lista de tipos de proyecto a los que contengan "console" en su nombre.On the Start Page, in the search box under New project, type in console to filter the list of project types to those that contain "console" in their name.

    Búsqueda de plantillas de proyecto en la página de inicio de Visual Studio

    Visual Studio proporciona varios tipos de plantillas de proyecto que ayudan a comenzar a codificar rápidamente.Visual Studio provides various kinds of project templates that help you get started coding quickly. Elija una plantilla de proyecto Console App (.NET Framework) de C#.Choose a C# Console App (.NET Framework) project template. (Si es desarrollador de Visual Basic, C++, Javascript u otro lenguaje, también puede crear un proyecto en uno de esos lenguajes.(Alternatively, if you're a Visual Basic, C++, Javascript, or other language developer, feel free to create a project in one of those languages. La interfaz de usuario que se muestra es similar para todos los lenguajes de programación).The UI we'll be looking at is similar for all programming languages.)

  2. En el cuadro de diálogo Nuevo proyecto que aparece, acepte el nombre de proyecto predeterminado y haga clic en Aceptar.In the New Project dialog box that appears, accept the default project name and choose OK.

    Se crea el proyecto y se abre un archivo denominado Program.cs en la ventana Editor.The project is created and a file named Program.cs opens in the Editor window. En el Editor se muestra el contenido de los archivos y es donde se va a realizar la mayor parte del trabajo de codificación en Visual Studio.The Editor shows the contents of files, and is where you'll do most of your coding work in Visual Studio.

    Editor en Visual Studio

Explorador de solucionesSolution Explorer

En el Explorador de soluciones, que normalmente se encuentra en el lado derecho de Visual Studio, se muestra una representación gráfica de la jerarquía de los archivos y las carpetas del proyecto, la solución o la carpeta de código.Solution Explorer, which is typically on the right-hand side of Visual Studio, shows you a graphical representation of the hierarchy of files and folders in your project, solution, or code folder. En el Explorador de soluciones se puede examinar la jerarquía y navegar hasta un archivo.You can browse the hierarchy and navigate to a file in Solution Explorer.

Explorador de soluciones en Visual Studio

La barra de menús de la parte superior de Visual Studio agrupa los comandos en categorías.The menu bar along the top of Visual Studio groups commands into categories. Por ejemplo, el menú Proyecto contiene comandos relacionados con el proyecto en el que está trabajando.For example, the Project menu contains commands related to the project you're working in. En el menú Herramientas, se puede personalizar el comportamiento de Visual Studio mediante la selección de Opciones, o bien agregar características a la instalación mediante la selección de Obtener herramientas y características.On the Tools menu, you can customize how Visual Studio behaves by selecting Options, or add features to your installation by selecting Get Tools and Features.

Barra de menús en Visual Studio

Se abre la ventana Lista de errores mediante la selección del menú Ver y después Lista de errores.Let's open the Error List window by choosing the View menu, and then Error List.

Lista de erroresError List

En la Lista de errores se muestran los errores, las advertencias y los mensajes relacionados con el estado actual del código.The Error List shows you errors, warning, and messages regarding the current state of your code. Si se produjera algún error (por ejemplo, la falta de un paréntesis o un punto y coma) en el archivo o en cualquier parte del proyecto, se indicaría aquí.If there are any errors (such as a missing brace or semicolon) in your file, or anywhere in your project, they're listed here.

Lista de errores en Visual Studio

Resultados (ventana)Output window

En la ventana Resultados se muestran los mensajes de resultados de la compilación del proyecto y del proveedor de control de código fuente.The Output window shows you output messages from building your project and from your source control provider.

Vamos a compilar el proyecto para ver algún resultado de compilación.Let's build the project to see some build output. En el menú Compilar , elija Compilar solución.From the Build menu, choose Build Solution. La ventana Resultados obtiene automáticamente el foco y muestra un mensaje de compilación correcta.The Output window automatically obtains focus and display a successful build message.

Ventana Resultados en Visual Studio

Inicio rápidoQuick Launch

El cuadro Inicio rápido es una manera rápida y sencilla de hacer prácticamente todo en Visual Studio.The Quick Launch box is a quick and easy way to do pretty much anything in Visual Studio. Puede especificar algún texto relacionado con lo que quiere hacer, y se mostrará una lista de opciones que pertenecen al texto.You can enter some text related to what you want to do, and it'll show you a list of options that pertain to the text. Por ejemplo, supongamos que se quiere aumentar el detalle de los resultados de compilación para mostrar más detalles sobre lo que está haciendo exactamente la compilación.For example, imagine you want to increase the build output's verbosity to display additional details about what exactly build is doing. Así es como se haría:Here's how you might do that:

  1. Escriba verbosity en el cuadro Inicio rápido.Type verbosity into the Quick Launch box. En los resultados que aparecen, elija Proyectos y soluciones --> Compilar y ejecutar en la categoría Opciones.From the displayed results, choose Projects and Solutions --> Build and Run under the Options category.

    Cuadro Inicio rápido en Visual Studio

    El cuadro de diálogo Opciones se abre en la página Compilar y ejecutar.The Options dialog box opens to the Build and Run options page.

  2. En Detalles de la salida de la compilación del proyecto de MSBuild, elija Normal y después haga clic en Aceptar.Under MSBuild project build output verbosity, choose Normal, and then click OK.

  3. Vuelva a compilar el proyecto al hacer clic con el botón derecho en el proyecto ConsoleApp1 del Explorador de soluciones y elija Recompilar en el menú contextual.Build the project again by right-clicking on the ConsoleApp1 project in Solution Explorer and choosing Rebuild from the context menu.

    Esta vez, en la ventana Resultados se muestra un registro más detallado del proceso de compilación, incluido dónde se copiaron los archivos.This time the Output window shows more verbose logging from the build process, including which files were copied where.

    Resultados de compilación detallados en Visual Studio

Menú Enviar comentariosSend Feedback menu

Si encuentra algún problema mientras usa Visual Studio o si tiene sugerencias para mejorar el producto, puede usar el menú Enviar comentarios de la parte superior de la ventana de Visual Studio, junto al cuadro Inicio rápido.Should you encounter any problems while you're using Visual Studio, or if you have suggestions for how to improve the product, you can use the Send Feedback menu at the top of the Visual Studio window, next to the Quick Launch box.

Menú Enviar comentarios en Visual Studio

Pasos siguientesNext steps

Solo se han examinado algunas de las características de Visual Studio para familiarizarse con la interfaz de usuario.We've looked at just a few of the features of Visual Studio to get acquainted with the user interface. Para explorarla más a fondo:To explore further:

Vea tambiénSee also