Inicio de sesión en Visual Studio en Windows

Se aplica a: síVisual Studio noVisual Studio for Mac

En este artículo, aprenderá lo siguiente:

Advertencia

Para trabajar con recursos configurados para el acceso condicional o la autenticación multifactor, necesita Visual Studio 2019 Update 16.6 o versiones posteriores. Las versiones anteriores pueden desencadenar una experiencia de autenticación degradada al solicitar la reautenticación varias veces dentro de la misma sesión de Visual Studio.

Ventajas: ¿por qué iniciar sesión?

Aunque no tiene que iniciar sesión, hacerlo ofrece muchas ventajas.

Prestación Descripción
Ampliar el período de prueba de Visual Studio Use Visual Studio Professional o Visual Studio Enterprise durante 90 días más, en lugar de disponer del período de prueba limitado de 30 días.
Desbloquear Visual Studio Desbloquee Visual Studio si usa una cuenta asociada con una suscripción de Visual Studio o una organización de Azure DevOps.
Sincronizar la configuración La configuración que personalice, como los enlaces de teclado, el diseño de ventana y el tema de color, se aplica inmediatamente al iniciar sesión en Visual Studio en cualquier dispositivo.
Conectarse automáticamente a los servicios de Azure Conéctese a servicios, como Azure y Azure DevOps Services, en el IDE sin que se vuelvan a solicitar las credenciales de la misma cuenta.
Siga usando nuestra edición Community sin interrupciones. Si la instalación le pide que inicie sesión periódicamente, inicie sesión en el IDE para seguir utilizando Visual Studio Community sin interrupciones.
Obtención de "Visual Studio Dev Essentials" Este programa incluye software gratuito, entrenamiento, soporte técnico y mucho más.

Inicie sesión con una cuenta Microsoft o una cuenta profesional.

  1. Inicie Visual Studio. La primera vez que abre Visual Studio, se le pide que inicie sesión y que proporcione información de registro básica.

    Solicitud de inicio de sesión

    Nota

    Si decide no iniciar sesión cuando abra Visual Studio por primera vez, es fácil hacerlo más adelante. Busque el vínculo Iniciar sesión situado en la esquina superior derecha del entorno de Visual Studio.

  1. Inicie Visual Studio. La primera vez que abre Visual Studio, se le pide que inicie sesión y que proporcione información de registro básica.

    Solicitud de inicio de sesión

  1. Elija una cuenta Microsoft o bien una cuenta profesional o educativa. Si no tiene una, seleccione el vínculo situado cerca del botón Iniciar sesión para crear una cuenta Microsoft de forma gratuita.

  2. Elija el tema de color que prefiera y otras opciones de configuración de la UI. Visual Studio recordará la configuración y la sincronizará en todos los entornos de Visual Studio en los que ha iniciado sesión. Puede cambiar la configuración más adelante si abre el menú Herramientas > Opciones en Visual Studio.

    Puede ver que ha iniciado sesión correctamente en la esquina superior derecha del entorno de Visual Studio. A menos que cierre sesión, siempre que inicia Visual Studio se inicia sesión automáticamente y todos los cambios realizados en la configuración sincronizada se aplican automáticamente.

Usuario actualmente registrado en VS2019

Usuario actualmente registrado en VS2019

Adición de cuentas de usuario y cambio entre ellas

Si tiene varias cuentas de Microsoft y/o cuentas profesionales o educativas, puede agregarlas todas a Visual Studio para que pueda acceder a los recursos desde cualquier cuenta sin tener que iniciar sesión separadamente.

Después de agregar varias cuentas en un equipo, el conjunto de cuentas lo acompañará si inicia sesión en Visual Studio desde otro equipo.

Nota

Aunque los nombres de cuenta tienen movilidad, las credenciales no. Se le pedirá que escriba las credenciales de las otras cuentas la primera vez que intente usar sus recursos en un equipo nuevo.

Agregar otra cuenta a Visual Studio

Para agregar otra cuenta a Visual Studio:

  1. Elija Archivo > Configuración de la cuenta.

  2. En Todas las cuentas, use + o la lista desplegable Agregar para elegir una cuenta.

  3. En la página Iniciar sesión en la cuenta, seleccione la cuenta o elija Usar otra cuenta. Siga los avisos para escribir las credenciales de la cuenta nueva.

(Opcional) Vaya ahora al Explorador de servidores y vea los servicios de Azure asociados con la cuenta que acaba de agregar. En el Explorador de servidores, haga clic con el botón derecho en el nodo Azure y elija Administrar y filtrar suscripciones. Elija la nueva cuenta (haciendo clic en la flecha desplegable junto a la cuenta actual) y elija las suscripciones que desea mostrar en el Explorador de servidores. Debería ver todos los servicios asociados a la suscripción especificada. Aunque no tenga iniciada sesión en Visual Studio con la segunda cuenta, sí ha iniciado sesión en los servicios y recursos de esa cuenta. Lo mismo se aplica a Proyecto > Agregar servicio conectado.

Agregar otra cuenta a Visual Studio

Para agregar otra cuenta a Visual Studio:

  1. Elija Archivo > Configuración de la cuenta.

  2. En Todas las cuentas, elija Agregar una cuenta.

  3. En la página Iniciar sesión en la cuenta, seleccione la cuenta o elija Usar otra cuenta. Siga los avisos para escribir las credenciales de la cuenta nueva.

(Opcional) Vaya ahora al Explorador de servidores y vea los servicios de Azure asociados con la cuenta que acaba de agregar. En el Explorador de servidores, haga clic con el botón derecho en el nodo Azure y elija Administrar y filtrar suscripciones. Elija la nueva cuenta (haciendo clic en la flecha desplegable junto a la cuenta actual) y elija las suscripciones que desea mostrar en el Explorador de servidores. Debería ver todos los servicios asociados a la suscripción especificada. Aunque no tenga iniciada sesión en Visual Studio con la segunda cuenta, sí ha iniciado sesión en los servicios y recursos de esa cuenta. Lo mismo sirve para Proyecto > Agregar servicio conectado y Equipo > Conectar con Team Foundation Server.

Agregar una cuenta mediante el flujo de código del dispositivo

En algunos casos, no se puede iniciar sesión ni agregar una cuenta de la forma habitual. Esto puede ocurrir si Internet Explorer está bloqueado por algún motivo o si la red está detrás de un firewall. Para solucionar este problema, puede habilitar el flujo de código del dispositivo para agregar una cuenta o volver a autenticarla. El flujo de código del dispositivo permite iniciar sesión en otro explorador o en otro equipo (sea este físico o virtual).

Para iniciar sesión mediante el flujo de código del dispositivo:

  1. Abra la página Cuentas desde Herramientas > Opciones > Entorno y, después, seleccione Habilitar el flujo de código del dispositivo al agregar o volver a autenticar una cuenta. Seleccione Aceptar para cerrar las páginas de opciones.

  2. Elija Archivo > Configuración de la cuenta para abrir la página de administración de cuentas.

  3. Elija Agregar una cuenta en Todas las cuentas.

    Un cuadro de diálogo muestra una dirección URL y un código para pegarlo en un explorador web.

    Dirección URL y código del flujo de código del dispositivo

  4. Presione Ctrl+C para copiar el texto del cuadro de diálogo y, luego, elija Aceptar para cerrar el cuadro de diálogo. Pegue el texto que ha copiado en un editor de texto, como el Bloc de notas. Así será más fácil copiar el código en el siguiente paso.

  5. Vaya a la dirección URL de inicio de sesión de dispositivo en el equipo o explorador web que quiera usar para iniciar sesión en Visual Studio y, después, pegue o introduzca en el cuadro Código el código que ha copiado.

    El nombre de la aplicación Visual Studio debe aparecer más abajo en la página.

  6. En Visual Studio, elija Continuar.

    Captura de pantalla de la página Inicio de sesión del dispositivo en la que se muestra la opción Continuar.

  7. Siga las instrucciones para escribir las credenciales de su cuenta.

    Aparece una página que le indica que ha iniciado sesión en Visual Studio en el dispositivo y que puede cerrar la ventana del explorador.

    Proceso de inicio de sesión de Visual Studio a través de un explorador completado

  8. Vuelva a la página de administración de cuentas de Visual Studio y verá que la cuenta recién agregada figura en Todas las cuentas. Elija Cerrar.

Adición de una cuenta de GitHub a Visual Studio

A partir de la versión 16.8, podrá agregar cuentas de GitHub y GitHub Enterprise a la cadena de claves. Estas cuentas las podrá agregar y aprovechar igual que hace con las cuentas de Microsoft, lo que significa que tendrá una mayor facilidad para acceder a los recursos de GitHub en Visual Studio.

Para instrucciones detalladas, consulte Trabajar con cuentas de GitHub en Visual Studio.

Adición de una cuenta habilitada para autenticación multifactor (MFA) a Visual Studio

En la versión 16.6, se han agregado nuevas funcionalidades a Visual Studio 2019 que agilizan la forma en que los usuarios pueden acceder a los recursos protegidos mediante directivas de CA como MFA. Para usar este flujo de trabajo mejorado, deberá optar por usar el explorador web predeterminado del sistema como mecanismo para agregar y volver a autenticar las cuentas de Visual Studio.

Para obtener instrucciones detalladas, consulte Trabajo con cuentas que requieren autenticación multifactor (MFA).

Acceso a varias cuentas asociadas a la cuenta de inicio de sesión de Visual Studio

Después de iniciar sesión en Visual Studio con una cuenta Microsoft o una cuenta profesional, puede ver los recursos accesibles desde sus cuentas en lugares como el cuadro de diálogo Agregar servicio conectado, el Explorador de servidores y Team Explorer.

Los servicios de Azure, Application Insights, Azure DevOps y Microsoft 365 admiten todos la experiencia de inicio de sesión simplificada.

Obtener acceso a su cuenta de Azure en el Explorador de servidores

Para abrir el Explorador de servidores, elija Ver > Explorador de servidores (o, si usa la configuración de entorno "General", presione Ctrl+Alt+S). Expanda el nodo Azure y fíjese en que contiene los recursos disponibles en la cuenta de Azure que está asociada con la cuenta que ha usado para iniciar sesión en Visual Studio. El aspecto debe ser similar al de la siguiente imagen:

Explorador de servidores con el nodo Azure expandido

Explorador de servidores con el nodo Azure expandido

La primera vez que use Visual Studio en cualquier dispositivo específico, el cuadro de diálogo solo muestra las suscripciones registradas en la cuenta con la que ha iniciado sesión. Puede acceder a los recursos de cualquiera de las demás cuentas directamente desde el Explorador de servidores: haga clic con el botón derecho en el nodo de Azure, elija Administrar y filtrar suscripciones y, luego, agregue las cuentas desde el control de selector de cuenta. Si lo desea, después puede elegir otra cuenta haciendo clic en la flecha hacia abajo y eligiendo en la lista de cuentas. Después de elegir la cuenta, puede indicar qué suscripciones de esa cuenta se van a mostrar en el Explorador de servidores.

Administrar el cuadro de diálogo de las suscripciones de Azure

La próxima vez que abra el Explorador de servidores, se mostrarán los recursos de esa suscripción.

Obtener acceso a su cuenta de Azure a través del cuadro de diálogo Agregar servicio conectado

  1. Abra un proyecto existente o cree uno.

  2. Seleccione el nodo de proyecto en el Explorador de soluciones y, después, haga clic con el botón derecho y seleccione Agregar > Servicio conectado.

    Se abre la ventana Servicios conectados con la lista de servicios de la cuenta de Azure asociada a la cuenta de personalización de Visual Studio. No tiene que iniciar sesión por separado en Azure. Sin embargo, deberá iniciar sesión en las otras cuentas la primera vez que intente acceder a sus recursos desde otro equipo.

Obtener acceso a Azure Active Directory en un proyecto web

Azure Active Directory (Azure AD) ofrece compatibilidad con el inicio de sesión único de usuario final en las aplicaciones web ASP.NET MVC o autenticación AD en los servicios de API web. La autenticación de dominio es diferente de la autenticación de cuentas de usuario individuales; Los usuarios que tienen acceso a su dominio de Active Directory pueden usar las cuentas de Azure AD que poseen para conectarse a sus aplicaciones web. Las aplicaciones de Microsoft 365 también pueden utilizar la autenticación de dominio.

Para ver cómo funciona, cree un proyecto de Aplicación web ASP.NET Core. En el cuadro de diálogo Nueva aplicación web ASP.NET Core, elija la plantilla Aplicación web y, luego, elija Cambiar autenticación.

Aparece el cuadro de diálogo Cambiar autenticación, donde puede elegir el tipo de autenticación que se va a usar en la aplicación.

Cuadro de diálogo de autenticación de cambio de ASP.NET

Para más información sobre los diferentes tipos de autenticación en ASP.NET, vea Create ASP.NET web projects in Visual Studio (Crear proyectos web de ASP.NET en Visual Studio).

Acceder a su organización de Azure DevOps

En el menú principal, elija Equipo > Administrar conexiones para abrir la ventana Team Explorer - Conectar. Elija Administrar conexiones > Conectar a un proyecto. En el cuadro de diálogo Conectar a un proyecto, seleccione un proyecto de la lista (o seleccione Agregar servidor TFS y escriba la dirección URL de su servidor). Cuando seleccione la dirección URL, iniciará sesión sin tener que volver a escribir las credenciales.

Para más información, vea Connect to projects in Team Explorer (Conectarse a proyectos en Team Explorer).

Para ver cómo funciona, cree un proyecto Aplicación web ASP.NET Core. En la página Información adicional, elija .NET Core 3.1 (Compatibilidad a largo plazo) en el menú desplegable Plataforma de destino y, a continuación, elija un tipo de autenticación en el menú desplegable Tipo de autenticación.

Para ver cómo funciona, cree un proyecto Aplicación web ASP.NET Core. En la página Información adicional, elija .NET Core 6 (Compatibilidad a largo plazo) en el menú desplegable Plataforma de destino y, a continuación, elija un tipo de autenticación en el menú desplegable Tipo de autenticación.

Identidad: compatibilidad de proxy con cuentas basadas en Azure Active Directory

Visual Studio ahora puede detectar si los usuarios están detrás de un proxy y solicitar proactivamente credenciales de proxy al agregar cuentas de Microsoft (MSA) o cuentas profesionales o educativas (WSA) a Visual Studio.

Las credenciales de proxy se almacenan en el Administrador de credenciales de Windows y se usan según sea necesario para completar las operaciones relacionadas con la identidad.

Nota

Si el servidor proxy se inicia o cambia después de abrir Visual Studio, el cuadro de diálogo Configuración de la cuenta mostrará una advertencia, pero deberá reiniciar Visual Studio para que se muestre el mensaje de solicitud de credenciales de proxy.

Cierre de sesión en la cuenta

  1. Seleccione el icono con su nombre de perfil en la esquina superior derecha del entorno de Visual Studio.
  2. Seleccione Configuración de la cuenta.
  3. Seleccione Cerrar sesión.

Actualización del perfil de la cuenta

  1. Vaya a Archivo > Configuración de la cuenta y seleccione el vínculo Administrar perfil de Visual Studio.
  2. En la ventana del explorador, seleccione Editar perfil y cambie los valores de configuración que quiera.
  3. Cuando haya terminado, seleccione Guardar cambios.

Vea también