Características del editor de códigoFeatures of the code editor

El editor de Visual Studio proporciona muchas características que le facilitan la escritura y la administración del código y del texto.The Visual Studio editor provides many features that make it easier for you to write and manage your code and text. Puede expandir y contraer diferentes bloques de código mediante el uso de la esquematización.You can expand and collapse different blocks of code by using outlining. Puede obtener más información sobre el código mediante IntelliSense, el Examinador de objetos y la jerarquía de llamadas.You can learn more about the code by using IntelliSense, the Object Browser, and the Call Hierarchy. Puede encontrar código mediante características como Ir a, Ir a definición y Buscar todas las referencias.You can find code by using features such as Go To, Go To Definition, and Find All References. Puede insertar bloques de código con fragmentos de código y generar código mediante funciones como Generar a partir del uso.You can insert blocks of code with code snippets, and you can generate code by using features such as Generate From Usage. Si no ha usado nunca el editor de Visual Studio, vea una breve introducción en Edición del código.If you have never used the Visual Studio editor before, see Edit your code for a quick overview.

Note

Este tema se aplica a Visual Studio para Windows.This topic applies to Visual Studio on Windows. En el caso de Visual Studio para Mac, vea Editor de código fuente (Visual Studio para Mac).For Visual Studio for Mac, see Source editor (Visual Studio for Mac).

Puede ver el código de varias maneras.You can view your code in a number of different ways. De forma predeterminada, en el Explorador de soluciones se muestra el código organizado por archivos.By default, Solution Explorer shows your code organized by files. Puede hacer clic en la pestaña Vista de clases en la parte inferior de la ventana para ver el código organizado por clases.You can click on the Class View tab at the bottom of the window to view your code organized by classes.

Puede buscar y reemplazar texto en uno o varios archivos.You can search and replace text in single or multiple files. Para obtener más información, vea Buscar y reemplazar texto.For more information, see Find and replace text. Puede usar expresiones regulares para buscar y reemplazar texto.You can use regular expressions to find and replace text. Para obtener más información, vea Usar expresiones regulares en Visual Studio.For more information, see Use regular expressions in Visual Studio.

Los diferentes lenguajes de Visual Studio ofrecen distintos conjuntos de características y, en algunos casos, estas se comportan de forma diferente en función del lenguaje.The different Visual Studio languages offer different sets of features, and in some cases the features behave differently in different languages. Muchas de estas diferencias se especifican en las descripciones de las características, pero si quiere obtener más información, puede ver las secciones sobre lenguajes específicos de Visual Studio.Many of these differences are specified in the descriptions of the features, but for more information you can see the sections on specific Visual Studio languages.

Características del editorEditor features

Colores de la sintaxisSyntax Coloring Algunos elementos de la sintaxis de los archivos de código y marcado están coloreados de forma distinta para distinguirlos.Some syntax elements of code and markup files are colored differently to distinguish them. Por ejemplo, las palabras clave (como using en C# y Imports en Visual Basic) son de un color, pero los tipos (como Console y Uri) son de otro.For example, keywords (such as using in C# and Imports in Visual Basic) are one color, but types (such as Console and Uri) are another color. También se colorean otros elementos de la sintaxis, como los comentarios y los literales de cadena.Other syntax elements are also colorized, such as string literals and comments. C++ utiliza el color para diferenciar entre tipos, enumeraciones y macros, entre otros tokens.C++ uses color to differentiate among types, enumerations, and macros, among other tokens.

Puede ver el color predeterminado para cada tipo y puede cambiar el color de cualquier elemento específico de la sintaxis en Fonts and Colors, Environment, Options Dialog Box, que puede abrir desde el menú Herramientas.You can see the default color for each type, and you can change the color for any specific syntax element in the Fonts and Colors, Environment, Options dialog box, which you can open from the Tools menu.
Marcas de errores y advertenciasError and Warning Marks Al agregar código y compilar su solución, puede que vea (a) que aparecen subrayados ondulados de diferentes colores o (b) bombillas en el código.As you add code and build your solution, you may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in your code. Los subrayados ondulados rojos indican errores de sintaxis, los subrayados ondulados azules indican errores del compilador, los subrayados ondulados verdes indican advertencias y los subrayados ondulados púrpura, otros tipos de errores.Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings, and purple denotes other types of errors. Las acciones rápidas sugieren correcciones para problemas y facilitan la aplicación de la corrección.Quick Actions suggest fixes for problems and make it easy to apply the fix.

Puede ver el color predeterminado de cada subrayado ondulado de error y advertencia en el cuadro de diálogo Herramientas > Opciones > Entorno > Fuentes y colores.You can see the default color for each error and warning squiggle in the Tools > Options > Environment > Fonts and Colors dialog box. Busque Error de sintaxis, Error del compilador, Advertenciay Otro Error.Look for Syntax Error, Compiler Error, Warning, and Other Error.
Coincidencia de llavesBrace Matching Cuando el punto de inserción se coloca en una llave de apertura en un archivo de código, tanto esta como la llave de cierre se resaltan.When the insertion point is placed on an open brace in a code file, both it and the closing brace are highlighted. Esta característica le permite saber inmediatamente si faltan llaves o si estas están mal colocadas.This feature gives you immediate feedback on misplaced or missing braces. Puede activar o desactivar la coincidencia de llaves mediante la configuración Resaltar con el delimitador automático (Herramientas > Opciones > Editor de texto).You can turn brace matching on or off with the Automatic Delimiter Highlighting setting (Tools > Options > Text Editor). Puede cambiar el color de resaltado en la configuración Fuentes y colores (Herramientas > Opciones > Entorno).You can change the highlight color in the Fonts and Colors setting (Tools > Options > Environment). Busque Coincidencia de llaves (resaltar) o Coincidencia de llaves (rectángulo) .Look for Brace Matching (Highlight) or Brace Matching (Rectangle).
Visualizador de estructuraStructure Visualizer Las líneas de puntos conectan las llaves que coinciden en los archivos de código, lo que hace que sea más fácil ver los pares de llaves de apertura y cierre.Dotted lines connect matching braces in code files, making it easier to see opening and closing brace pairs. Esto puede ayudarle a encontrar código en el código base más rápidamente.This can help you find code in your codebase more quickly. Puede activar o desactivar estas líneas con Mostrar líneas guía de estructura en la sección Mostrar de la página Herramientas > Opciones > Editor de texto > General.You can turn these lines on or off with the Show structure guidelines in the Display section of the Tools > Options > Text Editor > General page.
Números de líneaLine Numbers Se pueden mostrar números de línea en el margen izquierdo de la ventana de código.Line numbers can be displayed in the left margin of the code window. No se muestran de forma predeterminada.They are not displayed by default. Puede activar esta opción en la configuración de Editor de texto Todos los lenguajes (Herramientas > Opciones > Editor de texto > Todos los lenguajes).You can turn this option on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages). Puede mostrar los números de línea de los lenguajes de programación individuales cambiando la configuración de esos lenguajes (Herramientas > Opciones > Editor de texto > <lenguaje> ).You can display line numbers for individual programming languages by changing the settings for those languages (Tools > Options > Text Editor > <language>). Si quiere que se impriman los números de línea, seleccione Incluir números de línea en el cuadro de diálogo Imprimir.For line numbers to print, you must select Include line numbers in the Print dialog box.
Seguimiento de cambiosChange Tracking El color del margen izquierdo le permite realizar un seguimiento de los cambios realizados en un archivo.The color of the left margin allows you to keep track of the changes you have made in a file. Los cambios que se hayan realizado pero no se hayan guardado desde que se abrió el archivo se indican mediante una barra amarilla en el margen izquierdo (conocido como el margen de selección).Changes you have made since the file was opened but not saved are denoted by a yellow bar on the left margin (known as the selection margin). Una vez que haya guardado los cambios (pero antes de cerrar el archivo), la barra se volverá verde.After you have saved the changes (but before closing the file), the bar turns green. Si deshace un cambio después de haber guardado el archivo, la barra se volverá naranja.If you undo a change after you have saved the file, the bar turns orange. Para activar o desactivar esta característica, cambie la opción Seguimiento de cambios en la configuración del Editor de texto (Herramientas > Opciones > Editor de texto).To turn this feature off and on, change the Track changes option in the Text Editor settings (Tools > Options > Text Editor).
Selección de código y textoSelecting Code and Text Puede seleccionar texto en el modo de flujo continuo estándar o en el modo de cuadro, en el que selecciona una parte rectangular del texto en lugar de un conjunto de líneas.You can select text either in the standard continuous stream mode or in box mode, in which you select a rectangular portion of text instead of a set of lines. Para realizar una selección en el modo de cuadro, presione la tecla ALT mientras arrastra el mouse sobre la selección (o presione ALT+MAYÚS+ <tecla de flecha> ).To make a selection in box mode, press Alt as you drag the mouse over the selection (or press Alt+Shift+<arrow key>). La selección incluye todos los caracteres dentro del rectángulo definido por el primer y el último carácter de la selección.The selection includes all of the characters within the rectangle defined by the first character and the last character in the selection. Cualquier cosa escrita o pegada en el área seleccionada se inserta en el mismo punto en cada línea.Anything typed or pasted into the selected area is inserted at the same point on each line.
ZoomZoom Puede acercar o alejar la vista en cualquier ventana de código manteniendo presionada la tecla CTRL y moviendo la rueda del mouse (o CTRL+MAYÚS+ .You can zoom in or out in any code window by pressing and holding the Ctrl key and moving the scroll wheel on the mouse (or Ctrl+Shift+. para acercarla y CTRL+MAYÚS+ , para alejarla).to increase and Ctrl+Shift+, to decrease). También puede utilizar el cuadro Zoom en la esquina inferior izquierda de la ventana de código para establecer un porcentaje de zoom específico.You can also use the Zoom box in the lower left corner of the code window to set a specific zoom percentage. La característica de zoom no funciona en ventanas de herramientas.The zoom feature does not work in tool windows.
Espacio virtualVirtual Space De forma predeterminada, las líneas en los editores de Visual Studio terminan después del último carácter, para que si se pulsa la tecla de flecha derecha cuando el cursor está al final de una línea, este se mueva hasta el principio de la siguiente línea.By default, lines in Visual Studio editors end after the last character, so that the Right Arrow key at the end of a line moves the cursor to the beginning of the next line. En algunos editores, las líneas no terminan después del último carácter y se puede colocar el cursor en cualquier parte de la línea.In some other editors a line does not end after the last character, and you can place your cursor anywhere on the line. Puede habilitar el espacio virtual en el editor en la configuración Herramientas > Opciones > Editor de texto > Todos los lenguajes.You can enable virtual space in the editor in the Tools > Options > Text Editor > All Languages settings. Tenga en cuenta que puede habilitar bien Espacio Virtual o bien Ajuste automático de línea, pero no los dos.Note that you can enable either Virtual Space or Word Wrap, but not both.
ImpresiónPrinting Puede utilizar las opciones del cuadro de diálogo Imprimir para que al imprimir un archivo, se incluyan los números de línea o las regiones contraídas y ocultas de código.You can use the options in the Print dialog box to include line numbers or hide collapsed regions of code when you print a file. En el cuadro de diálogo Configurar página también puede elegir imprimir la ruta de acceso completa y el nombre del archivo seleccionando Encabezado de página.In the Page Setup dialog box, you can also choose to print the full path and the name of the file by choosing Page header.

Puede establecer las opciones de impresión de color en el cuadro de diálogo Herramientas > Opciones > Entorno > Fuentes y colores.You can set color printing options in the Tools > Options > Environment > Fonts and Colors dialog box. Elija Impresora en la lista Mostrar valores para para personalizar la impresión en color.Choose Printer in the Show settings for list to customize color printing. Puede especificar distintos colores para imprimir un archivo y para editarlo.You can specify different colors for printing a file than for editing a file.
Deshacer y Rehacer globalGlobal Undo and Redo Los comandos Deshacer la última acción global y Rehacer la última acción global del menú Editar permiten deshacer o rehacer acciones globales que afectan a varios archivos.The Undo Last Global Action and Redo Last Global Action commands on the Edit menu undo or redo global actions that affect multiple files. Entre las acciones globales se incluyen cambiar el nombre de una clase o espacio de nombres, realizar una operación de buscar y reemplazar en una solución, refactorizar una base de datos o cualquier otra acción que modifique varios archivos.Global actions include renaming a class or namespace, performing a find-and-replace operation across a solution, refactoring a database, or any other action that changes multiple files. Puede aplicar los comandos deshacer y rehacer global a acciones de la sesión actual de Visual Studio, incluso después de haber cerrado la solución en la que se aplicó una acción.You can apply the global undo and redo commands to actions in the current Visual Studio session, even after you close the solution in which an action was applied.

Características de edición avanzadasAdvanced editing features

Puede encontrar un número de características avanzadas en el menú Editar > Avanzada en la barra de herramientas.You can find a number of advanced features on the Edit > Advanced menu on the toolbar. No todas estas características están disponibles para todos los tipos de archivos de código.Not all of these features are available for all types of code files.

Dar formato al documentoFormat Document Establece la sangría adecuada de las líneas de código y mueve las llaves para separar las líneas del documento.Sets the proper indentation of lines of code and moves curly braces to separate lines in the document.
Dar formato a la selecciónFormat Selection Establece la sangría adecuada de las líneas de código y mueve las llaves para separar las líneas de la selección.Sets the proper indentation of lines of code and moves curly braces to separate lines in the selection.
Aplicar tabulación a las líneas seleccionadasTabify Selected Lines Cambia los espacios iniciales por tabulaciones en los casos que sea apropiado.Changes leading spaces to tabs where appropriate.
No aplicar tabulación a las líneas seleccionadasUntabify Selected Lines Cambia las tabulaciones iniciales por espacios.Changes leading tabs to spaces. Si desea convertir todos los espacios del archivo en tabulaciones (o todas las tabulaciones en espacios), puede utilizar los comandos Edit.ConvertSpacesToTabs y Edit.ConvertTabsToSpaces .If you want to convert all the spaces in your file to tabs (or all the tabs to spaces), you can use the Edit.ConvertSpacesToTabs and Edit.ConvertTabsToSpaces commands. Estos comandos no aparecen en los menús de Visual Studio, pero se pueden llamar desde la ventana Acceso rápido o la ventana Comandos.These commands do not appear in Visual Studio menus, but you can call them from the Quick Access window or the command window.
Poner en mayúsculasMake Uppercase Cambia todos los caracteres de la selección a mayúsculas o, si no hay ninguna selección, cambia el carácter situado en el punto de inserción a mayúsculas.Changes all characters in the selection to uppercase, or if there is no selection, changes the character at the insertion point to uppercase. Método abreviado: Ctrl+Mayús+U.Shortcut: Ctrl+Shift+U.
Poner en minúsculasMake Lowercase Cambia todos los caracteres de la selección a minúsculas o, si no hay ninguna selección, cambia el carácter situado en el punto de inserción a minúsculas.Changes all characters in the selection to lowercase, or if there is no selection, changes the character at the insertion point to lowercase. Método abreviado: Ctrl+U.Shortcut: Ctrl+U.
Subir líneas seleccionadasMove selected Lines Up Mueve la línea seleccionada una línea hacia arriba.Moves the selected line up one line. Método abreviado: Alt+Flecha arriba.Shortcut: Alt+Up Arrow.
Bajar líneas seleccionadasMove Selected Lines Down Mueve la línea seleccionada una línea hacia abajo.Moves the selected line down one line. Método abreviado: Alt+Flecha abajo.Shortcut: Alt+Down Arrow.
Eliminar espacio en blanco horizontalDelete Horizontal White Space Elimina las tabulaciones o los espacios al final de la línea actual.Deletes tabs or spaces at the end of the current line. Método abreviado: Ctrl+K, Ctrl+ \Shortcut: Ctrl+K, Ctrl+\
Ver espacios en blancoView White Space Muestra los espacios como puntos elevados y las tabulaciones como flechas.Displays spaces as raised dots, and tabs as arrows. El final de un archivo se muestra como un glifo rectangular.The end of a file is displayed as a rectangular glyph. Si está seleccionada la opción Herramientas > Opciones > Editor de texto > Todos los lenguajes > Ajuste automático de línea > Mostrar glifos visibles para ajuste automático de línea, también se muestra ese glifo.If Tools > Options > Text Editor > All Languages > Word Wrap > Show visible glyphs for word wrap is selected, that glyph is also displayed.
Ajuste automático de líneaWord Wrap Hace que todas las líneas de un documento se vean en la ventana de código.Causes all the lines in a document to be visible in the code window. Puede activar o desactivar el ajuste automático de línea en la configuración Editor de texto/Todos los lenguajes (Herramientas > Opciones > Editor de texto > Todos los lenguajes).You can turn word wrap off and on in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages).
Selección con comentariosComment Selection Agrega los caracteres de comentarios a la selección o la línea actual.Adds comment characters to the selection or the current line. Método abreviado: Ctrl+K, Ctrl+CShortcut: Ctrl+K, Ctrl+C
Selección sin comentariosUncomment Selection Quita los caracteres de comentarios de la selección o la línea actual.Removes comment characters from the selection or the current line. Método abreviado: Ctrl+K, Ctrl+UShortcut: Ctrl+K, Ctrl+U
Aumentar sangría de líneaIncrease Line Indent Agrega una tabulación (o los espacios equivalentes) a las líneas seleccionadas o la línea actual.Adds a tab (or the equivalent spaces) to the selected lines or the current line.
Reducir sangría de líneaDecrease Line Indent Quita una tabulación (o los espacios equivalentes) de las líneas seleccionadas o la línea actual.Removes a tab (or the equivalent spaces) from the selected lines or the current line.
Seleccionar etiquetaSelect Tag En un documento que contenga etiquetas (por ejemplo, XML o HTML), selecciona la etiqueta.In a document that contains tags (for example, XML or HTML), selects the tag.
Seleccionar contenido de la etiquetaSelect Tag Content En un documento que contenga etiquetas (por ejemplo, XML o HTML), selecciona el contenido.In a document that contains tags (for example, XML or HTML), selects the content.

Puede moverse por el editor de código de varias maneras. Por ejemplo, puede navegar hacia atrás y hacia delante a puntos de inserción anteriores, ver la definición de un tipo o miembro y saltar a un método específico mediante la barra de navegación.You can move around in the code editor in several different ways, including navigating backwards and forwards to previous insertion points, viewing the definition of a type or member, and jumping to a specific method using the navigation bar. Para obtener más información, vea navegar por el código.For more information see Navigate code.

Búsqueda de referencias en el código baseFind references in your code base

Para buscar dónde se hace referencia a elementos de código específicos en todo el código base, puede usar el comando Buscar todas las referencias o presionar Mayús+F12.To find where particular code elements are referenced throughout your codebase, you can use the Find All References command or press Shift+F12. Además, al hacer clic en un tipo o miembro, la característica de resaltado de referencia resalta automáticamente todas las referencias a ese tipo o miembro.Also, when you click on a type or member, the reference highlighting feature automatically highlights all references to that type or member. Para obtener más información, vea Búsqueda de referencias en el código.For more information, see Find references in your code.

Personalización del editorCustomize the editor

Puede compartir su configuración de Visual Studio con otro desarrollador, hacer que su configuración cumpla con un estándar o volver a la configuración predeterminada de Visual Studio mediante el comando Asistente para importar y exportar configuraciones en el menú Herramientas.You can share your Visual Studio settings with another developer, have your settings conform to a standard, or return to Visual Studio default settings by using the Import and Export Settings Wizard command on the Tools menu. En el Asistente para importar y exportar configuraciones, puede cambiar la configuración general o el lenguaje seleccionados y la configuración específica del proyecto.In the Import and Export Settings Wizard, you can change selected general settings or language and project-specific settings.

Para definir teclas de acceso rápido nuevas o redefinir las existentes, vaya a Herramientas > Opciones > Entorno > Teclado.To define new hotkeys or redefine existing hotkeys, go to Tools > Options > Environment > Keyboard. Para más información sobre las teclas de acceso rápido, consulte Métodos abreviados de teclado predeterminados.For more information about hotkeys, see Default keyboard shortcuts.

Para las opciones del editor específicas de JavaScript, consulte las opciones del editor de JavaScript.For JavaScript-specific editor options, see JavaScript editor options.

Vea tambiénSee also