Visual Studio 2017 para Mac versión 7.4 Visual Studio 2017 for Mac version 7.4


Comunidad de desarrolladores | Requisitos del sistema | Compatibilidad | Código distribuible | Xamarin | Blogs | MantenimientoDeveloper Community | System Requirements | Compatibility | Distributable Code | Xamarin | Blogs | Servicing


Nota

Si accede a esta página desde una versión de idioma distinta del inglés y quiere ver el contenido más actualizado, visite la página Notas de la versión en inglés.If you are accessing this page from a non-English language version, and want to see the most up-to-date content, please visit this Release Notes page in English.

Sugerencia

Puede cambiar el idioma de la página en la parte inferior de esta.You can switch the page language at the bottom of this page. Haga clic en el botónClick the y busque su idioma o selecciónelo en la lista de idiomas disponibles. icon, search for your language, or select from the list of available languages.


Visual Studio 2017 para Mac permite crear aplicaciones para dispositivos móviles, la Web y la nube con Xamarin y .NET Core, así como juegos con Unity.Use Visual Studio 2017 for Mac to build apps for mobile, web, and the cloud with Xamarin and .NET Core, as well as games with Unity.

Descarga de la versión más reciente de Visual Studio para Mac 2017Download the Current Release of Visual Studio for Mac 2017

Download Visual Studio 2017 for Mac

Para obtener más información sobre Visual Studio 2017 para Mac, consulte Mac System Requirements (Requisitos del sistema de equipos Mac) y Mac Platform Targeting and Compatibility (Compatibilidad y destinatarios de la plataforma Mac).To learn more about Visual Studio 2017 for Mac, see Mac System Requirements and Mac Platform Targeting and Compatibility.

Para obtener más información sobre otras descargas relacionadas, consulte la página Descargas.To learn more about other related downloads, see the Downloads page.

ComentariosFeedback

Queremos que nos dé su opinión.We’d love to hear from you! Puede notificar un problema a través de la opción Notificar un problema del IDE de Visual Studio para Mac y realizar el seguimiento de los comentarios en el portal de la comunidad de desarrolladores.You can report a problem via the Report a Problem option the Visual Studio for Mac IDE and track your feedback in the Developer Community portal. Si quiere hacer alguna sugerencia, puede hacerlo a través de UserVoice.For suggestions, let us know through UserVoice.

Historial de versionesRelease History


5 de marzo de 2018: Visual Studio 2017 para Mac, versión 7.4 (7.4.0.1033)March 5, 2018 - Visual Studio 2017 for Mac 7.4 (7.4.0.1033)

Para la versión de Visual Studio para Mac 7.4, hemos dedicado el tiempo necesario para centrarnos en solucionar algunas de las principales fugas de memoria, así como problemas de rendimiento y de estabilidad que se nos han notificado.For the Visual Studio for Mac 7.4 release, we've taken time to focus on fixing some of the top memory leaks, performance problems, and stability issues that have been reported to us. Esta versión también ofrece compatibilidad para el desarrollo de Android Oreo 8.1 y varias mejoras de productividad para los desarrolladores de Xamarin.This release also brings support for Android Oreo 8.1 development and several productivity enhancements for Xamarin developers.

Aspectos destacados de la versiónRelease Highlights

  • macOS High Sierra ahora se admite oficialmente.macOS High Sierra is now officially supported.
  • Compatibilidad con Xcode 9.3.Support for Xcode 9.3.
  • Ahora se admite C# 7.1 (consulte las novedades en C# 7.1).C# 7.1 is now supported (see what's new in C# 7.1).
  • Compatibilidad con Android 8.1 Oreo.Support for Android 8.1 Oreo.
  • Implementación inalámbrica y depuración para Xamarin.iOS.Wireless deployment and debugging for Xamarin.iOS.
  • Se realizaron cambios básicos en la arquitectura en el editor C#; como resultado, se mejoraron tanto el rendimiento y la confiabilidad de IntelliSense como la capacidad de respuesta al escribir.Core architectural changes were made to the C# editor; both IntelliSense performance/reliability and typing responsiveness are improved as a result.

Problemas corregidos en esta versiónIssues fixed in this release

Versión en detalleRelease in Detail

  • Se ha agregado un menú Editar > Switch to Suggestion Mode (Cambiar al modo de sugerencia), para alternar entre el modo de sugerencia de IntelliSense y el modo de finalización.Added an Edit > Switch to Suggestion Mode menu, to toggle between IntelliSense suggestion mode and completion mode. En el modo de sugerencias, las sugerencias de autocompletar de IntelliSense no invalidarán el texto que ha escrito a menos que lo elija manualmente de la lista de sugerencias de IntelliSense.In suggestion mode, IntelliSense auto-complete suggestions will not override the text you've written unless you manually choose them from the IntelliSense suggestion list. Para volver al modo de finalización, puede elegir el menú Editar | Switch to Completion Mode (Cambiar al modo de finalización).To switch back to Completion Mode you can choose the Edit | Switch to Completion Mode menu. Se proporciona un método abreviado de teclado predeterminado Ctrl+Alt+Barra espaciadora si está utilizando esquemas de enlace de teclado de Visual Studio (mixto) o Visual Studio (Windows).A default keyboard shortcut of Ctrl+Alt+Space is provided if you're using Visual Studio (Mixed) or Visual Studio (Windows) key binding schemes.

  • Se ha agregado un acceso directo Cmd+Mayús+P que abre el cuadro de búsqueda Ir a, filtrado para que pueda buscar los comandos disponibles basados en su contexto actual.Added a Cmd+Shift+P shortcut that will open the Navigate To search box, filtered so you can search for available commands based on your current context.

Debug source files option
(Figura 1) Filtrado de comandos(Figure 1) Command Filtering
  • Búsqueda de código fuente de depurador.Debugger source lookup.

    • Agrega compatibilidad para la pestaña Depurar archivos de código fuente en las opciones de la solución (figura 2).Added support for the Debug Source Files tab in solution options (Figure 2). Para mantener limpia la interfaz de usuario, este menú aparece solo después de agregar la primera carpeta.To keep the UI clean, this menu appears only after you add the first folder.

      Debug source files option
      (Figura 2) Opción Depurar archivos de código fuente(Figure 2) Debug source files option
    • Si intenta ir a un marco de pila o depurar un método paso a paso por instrucciones y el depurador no encuentra los archivos de código fuente, se muestra un nuevo documento Código fuente no encontrado (figura 3).If you try to navigate to a stack frame or step into a method and the debugger doesn't find source files, a new Source Not Found document (Figure 3) is shown. Este documento ayuda a proporcionar algunas opciones para localizar archivos de código fuente si los tiene.This document helps to provide some options to locate source files if you have them. Esto es útil cuando se depuran ensamblados que fueron compilados en CI y el usuario tiene acceso a los archivos de código fuente y al archivo .pdb.This is useful when debugging assemblies that were compiled on CI and user has access to source files and .pdb file.

      New 'source not found' dialog
      (Figura 3) Nuevo cuadro de diálogo "Código fuente no encontrado"(Figure 3) New "source not found" dialog
  • Monitor de archivos para detectar archivos agregados al proyecto.File watcher to detect files added to the project.

    Visual Studio para Mac detecta ahora los archivos agregados o quitados de un proyecto .NET Core y actualiza dinámicamente la ventana de soluciones con los cambios.Visual Studio for Mac will now detect files added to or removed from a .NET Core project and update the Solution window with the changes dynamically. Esta mejora abordó el problema de la descarga/recarga requerida después de las migraciones de EF notificado en la comunidad de desarrolladores.This improvement addressed the unload/reload required after EF migrations issue reported in the Developer Community.

  • Uso del directorio .vs para .userprefsUse .vs directory for .userprefs

    • Para mejorar la compatibilidad con Visual Studio en Windows, el archivo de preferencias de usuario que genera Visual Studio para Mac ya no se almacena en el directorio de la solución, sino que ahora se almacena en .vs/SolutionName/xs/UserPrefs.xml.To improve compatibility with Visual Studio on Windows the user preferences file generated by Visual Studio for Mac are no longer stored in the solution directory but are now stored in .vs/SolutionName/xs/UserPrefs.xml.

XamarinXamarin

  • Ya no se admite la función "Cargar en Xamarin Test Cloud" en Visual Studio para Mac (que se invoca al hacer clic con el botón derecho en el árbol de la prueba unitaria).We no longer support the “Upload to Xamarin Test Cloud” function in Visual Studio for Mac (invoked by right-clicking the Unit test tree). Las pruebas de avance progresivo se pueden enviar mediante la CLI de Visual Studio App Center.Moving forwards tests can be submitted through the Visual Studio App Center CLI.

  • Se ha quitado la compatibilidad con componentes en el IDE.We have removed the support for components in IDE. Si abre un proyecto que tiene componentes ya referenciados, se encontrará con un error.If you open a project that has components already referenced, you will be met with an error. Para corregir este error, debe modificar manualmente el archivo .csproj y quitar toda la información de las etiquetas <XamarinComponentReference/>.The fix this error, you must edit the .csproj file manually and remove all information in the <XamarinComponentReference/> tags. Para más información, consulte la guía de migración de componentes.For more information see the Components migration guide.

iOSiOS

  • Hemos agregado compatibilidad para la implementación inalámbrica y depuración para dispositivos iOS o AppleTV.We've added support for wireless deployment and debugging for iOS or AppleTV devices. Cuando un dispositivo se conecta a través de una red y está listo para ser utilizado para la implementación, ahora aparece en la lista de destino del dispositivo, como si el dispositivo estuviera conectado mediante USB.When a device is connected via a network and ready to be used for deployment, it now shows up in the device target list, as if the device were connected through USB. (Figura 4):(Figure 4):

    Apple device connected over Wi-Fi selected in device list
    (Figura 4) En la lista de dispositivos aparece un dispositivo Apple conectado a través de una red(Figure 4) Apple device connected over a network is displayed in device list

    Para más información sobre esta característica, consulte la guía de implementación inalámbrica.For more information on this feature, see the Wireless Deployment guide.

  • Visual Studio para Mac ahora solicita desbloquear el dispositivo de implementación antes de iniciar la aplicación (figura 5) y no interrumpe la sesión de depuración:Visual Studio for Mac now asks to unlock the deployment device before launching the app (Figure 5) and does not interrupt the debugging session:

    Alert advising user to unlock iOS device
    (Figura 5) Alerta que solicita al usuario que desbloquee el dispositivo iOS(Figure 5) Alert advising user to unlock iOS device
  • Visual Studio para Mac ahora genera automáticamente enlaces de C# para los modelos CoreML cuando se agregan a un proyecto, lo que permite un uso rápido y sencillo de los modelos CoreML.Visual Studio for Mac now auto-generates C# bindings for CoreML models when they are added to a project allowing for quick and easy usage of CoreML models.

  • Mejoras de aprovisionamiento:Provisioning Improvements:

    • Esta versión introduce un mejor flujo de trabajo de instalación de fastlane.This release introduces a better fastlane installation workflow. Si fastlane no está instalado, en lugar de mostrar un cuadro de diálogo de error solicitando al usuario que lea la documentación de aprovisionamiento e instale fastlane, se le proporciona una forma de hacerlo dentro del IDE.If fastlane is not installed, instead of showing an error dialog asking you to read the provisioning documentation and install fastlane, we provide a way to do it within the IDE.
    • Dependiendo de la velocidad de Internet y de los parámetros del equipo, la instalación puede tardar hasta dos minutos.Depending on the internet speed and computer parameters the installation can take up to two minutes. Por esta razón, fastlane se descargará en segundo plano para su comodidad.For this reason, fastlane will be downloaded in the background for your convenience.
    • Hemos realizado varias mejoras en la interfaz de usuario para el widget de aprovisionamiento automático en el editor Info.plist.We made a number of UI improvements to the automatic provisioning widget in Info.plist editor. El nuevo widget distingue claramente entre los modos de aprovisionamiento manual y automático y comunica el estado de aprovisionamiento al usuario.The new widget draws a definite distinction between manual and automatic provisioning modes and communicates provisioning status to the user.

AndroidAndroid

Android 8.1 Oreo es la versión más reciente de Android que está disponible en Google.Android 8.1 Oreo is the latest version of Android available from Google. Android 8.1 Oreo ofrece muchas nuevas características de interés para los desarrolladores de Xamarin.Android, como Android Go, Neural Networks API, actualizaciones de la plataforma de autocompletar, SharedMemory API y muchas más.Android 8.1 Oreo offers many new features of interest to Xamarin.Android developers such as Android Go, Neural Networks API, Autofill Framework updates, SharedMemory API, and many more. Estas API están disponibles para las aplicaciones Xamarin.Android cuando se utiliza Xamarin.Android 8.2 y versiones posteriores.These APIs are available to Xamarin.Android apps when you use Xamarin.Android 8.2 and later.

  • Hemos agregado integración para el Administrador de dispositivos de Xamarin Android (versión preliminar) para usuarios con SDK Tools 26 instalado.We've added integration for the Xamarin Android Device Manager (preview) for users with SDK Tools 26 installed. Para más información, consulte la documentación.For more information, refer to the documentation.

  • Ahora se le advertirá al usuario si el emulador de Android no utiliza HAXM.You'll now be warned if the Android emulator is not using HAXM.

Diseñadores de objetos visualesVisual Designers

Diseñador de iOSiOS Designer
  • Enlaces de teclado para el modo de restricciones:Constraints Mode Key Bindings:

    Los nuevos enlaces de teclado facilitan trabajar con el nuevo modo de restricciones (introducido en 15.5).New key bindings make it easier to work with the new constraints mode (introduced in 15.5). Por ejemplo:For example:

    • Alternar el modo de restricciones: ⌘ EToggle constraints mode: ⌘ E
    • Habilitar temporalmente el modo de restricciones: Mantener pulsado ⌃Temporarily enable constraints mode: Hold ⌃
    • En el modo de restricciones, actualizar restricciones; de lo contrario, actualizar fotogramas: ⇧ ⌘ RIn constraints mode, update constraints; else update frames: ⇧ ⌘ R
  • Ahora se pueden habilitar las variaciones de rasgos para tvOS:Trait Variations can now be enabled for tvOS :

    Ahora se pueden habilitar las variaciones de rasgos para los guiones gráficos de tvOS y XIBs, que permiten la variación por estilo claro u oscuro.Trait variations can now be enabled for tvOS storyboards and XIBs, which enables variation by light style or dark style.

  • Alejado automático cuando se arrastran elementos grandes desde el cuadro de herramientas:Automatic Zoom Out when dragging large items from the Toolbox:

    La superficie de diseño ahora se aleja automáticamente al arrastrar un elemento grande desde el cuadro de herramientas.The design surface now automatically zooms out when you drag a large item from the toolbox. Esto facilita la colocación de elementos grandes en el XIB o guion gráfico.This makes it easier to place large items on your XIB or storyboard.

  • Indicador y selector de zoom:Zoom Indicator and Selector:

    Indica el porcentaje actual del nivel de zoom y permite seleccionar los niveles de zoom en una lista desplegable.Indicates current zoom level percentage and enables selecting zoom levels from a pop up list.

Android DesignerAndroid Designer
  • El análisis y el procesamiento de recursos de Android se han renovado enormemente en esta versión, lo que se traduce en un aumento del rendimiento y en la precisión en todo el panel.Android resource parsing and processing has been vastly revamped in this release resulting in increased performance and accuracy across the board.
  • Se agregó compatibilidad con representación de Android Oreo (API 26).Added Android Oreo (API 26) rendering support.
  • Ahora son compatibles las características de Oreo como fuentes personalizadas e iconos adaptables.Oreo features like custom fonts and adaptive icons are now supported.
  • Mejoras en la velocidad de representación.Rendering speed improvements.
  • Experiencia mejorada en la finalización de IntelliSense.Improved IntelliSense completion experience.

Xamarin.FormsXamarin.Forms

Se han corregido una serie de errores para mejorar la edición de XAML:We fixed a number of bugs to improve XAML editing:

  • [CORREGIDO] Comportamiento incoherente en el editor XML/XAML entre vs/vsmac al pulsar "ENTRAR" para agregar un nuevo atributo a un elemento.[FIXED] Inconsistent behavior in XML/XAML editor between vs/vsmac when hitting "ENTER" in to add a new attribute to an element.
  • [CORREGIDO] Faltan muchos elementos de finalización: ResourceDictionary, x:Double, x:Key, entre otros.[FIXED] Many elements are missing from completion: ResourceDictionary, x:Double, x:Key etc.
  • [CORREGIDO] Sin IntelliSense después de escribir el punto en el nombre.[FIXED] No IntelliSense after typing period in name.
  • [CORREGIDO] Una plataforma falta en IntelliSense.[FIXED] One Platform is missing from IntelliSense.
  • [CORREGIDO] La tecla tabulador inserta espacios, el aplicador de sangrías inserta pestañas.[FIXED] Tab key inserts spaces, indenter inserts tabs.
  • [CORREGIDO] IntelliSense de XAML muestra las propiedades de los elementos ordenadas por longitud del nombre.[FIXED] XAML IntelliSense lists element properties sorted by length of name.

Xamarin Workbooks e instaladorXamarin Workbooks and Installer

Se ha separado completamente Xamarin Inspector de Xamarin Workbooks.We have fully split Xamarin Inspector from Xamarin Workbooks. La extensión de Inspector ya no requiere una instalación de Workbooks para que funcione.The Inspector extension no longer requires a Workbooks installation to function.

Todas las notas de la versión de producto de XamarinAll Xamarin Product release notes


26 de marzo de 2018: Visual Studio 2017 para Mac, versión 7.4.1 (7.4.1.48)March 26, 2018 - Visual Studio 2017 for Mac 7.4.1 (7.4.1.48)


3 de abril de 2018: Visual Studio 2017 para Mac, versión 7.4.2 (7.4.2.12)April 3, 2018 - Visual Studio 2017 for Mac 7.4.2 (7.4.2.12)

Esta versión incluye compatibilidad con Xcode 9.3 y resuelve los problemas siguientes:This release includes support for Xcode 9.3 and addresses the following issues:


Problemas conocidosKnown Issues


Historial de notas de la versión de Visual Studio 2017 para MacVisual Studio 2017 for Mac Release Notes History

Notas de la versión 7.3 de Visual Studio 2017 para MacVisual Studio 2017 for Mac version 7.3 Release Notes

Notas de la versión 7.2 de Visual Studio 2017 para MacVisual Studio 2017 for Mac version 7.2 Release Notes

Notas de la versión 7.1 de Visual Studio 2017 para MacVisual Studio 2017 for Mac version 7.1 Release Notes

Notas de la versión 7.0 de Visual Studio 2017 para MacVisual Studio 2017 for Mac version 7.0 Release Notes


Principio de página
Top of Page