Visual Studio Icon Notas de la versión de Visual Studio 2019Visual Studio 2019 Release Notes


| Comunidad de desarrolladores | Requisitos del sistema | Compatibilidad | Código distribuible | Términos de licencia | Blogs | Problemas conocidos || Developer Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues |


Haga clic en un botón para descargar la última versión de Visual Studio 2019.Click a button to download the latest version of Visual Studio 2019. Para obtener instrucciones sobre cómo instalar y actualizar Visual Studio 2019, vea Actualizar Visual Studio 2019 a la versión más reciente.For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. Consulte también las instrucciones sobre cómo efectuar una instalación sin conexión.Also, see instructions on how to install offline.


Novedades de Visual Studio 2019What's New in Visual Studio 2019

Versiones de Visual Studio 2019Visual Studio 2019 Releases

Notas de la versión archivadasArchived Release Notes

Blog de Visual Studio 2019Visual Studio 2019 Blog

El blog de Visual Studio 2019 es la fuente oficial de información sobre el producto de la mano del equipo de ingeniería de Visual Studio.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. Encontrará información detallada sobre las versiones de Visual Studio 2019 en las publicaciones siguientes:You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019 versión 16.3.9Visual Studio 2019 version 16.3.9 New release icon

Publicado el 12 de noviembre de 2019released November 12, 2019

Principales problemas corregidos en la versión 2019 de Visual Studio 16.3.9Top Issues Fixed in Visual Studio 2019 version 16.3.9


Release Notes Icon Visual Studio 2019, versión 16.3.8Visual Studio 2019 version 16.3.8

Fecha de publicación: 5 de noviembre de 2019released November 5, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.8Top Issues Fixed in Visual Studio 2019 version 16.3.8


Release Notes Icon Visual Studio 2019, versión 16.3.7Visual Studio 2019 version 16.3.7

Fecha de publicación: 29 de octubre de 2019released October 29, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.7Top Issues Fixed in Visual Studio 2019 version 16.3.7


Release Notes Icon Visual Studio 2019 versión 16.3.6Visual Studio 2019 version 16.3.6

publicada el 22 de octubre de 2019released October 22, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.6Top Issues Fixed in Visual Studio 2019 version 16.3.6


Release Notes Icon Visual Studio 2019, versión 16.3.5Visual Studio 2019 version 16.3.5

publicada el 15 de octubre de 2019released October 15, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.5Top Issues Fixed in Visual Studio 2019 version 16.3.5


Release Notes Icon Visual Studio 2019, versión 16.3.4Visual Studio 2019 version 16.3.4

publicada el 10 de octubre de 2019released October 10, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.4Top Issues Fixed in Visual Studio 2019 version 16.3.4


Release Notes Icon Visual Studio 2019, versión 16.3.3Visual Studio 2019 version 16.3.3

publicada el 8 de octubre de 2019released October 8, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.3Top Issues Fixed in Visual Studio 2019 version 16.3.3


Release Notes Icon Visual Studio 2019, versión 16.3.2Visual Studio 2019 version 16.3.2

publicado el 1 de octubre de 2019released October 1, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.2Top Issues Fixed in Visual Studio 2019 version 16.3.2

  • Se ha corregido un problema con la compatibilidad con Xcode 11.Corrected an issue with Xcode 11 support.

Release Notes Icon Visual Studio 2019, versión 16.3.1Visual Studio 2019 version 16.3.1

publicado el 25 de septiembre de 2019released September 25, 2019

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.1Top Issues Fixed in Visual Studio 2019 version 16.3.1


Release Notes Icon Visual Studio 2019 versión 16.3.0Visual Studio 2019 version 16.3.0

publicada el 23 de septiembre de 2019released September 23, 2019

Resumen de las novedades de la versión 16.3 de Visual Studio 2019 16.3Summary of What's New in Visual Studio 2019 version 16.3

Principales incidencias corregidas en Visual Studio 2019, versión 16.3.0Top Issues Fixed in Visual Studio 2019 version 16.3.0


Detalles de las novedades de la versión 16.3.0 de Visual Studio 2019Details of What's new in Visual Studio 2019 version 16.3.0

.NET Framework 4.8.NET Framework 4.8

Se han agregado las herramientas de desarrollo de .NET Framework 4.8 para admitir .NET Framework 4.8 como destino.The .NET Framework 4.8 development tools have been added to support targeting .NET Framework 4.8. .NET Framework 4.8 ofrece diversas mejoras y características nuevas, así como numerosas correcciones de fiabilidad, estabilidad, seguridad y rendimiento.The .NET Framework 4.8 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes. Obtenga más información sobre .NET Framework 4.8 en el anuncio del blog de .NET Framework 4.8Find more details about the .NET Framework 4.8 in the .NET Framework 4.8 blog announcement

Productividad de .NET.NET productivity

  • Los desarrolladores ahora pueden cambiar el nombre de un archivo cuando cambian el nombre de una interfaz, una enumeración o una clase.Developers can now rename a file when renaming an interface, enum, or class. Coloque el cursor en el nombre y el tipo de la clase (Ctrl + R,R) para abrir el cuadro de diálogo Cambiar nombre y active la casilla "Cambiar el nombre del archivo".Place the cursor in the class name and type (Ctrl + R,R) to open the Rename dialogue and check the ‘Rename file’ box.
Rename containing file when renaming a class
Cambio de nombre del archivo contenedor al cambiar el nombre de una claseRename containing file when renaming a class
  • Ahora puede agregar compatibilidad para Editar y continuar en proyectos de varios destinos, que incluye módulos cargados varias veces en el mismo proceso en diferentes dominios o contextos de carga.You can now Edit and Continue support for multi-targeted projects which includes modules loaded multiple times in the same process on different domains or load contexts. Además, los desarrolladores pueden editar los archivos de origen, incluso aunque el proyecto contenedor no esté cargado o la aplicación se esté ejecutando.In addition, developers can edit source files even when the containing project is not loaded or the application is running.
  • Ahora, puede envolver cadenas de llamadas fluidas con una refactorización.You can now wrap chains of fluent calls with a refactoring. Coloque el cursor sobre una cadena de llamadas y presione Ctrl+. para abrir el menú Acciones rápidas y refactorizaciones.Place your cursor on a call chain and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Seleccione Envolver cadena de llamadas o Envolver y alinear cadena de llamadas.Select either Wrap call chain or Wrap and align call chain.
Wrap call chain
Envolver cadena de llamadasWrap Call Chain
  • Ahora, los usuarios pueden introducir una variable local inmediatamente después de escribir su inicializador.Users can now introduce a local variable immediately after writing its initializer. Primero, escriba una expresión.First, write an expression. Después, coloque el cursor en el nombre de la expresión y presione Ctrl+. para abrir el menú Acciones rápidas y refactorizaciones.Then place the cursor in the expression name and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Seleccione la opción para introducir una variable local.Select the option to introduce a local variable.
Introduce a local variable
Introducir una variable local después de escribir el inicializadorIntroduce Local Variable After Writing Initializer
  • Ahora, los analizadores son compatibles con las herramientas de .NET Core.There is now .NET Core tooling support for analyzers. Los usuarios pueden agregar el paquete de analizador más recomendado si hacen clic con el botón derecho sobre el nombre del proyecto en el Explorador de soluciones y seleccionan Propiedades.Users can add the most recommended analyzer package by right clicking on the project name within the solution explorer and select properties. Seleccione Análisis de código para instalar el paquete del analizador y configurar cuándo se ejecutará el análisis de código.Select Code Analysis to install the analyzer package and to configure when to run code analysis.
.NET Core Tooling Analyzer Support
Compatibilidad con el analizador de herramientas de .NET Core.NET Core Tooling Analyzer Support
  • Anteriormente, agregamos la finalización de IntelliSense para los tipos no importados.Previously, we added IntelliSense completion for unimported types. Esta característica podían desactivarla aquellos usuarios que no quisieran que los tipos no importados siempre aparecieran en sus valores de IntelliSense.This feature came with the option to turn it off for users who did not want unimported types always populating their IntelliSense. Ahora, los usuarios que hayan desactivado la finalización para los tipos no importados podrán volverla a incluir en la lista de finalización con el nuevo filtro de tipo importado agregado a los botones de alternancia de IntelliSense.Now, for users who turn off the completion for unimported types, it's much easier to get it back in the completion list with the new imported type filter added to the IntelliSense toggles.
IntelliSense completion list expander
Expansor de la lista de finalización de IntelliSenseIntelliSense completion list expander
IntelliSense completion list expander triggered
Expansor de la lista de finalización de IntelliSense activadoIntelliSense Completion List Expander Triggered
  • Ahora, el estilo Información rápida es compatible con comentarios XML.There is now Quick Info style support for XML comments. Coloque el cursor sobre el nombre del método.Place the cursor over the method name. Información rápida mostrará los estilos admitidos de los comentarios XML encima del código.Quick Info will then display the supported styles from the XML comments above the code.
Quick info style support for XML comments
Compatibilidad del estilo Información rápida con comentarios XMLQuick Info style support for XML comments

Herramientas de WPF y UWPWPF/UWP Tooling

Los clientes que compilan aplicaciones WPF y UWP verán las mejoras siguientes en las herramientas XAML de Visual Studio:Customers building WPF/UWP applications will see the following improvements in Visual Studio XAML tooling:

Diseñador:Designer:

  • Ahora WPF Designer está totalmente disponible (GA) para proyectos de .NET Core para WPF: el Diseñador XAML para las aplicaciones .NET Core para WPF ahora está disponible con carácter general (GA) para todos los clientes sin necesidad de la marca de característica en versión preliminar.WPF Designer now fully available (GA) for WPF .NET Core Projects: The XAML Designer for WPF .NET Core applications is now generally available (GA) to all customers without the need for preview feature flag. El Diseñador XAML para aplicaciones .NET Core para WPF es ligeramente distinto en algunos comportamientos y funcionalidades que el Diseñador de .NET Framework para WPF por diseño.The XAML Designer for WPF .NET Core applications is slightly different in some behaviors and functionality then WPF .NET Framework Designer, please note this is by design. Dada la diferencia, nos gustaría animar a que los clientes informen de cualquier problema o limitación que puedan encontrar mediante la característica de comentarios de Visual Studio.Given the difference we’d like to encourage customers to report any problems or limitations that you might be running into using Visual Studio feedback feature.
WPF .NET Core XAML Designer
Diseñador XAML .NET Core para WPFWPF .NET Core XAML Designer

Herramientas de depuración de XAML:XAML Debugging Tools:

  • Se ha agregado compatibilidad con Recarga activa de XAML para los cambios de los diccionarios de recursos de WPF: ahora Recarga activa de XAML admite la actualización de diccionarios de recursos de WPF para actualizaciones en tiempo real en la aplicación.XAML Hot Reload support added for WPF resource dictionaries changes: XAML Hot Reload now supports updating WPF Resource Dictionaries for real-time updates in the application. Anteriormente, esta característica solo estaba disponible para Plataforma universal de Windows (UWP), pero ahora se admite en las aplicaciones .NET Framework y .NET Core para WPF, y UWP.Previously this feature was only available to Universal Windows Platform (UWP), but is now supported for WPF .NET Framework, WPF .NET Core and UWP apps. Entre las acciones admitidas se incluyen la adición de una nueva definición de la sección de recursos y la adición, eliminación y actualización de recursos en secciones nuevas o existentes.Supported actions include adding a new Resources section definition and adding, deleting and updating resources new/existing sections.
  • Ahora la barra de herramientas de la aplicación se puede mover: la barra de herramientas de la aplicación se ha mejorado para que se pueda mover dentro de la aplicación WPF o UWP en ejecución, lo que permite a los desarrolladores arrastrarla hacia la izquierda o la derecha dentro de la aplicación para desbloquear la interfaz de usuario.In-app toolbar now movable: The in-app toolbar has been enhanced so that it is movable within the running WPF/UWP application, enabling developers to drag it left or right within the app to unblock app UI. Tenga en cuenta que la posición a la que se mueve la barra de herramientas no se almacena entre sesiones y que volverá a la posición predeterminada cuando se reinicie la aplicación.Note that position to which the toolbar is moved is not stored between sessions and will go back to the default position when your app is restarted.
In-app toolbar movable
Barra de herramientas de la aplicación movibleIn-app toolbar movable

Firma del paquete UWP.UWP Package Signing.

  • Se ha devuelto la capacidad de crear e importar archivos de certificado de firma (. pfx) mediante el Diseñador de manifiestos.
    Brought back the ability to create and import signing certificate files (.pfx) through the Manifest Designer.
    uwp signing
  • Se ha incorporado la capacidad de crear e importar certificados de firma a través del Asistente para empaquetado para simplificar el proceso de firma.
    Introduced the ability to create and import signing certificates through the Packaging Wizard to streamline the signing process.
    uwp signing

Herramientas de .NET.NET tools

  • Se ha agregado compatibilidad para incorporar nuevas referencias de servicio Open API y GRPC a proyectos de .NET Core 3.0.Support for adding new Open API & GRPC service references to .NET Core 3.0 projects.
  • Publique proyectos de trabajo de .NET Core 3.0 en Azure Container Registry, DockerHub, etc.Publish .NET Core 3.0 worker projects Azure Container Registry, DockerHub, etc.
  • En el cuadro de diálogo Nuevo proyecto aparecen las plantillas de .NET Core 3.0 para Worker, gRPC, la biblioteca de clases de Razor y Blazor..NET Core 3.0 templates for Worker, gRPC, Razor Class library & Blazor are surfaced in the New Project Dialog.
  • Todas las actualizaciones realizadas en las plantillas de .NET Core 3.0 mediante la CLI de .NET también se muestran en Visual Studio.Any updates made to the .NET Core 3.0 templates via the .NET CLI are also surfaced in Visual Studio.

C++C++

  • Los desarrolladores de C++ ahora pueden alternar los comentarios de línea mediante el método abreviado de teclado Ctrl + K, Ctrl + / .C++ developers can now toggle line comments using the keyboard shortcut Ctrl + K, Ctrl + /.
  • Ahora, las listas de miembros de IntelliSense se filtran en función de calificadores de tipo; por ejemplo, const std::vector ahora filtrará métodos como push_back.IntelliSense member lists are now filtered based on type qualifiers, e.g. const std::vector will now filter out methods such as push_back.
  • Se han agregado las siguientes características de la versión preliminar de la biblioteca estándar de C++20 (con /std:c++latest):Added the following C++20 Standard Library preview features (with /std:c++latest):
    • P0487R1: corrección de operator>>(basic_istream&, CharT*)P0487R1: Fixing operator>>(basic_istream&, CharT*)
    • P0616R0: uso de move() en <numeric>P0616R0: Using move() In <numeric>
    • P0758R1: is_nothrow_convertibleP0758R1: is_nothrow_convertible
    • P0734R0: extensiones de C++ para conceptosP0734R0: C++ extensions for Concepts
    • P0898R3: conceptos de biblioteca estándarP0898R3: Standard Library Concepts
    • P0919R3: búsqueda heterogénea para contenedores sin ordenarP0919R3: Heterogeneous Lookup For Unordered Containers
  • Nuevas comprobaciones de instrucciones de C++ Core, incluido el nuevo conjunto de reglas “Enum Rules”, así como reglas adicionales de tipo, enumeración y constantes.New C++ Core Guideline checks, including the new "Enum Rules" rule set, and additional const, enum, and type rules.
  • Un nuevo esquema predeterminado de coloración semántica permite a los usuarios comprender mejor su código a simple vista, la ventana Pila de llamadas se puede configurar para ocultar los argumentos de la plantilla, e IntelliCode de C++ está activado de forma predeterminada.A new default semantic colorization scheme allows users to better understand their code at a glance, the call-stack window can be configured to hide template arguments, and C++ IntelliCode is on-by-default.
  • Configure los destinos de depuración y las tareas personalizadas con variables de entorno mediante CMakeSettings.json o CppProperties.json, o bien con la nueva etiqueta “env” en tareas y destinos individuales en launch.vs.json y tasks.vs.json.Configure debug targets and custom tasks with environment variables using CMakeSettings.json or CppProperties.json or the new "env" tag on individual targets and tasks in launch.vs.json and tasks.vs.json.
  • Ahora, los usuarios pueden usar una acción rápida en paquetes de vcpkg que falten para abrir automáticamente una consola y realizar una instalación en la instancia de vcpkg predeterminada.Users can now use a quick action on missing vcpkg packages to automatically open a console and install to the default vcpkg installation.
  • La copia de encabezados remotos realizada por proyectos de Linux (CMake y MSBuild) se ha optimizado y ahora se ejecuta en paralelo.The remote header copy done by Linux projects (CMake and MSBuild) has been optimized and now runs in parallel.
  • La compatibilidad nativa con WSL de Visual Studio ahora admite las compilaciones en paralelo para proyectos de Linux basados en MSBuild.Visual Studio's native support for WSL now supports parallel builds for MSBuild-based Linux projects.
  • Ahora, los usuarios pueden especificar una lista de resultados de compilación locales para implementarlos en un sistema remoto con proyectos de archivos Make de Linux.Users can now specify a list of local build outputs to deploy to a remote system with Linux Makefile projects.
  • Las descripciones del Editor de configuración de CMake ahora contienen más contexto y vínculos a la documentación de ayuda.Setting descriptions in the CMake Settings Editor now contain more context and links to helpful documentation.

Herramientas de contenedorContainer Tools

  • Los desarrolladores que creen Azure Functions (v2) ahora pueden agregar la compatibilidad con contenedores de Docker (solo en Linux) a sus proyectos de C#.Developers building Azure Functions (v2) can now add Docker container support (Linux only) to their C# projects. Para ello, haga clic con el botón derecho sobre el nombre del proyecto en el Explorador de soluciones y seleccione “Agregar” --> “Compatibilidad con Docker”.This can be done by right clicking the project name in Solution Explorer and selecting "Add" --> "Docker Support". Además de agregar un archivo de Docker al proyecto, el destino depuración se establecerá en “Docker”.In addition to adding a Dockerfile to your project the debug target will be set to "Docker". Esto quiere decir que la depuración de código de Functions se producirá dentro del contenedor en ejecución.What this means is debugging of Functions code will happen inside of the running container. Los usuarios podrán alcanzar puntos de interrupción, inspeccionar variables y usar todas las características avanzadas de depuración que ofrece Visual Studio.Users will be able to hit breakpoints, inspect variables, and use all the powerful debugging features Visual Studio provides.
Debug Azure Functions running in Linux containers.
Depurar Azure Functions que se ejecuten en contenedores de LinuxDebug Azure Functions running in Linux containers

Generación de perfiles de base de datos para proyectos de .Net CoreDatabase Profiling for .Net Core projects

Esta versión incluye una nueva herramienta en el conjunto de herramientas de rendimiento y diagnóstico disponibles a través del Generador de perfiles de rendimiento (ALT + F2).This release includes a new tool in the suite of performance and diagnostics tools available via the Performance Profiler (ALT-F2). La nueva herramienta de base de datos proporcionará detalles sobre las consultas de proyectos de .Net Core usan ADO.Net o Entity Framework.The new database tool will provide details about queries from .Net Core projects which utilize ADO.Net or Entity Framework. La herramienta proporciona una opción "ir al origen" para crear un vínculo al código fuente, así como detalles de tiempo sobre cada consulta ejecutada durante una sesión de generación de perfiles.The tool provides a "go to source" option for linking to source code and provides timing details for each query executed during a profiling session. Esta herramienta puede trabajar simultáneamente con otras herramientas del Generador de perfiles de rendimiento.This tool can work simultaneously with other tools in the Performance Profiler. Cuando se utiliza con la herramienta Uso de CPU, se obtiene información detallada sobre las características de rendimiento del código de .Net Core que utiliza una base de datos.When used in conjunction with the CPU Usage tool, one gains detailed information about the performance characteristics of .Net Core code which uses a database.

DepuradorDebugger

  • En la ventana Pilas paralelas, se ha mejorado la visualización de tareas y sus dependencias en un proceso para que resulte más fácil diagnosticar problemas en código asincrónico.The Parallel Stacks Window has improved the visualization of tasks and their dependencies in a process to make it easier to diagnose problems in asynchronous code.
Tasks visualization in parallel stacks window
Mejora de la visualización de tareas en la ventana Pilas paralelasImproved task visualization in the Parallel Stacks Window

F# y herramientas de F#F# and F# tools

Esta versión incluye compatibilidad con F# 4,7, la versión más reciente del lenguaje F#.This release includes support for F# 4.7, the newest version of the F# language!

Gran parte de F# 4.7 se dedicó a los cambios de infraestructura subyacentes que nos permiten ofrecer una versión preliminar de la funcionalidad del lenguaje F# de forma más efectiva.Much of F# 4.7 was dedicated to underlying infrastructural changes that allow us to deliver preview of F# language functionality more effectively. Dicho esto, todavía hay algunas características nuevas muy útiles.That said, there are still some nice new features delivered as well.

Lenguaje F# y biblioteca principalF# language and core library

Hemos agregado soporte técnico para F# 4.7, una versión secundaria del lenguaje que viene con una infraestructura de compilador para habilitar las características de versión preliminar de modo que podamos obtener comentarios sobre los diseños de las características en las primeras etapas del proceso de desarrollo.We added support for F# 4.7, a minor language release that comes with compiler infrastructure to enable preview features so that we can get feedback on feature designs earlier in the development process.

El conjunto de características completo de F# 4.7 es:The full F# 4.7 feature set is:

Además del conjunto de características de F# 4.7, esta versión incluye compatibilidad con las siguientes características del lenguaje F# de versión preliminar:In addition to the F# 4.7 feature set, this release includes support for the following preview F# language features:

Puede habilitarlo mediante la configuración de <LangVersion>preview</LangVersion> en el archivo del proyecto.You can enable this by seeting <LangVersion>preview</LangVersion> in your project file.

Esta versión también incluye las siguientes mejoras y correcciones de errores para el compilador de F#:This release also contains the following bug fixes and improvements to the F# compiler:

  • Se ha resuelto un problema antiguo en el que el compilador de F# podía tener un desbordamiento de pila con registros masivos, estructuras u otros tipos (#7070).A longstanding issue where the F# compiler could stack overflow with massive records, structs, or other types has been resolved (#7070)
  • Se ha resuelto un problema en el que la especificación de IL insertado no válido podía bloquear Visual Studio (#7164).An issue where specifying invalid inline IL could crash Visual Studio has been resolved (#7164
  • Resolución de un problema en el que la copia de un elemento struct no se produciría si C# se hubiera definido y hubiera mutado en una llamada de miembro (#7406).Resolution of an issue where copying of a struct would not occur if it was defined in C# and mutated in a member call (#7406)
  • Un hash criptográfico del contenido PDB portátil creado por el compilador no está incluido en el directorio de depuración de PE, con un hash configurable establecido en SHA-256 de forma predeterminada (#4259, #1223).A crypto hash of the portable PDB content created by the compiler is not included in the PE debug directory, with a configurable hash set to SHA-256 by default (#4259, #1223)
  • Se ha corregido un error en el que LeafExpressionConverter ignoró ValueType y asumió System.Tuple (#6515) por Kevin Malenfant.A bug where LeafExpressionConverter ignored ValueType and assumed System.Tuple has been fixed (#6515) by Kevin Malenfant
  • Se ha resuelto un error en el que se descartaron datos List.transpose en lugar de producir una excepción (#6908) por Patrick McDonald.A bug where List.transpose discaded data instead of throwing an exception has been resolved (#6908) by Patrick McDonald
  • Se ha resuelto un error en el que List.map3 producía un error engañoso cuando se utilizaba en listas de diferentes longitudes (#6897) por reacheight.A bug where List.map3 gave a misleading error when used on lists of different lengths has been resolved (#6897) by reacheight

Herramientas de F#F# tools

En esta versión también se incluyen algunas mejoras en las herramientas de F# para Visual Studio:This release also includes a few improvements to the F# tools for Visual Studio:

  • El formato de los registros es más parecido a las declaraciones canónicas y a los valores de la información sobre herramientas y F# interactivo (#7163).Records are formatted more to look more like canonical declarations and values in tooltips and F# interactive (#7163)
  • Ahora, las propiedades de la información sobre herramientas especifican si son solo get, solo set, o get y set (#7007).Properties in tooltips now specify whether or not that are get-only, set-only, or get and set (#7007)
  • Se ha corregido un problema en el que Ir a la definición y otras características no siempre podían funcionar en todos los proyectos cuando los archivos utilizan barras diagonales (#4446, #5521, #4016), con la ayuda de chadunit.An issue where Go to Definition and other features could not always work across projects when files use forward slashes (#4446, #5521, #4016) has been fixed, with help from chadunit
  • Se han resuelto problemas con registros anónimos y depuración (#6728, #6512).Issues with anonymous records and debugging have been resolved (#6728, #6512)
  • Se ha resuelto un error por el que las directivas hash vacías en el código fuente podían hacer que el color del texto fuente pareciera aleatorio (#6400, #7000).A bug where empty hash directives in source could make source text coloring seem random has been resolved (#6400, #7000)

IDEIDE

  • Un cuadro de búsqueda en la ventana de inicio permite ubicar rápidamente los proyectos, las soluciones y las carpetas que se han usado recientemente.A search box in the start window allows you quick location of recently used projects, solutions, and folders. Además, estos contenedores de código MRU se integran con la búsqueda global de Visual Studio para que los desarrolladores puedan encontrarlos a través del cuadro de búsqueda de Visual Studio.In addition, these MRU code containers integrate with Visual Studio global search so developers can find them through the Visual Studio search box.
Start window MRU search
Búsqueda en la lista de proyectos recientes en la ventana de inicioSearch in recent projects list on start window
  • Las mejoras en la interfaz del cuadro de diálogo del instalador en el IDE de Visual Studio ahora permiten identificar con mayor facilidad cargas de trabajo específicas agregadas a Visual Studio.Improvements to the Installer dialog interface within the Visual Studio IDE makes it easier to identify specific workloads being added to Visual Studio.
  • Búsqueda de VS admitirá la búsqueda de tipos y miembros con C# y VB, así como la búsqueda de archivos en todos los idiomas.VS Search will support the ability to search for types and members with C# and VB, as well as file search for all languages. Se mostrarán los resultados a medida que los usuarios escriban la consulta de búsqueda, así como en el grupo “Código” específico accesible mediante métodos abreviados de teclado o clics del mouse.Results will show up as users type their search query, as well as in a dedicated ‘Code’ group accessible via keyboard shortcut or mouse click.
  • Las plantillas de proyecto recién instaladas se marcan con la etiqueta “Nueva”, lo que permite identificarlas rápidamente, y los filtros muestran los valores seleccionados en el cuadro de diálogo Nuevo proyecto.Newly installed project templates are indicated with a "New" label to allow quick identification, and filters show selected values in the New Project Dialog. Además, los desarrolladores pueden organizar las plantillas usadas recientemente en la lista (se pueden anclar, desanclar y quitar).In addition, developers can organize recently used templates by pinning, unpinning, and removing them from the list.
Start window MRU search
Vea los proyectos recién instalados y los filtros seleccionados, y ancle plantillas en el cuadro de diálogo Nuevo proyecto.See newly installed projects and selected filters, and pin templates in the New Project Dialog
  • Busque plantillas en el cuadro de diálogo Nuevo proyecto a través de una búsqueda aproximada más sólida que se adapta con errores tipográficos y plurales para resaltar las palabras clave coincidentes y clasifique los resultados en función de la relevancia de búsqueda y filtro.Search for templates in the New Project Dialog through a more robust fuzzy search which adapts with typos and plurals to highlighting matching keyword and rank results based on search and filter relevance.
New Project Dialog template search
Precisión de búsqueda y resaltado mejorados en la búsqueda de plantillas de proyectosImproved search accuracy and highlighting in project templates search

InstaladorInstaller

  • Ahora, Visual Studio actualiza tanto el IDE de Visual Studio como el instalador mediante un solo clic para mejorar la productividad.Visual Studio now updates both the Visual Studio IDE and the Installer with a single click for increased productivity.
  • Los componentes del instalador de Visual Studio para .NET Core 2.1 y 2.2 solían contener únicamente el entorno de ejecución.The Visual Studio installer components for .NET Core 2.1 and 2.2 used to only carry the runtime. A partir de esta versión preliminar, los componentes también contendrán las plantillas y el entorno de ejecución.From this preview onwards the components will also carry the templates as well as the runtime.
  • Un cuadro de búsqueda en la pestaña “Componentes individuales” del instalador de Visual Studio permite buscar rápidamente todos los componentes disponibles para su instalación.A search box in the Visual Studio Installer's Individual components tab allows for quick location of all available components for installation.
Installer components search
Buscar componentes individuales en el instalador de Visual StudioSearch individual components in the Visual Studio Installer

IntelliCodeIntelliCode

  • El modelo base de C++ se ha activado de forma predeterminada.The C++ base model has been turned on by default.
    • Para cambiar esta configuración, vaya a Herramientas > Opciones > IntelliCode.You can change this setting by going to Tools > Options > IntelliCode.
  • Hemos incluido ediciones repetidas para C#, que analizan las modificaciones locales en busca de cambios repetibles y determina otros lugares en los que puede necesitar este cambio dentro del mismo archivo.We've included Repeated Edits for C#, which analyzes local edits for repeatable changes and determines other places you may need this change within the same file.
    • Las ediciones repetidas sugeridas aparecerán en la lista de errores y como advertencias dentro del archivo de código.Suggested repeated edits will appear in the Error List and as warnings within the code file.

JavaScript/TypeScriptJavaScript/TypeScript

  • La clasificación de JavaScript y TypeScript (que suele conocerse como “color de sintaxis”) se aplicará con mayor rapidez en archivos de gran tamaño.JavaScript and TypeScript classification (commonly called “syntax coloring”) will be applied to large files more quickly. La lista de refactorizaciones y correcciones de código de JavaScript y TypeScript (es decir, la bombilla) también se mostrará con mayor rapidez.The list of JavaScript and TypeScript code fixes and refactorings (i.e. the lightbulb) will also be displayed more quickly.
  • Ahora hay compatibilidad con el editor para TypeScript 3.6.There is now editor support for TypeScript 3.6.
  • Cuando se edita o cambia un archivo tsconfig.json, Visual Studio actualizará ahora el proyecto de forma más responsable.When a tsconfig.json file is edited or changed, Visual Studio will now refresh the project more responsively.

Pruebas de PythonPython Tests

  • Los desarrolladores de Python ahora pueden ejecutar pruebas mediante el popular pytest del marco de Python, tanto en proyectos de Python como en escenarios del área de trabajo de Abrir carpeta.Python Developers can now run tests using the popular Python framework pytest in both Python projects and Open Folder workspace scenarios.

  • Para habilitar pytest y unittest en un proyecto de Python, haga clic con el botón derecho en el nombre de la solución del proyecto y seleccione Propiedades.To enable pytest and unittest for Python projects, right-click on the project solution name and select Properties. Después, seleccione la pestaña Prueba para seleccionar opciones de pruebas.From there, select the Test tab to select testing options. Tenga en cuenta que, en el caso de unittest, tendrá que especificar el directorio de las pruebas (el directorio raíz es el predeterminado), así como el patrón para los nombres de archivo de las pruebas.Note that for unittest, you must specify the directory for the tests (root directory is the default) as well as the pattern for the test filenames. La detección de pruebas se inicia en cuanto se guardan los cambios en la pestaña Prueba.

    Test Discovery is intitiated as soon as changes are saved in the Test tab.
    pythontest_project
    Configurar un proyecto de Python para detectar pytests o pruebas escritas con unittest. Tenga en cuenta que, al seleccionar “Mostrar resultados de: pruebas” en la ventana de salida, los usuarios podrán ver la información de registro asociada a las ejecuciones de prueba, tanto de las pruebas completadas correctamente como de las pruebas con errores.Configuring a Python project to discover pytests or tests written with unittest. Notice that by selecting 'Show output from: Tests' in the Output Window, users are able to see logging information associated with test runs, for both failed and passed tests.

  • La experiencia de pruebas de unittest se ha rediseñado de forma que, ahora, un usuario tiene que configurar de forma manual las pruebas, tanto para proyectos de Python como para áreas de trabajo de Abrir carpeta, porque estas pruebas ya no se detectan automáticamente:The unittest testing experience has been reworked such that a user now needs to manually configure tests for both Python projects and Open Folder workspaces as these tests are no longer automatically discovered:

  • Para habilitar las pruebas para las carpetas de Python, haga clic en elTo enable tests for Python folders, click on the Show All Files icono para Mostrar todos los archivos en el Explorador de soluciones.icon to Show All Files in the Solution Explorer. Desde allí, haga clic en el archivo PythonSettings.json que se encuentra dentro de la carpeta “Configuración local” (si no hay ningún archivo, cree uno).From there, click on the PythonSettings.json file located within your 'Local Settings' folder (if there isn't a file there, create one). En el archivo, puede especificar el valor de “TestFramework” que quiera usar, así como los patrones de nombres de archivo de las pruebas y el directorio que contendrá las pruebas (ambas opciones se aplicarán en unittest):

    Within this file, you can specify the 'TestFramework' you wish to use as well as the test filename patterns and the directory that contains your tests (both options apply to unittest):
    pythontest_folder

  • La depuración de pruebas se ha actualizado para usar PTVSD 4; pero, si los usuarios siguen usando el “depurador heredado” o se encuentran con problemas al usar un nuevo depurador, pueden habilitarlo; para hacerlo, vaya a Herramientas > Opciones > Python > Depuración > Usar depurador heredado y active la casilla.Test debugging is updated to use PTVSD 4, but if users wish to continue using the 'Legacy Debugger' or run into any issues with using the new debugger, they can enable it by going to Tools > Options > Python > Debugging > Use Legacy Debugger and check the box to enable it.

  • También hemos facilitado que los usuarios con proyectos preexistentes y en áreas de trabajo de Abrir carpeta que contengan archivos de prueba puedan seguir trabajando rápidamente con su código en Visual Studio 2019.We have also made it simple for users with pre-existing projects and in open folder workspaces that contain test files to quickly continue working with their code in Visual Studio 2019. Cuando los usuarios abren un proyecto que contiene archivos de configuración de prueba (por ejemplo, un archivo .ini para pytest), pero no han instalado ni habilitado pytest, se les pedirá que instalen los paquetes necesarios y que los configuren para el entorno de Python en el que estén trabajando:

    When users open a project that contains testing configuration files (e.g. a .ini file for pytest), but they have not installed or enabled pytest, they will be prompted to install the necessary packages and configure them for the Python environment they are working:
    pytest infobar
    Cada vez que se abre un proyecto o carpeta de Python que contiene archivos de prueba que no se han configurado, se pedirá a los usuarios que lo hagan y que instalen el paquete de pruebas necesario, que en este ejemplo es pytest.Whenever a Python project or folder is opened that contains test files that aren't configured, users are prompted to do so as well as install the necessary test package, which in this example, is pytest.

  • De forma similar, para los archivos de prueba de unittest en un proyecto o área de trabajo de Abrir carpeta, se pedirá a los usuarios que instalen o habiliten el marco de pruebas.Similarly for unittest test files within a project or open folder workspace, users will be prompted to install and/or enable the testing framework. En ambos escenarios, los desarrolladores pueden omitir el mensaje y configurar el marco de forma manual.For both scenarios, developers have the option to ignore the message and to manually configure the framework.

Generador de perfiles de rendimiento de Visual StudioVisual Studio Performance Profiler

  • La herramienta de uso de CPU del generador de perfiles de rendimiento muestra automáticamente el indicador "ruta de acceso activa" con un icono de llama roja al mostrar el árbol de llamadas.The CPU Usage tool in the Performance Profiler automatically displays the "hot path" indicator with a red flame icon when displaying the Call Tree. Esto ahorra un clic en las investigaciones de rendimiento habituales sobre el uso de CPU.This saves a click on common CPU Usage performance investigations. Se puede obtener acceso a las herramientas de uso de CPU mediante Alt + F2 o desde el menú Depurar.The CPU Usage tools is accessible by using Alt-F2 or from the Debug menu.
  • El generador de perfiles de rendimiento participa ahora en la navegación hacia delante o hacia atrás en el IDE de Visual Studio.The Performance Profiler now participates in forward/backward navigation in the Visual Studio IDE. A medida que los desarrolladores navegan por varias vistas de herramientas en el generador de perfiles de rendimiento, los puntos de navegación se guardan junto con otros elementos de navegación.As developers navigate to various views of tools in the Performance Profiler, navigation points are saved along with other navigation items. Pueden emplearse haciendo clic en los botones de navegación o usando comandos de navegación en Visual Studio.They can be employed by clicking the navigation buttons or using navigation commands in Visual Studio.
Forward/Backward Navigation Image
Navegación hacia delante o hacia atrás en el generador de perfilesForward/Backward Navigation in the Profiler

Herramientas webWeb Tools

  • Configure fácilmente las dependencias de sus aplicaciones en perfiles de publicación mediante el asistente Agregar dependencia.Easily configure applications' dependencies in publish profiles using the new Add Dependency wizard. Actualmente, admite la adición de dependencias a Azure SignalR Service, Azure SQL Server y Azure Storage, lo que permite a los usuarios aprovisionar nuevas instancias o seleccionar instancias existentes sin salir del IDE.It currently supports adding dependencies to Azure SignalR Service, Azure SQL Server, Azure Storage allowing users to either provision new instances or select existing ones without leaving the IDE.
  • El equipo del entorno de ejecución de ASP.NET ha habilitado la compatibilidad para servir contenido estático desde bibliotecas de clases de Razor debido a la demanda popular.The ASP.NET runtime team has enabled support for serving static content from within Razor class libraries due to popular demand. En esta versión preliminar de Visual Studio, el equipo ha agregado la compatibilidad con herramientas para este escenario.In this preview of Visual Studio, the team has added tooling support for this scenario.

XamarinXamarin

En esta versión se incluyen las siguientes características del SDK de Xamarin:This release includes the following Xamarin SDK updates:

  • Xamarin.iOS 13Xamarin.iOS 13
    • Agrega compatibilidad con Xcode 11 para compilar y depurar aplicaciones para iOS 13, tvOS 13 y watchOS 6.Adds support for Xcode 11 to build and debug apps for iOS 13, tvOS 13, and watchOS 6. Para obtener información detallada sobre las nuevas características disponibles, consulte nuestra introducción a iOS 13.See our Introduction to iOS 13 for more details on the new features available.
  • Xamarin.Android 10Xamarin.Android 10
    • Ahora, las aplicaciones Android pueden tener como destino Android 10 estableciendo la opción Compilar con la versión de Android: (plataforma de destino) en Android 10.0 (Q) , en la pestaña Aplicación de las páginas de propiedades del proyecto.Android apps can now target Android 10 by setting Compile using Android version: (Target Framework) to Android 10.0 (Q) under the Application tab of the project property page. Android 10 incluye características como el tema oscuro, la navegación gestural y las optimizaciones para dispositivos plegables.Android 10 introduces features such as dark theme, gestural navigation, and optimizations for foldable devices. Consulte nuestra página de Android 10 con Xamarin para obtener más información sobre estas nuevas características.See our Android 10 with Xamarin page for more information on these new features.
android q
Establezca la opción Compilar con la versión de Android: (plataforma de destino) en Android 10.0 (Q).Set the Compile using Android version: (Target Framework) to Android 10.0 (Q).

Esta versión también incluye varias características de herramientas y mejoras nuevas:This release also includes several new tooling features and enhancements:

  • En esta versión se encuentra disponible una versión preliminar pública de la Recarga activa de XAML para Xamarin.Forms.A public preview of XAML Hot Reload for Xamarin.Forms is available in this release. La Recarga activa de XAML le permite iterar rápidamente en la interfaz de usuario durante la depuración de la aplicación en un emulador, un simulador o un dispositivo físico.XAML Hot Reload lets you rapidly iterate on your UI while debugging your app on an emulator, simulator, or physical device. Simplemente edite el código XAML y guarde el archivo para ver los cambios inmediatamente reflejados en la aplicación en ejecución.Simply edit your XAML then save the file to see the changes immediately reflected on the running app. Para habilitar la Recarga activa de XAML, vaya a Herramientas > Opciones > Xamarin > Recarga activa.To enable XAML Hot Reload, go to Tools > Options > Xamarin > Hot Reload.
xaml hot reload
Recarga activa de XAML para Xamarin.Forms.XAML Hot Reload for Xamarin.Forms.
  • El controlador de vista previa de XAML para Xamarin.Forms ahora representa el diseño del material tanto para iOS como para Android al usar Xamarin.Forms Visual.The XAML Previewer for Xamarin.Forms now renders Material design for both iOS and Android when using Xamarin.Forms Visual.
  • Xamarin Designer para iOS tiene una nueva forma de trabajar con restricciones.The Xamarin Designer for iOS has a new way to work with constraints. Al seleccionar una vista restringida, ahora aparecerán puntos suspensivos en la barra de herramientas situada junto al selector del modo de anclaje de las restricciones.When you select a constrainable view, an ellipsis will now appear in the toolbar next to the Constraints Pinning Mode selector. Haga clic en los puntos suspensivos con el fin de mostrar un elemento flotante para editar restricciones en la vista seleccionada.Click the ellipsis to display a popover for editing constraints on the selected view.
new ios constraints editor
Nuevo elemento flotante del editor de restricciones de iOS.New iOS constraints editor popover.
  • Ahora puede archivar y publicar aplicaciones de iOS desde Visual Studio en Windows.You can now archive and publish iOS apps from Visual Studio on Windows. Cree un archivo cuando se empareje a un equipo Mac; para ello, establezca la configuración en Versión|iPhone, haga clic con el botón derecho en el proyecto iOS del Explorador de soluciones y, a continuación, seleccione la opción de menú Archivar...Create an archive while paired to a Mac machine by setting the configuration to Release|iPhone, right-clicking your iOS project in the Solution Explorer, and selecting the Archive... menu option. En el administrador de archivos, puede guardar un archivo .ipa en el disco para la distribución ad hoc o cargar en App Store Connect para publicar la aplicación en App Store.From the archive manager you can save an .ipa to disk for ad-hoc distribution or upload to App Store Connect to publish your app to the App Store.
  • Al hacer clic con el botón secundario en un archivo .plist en el Explorador de soluciones, hay nuevas opciones para abrirlo rápidamente mediante el diseñador plist genérico o el editor XML.When you right-click a .plist file in the Solution Explorer, there are new options to quickly open it using the generic plist designer or the XML editor.
new plist options
Nuevas opciones para abrir archivos .plist.New options to open .plist files.

Problemas conocidosKnown Issues

Consulte todos los problemas y las soluciones alternativas disponibles de la versión 16.3 de Visual Studio 2019 en el vínculo siguiente.See all issues and available workarounds in Visual Studio 2019 version 16.3 by following the below link.

Visual Studio 2019 Known Issues Visual Studio 2019 Known Issues


ComentariosFeedback

Nos encantaría que nos diera su opinión.We would love to hear from you! Puede informarnos de un problema mediante la opción Notificar un problema de la esquina superior derecha del instalador o del propio IDE de Visual Studio.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. A la claseThe Feedback Icon icono se encuentra en la esquina superior derecha.icon is located in the upper right-hand corner. Puede realizar una sugerencia de producto o un seguimiento de los problemas en la comunidad de desarrolladores de Visual Studio, donde podrá hacer preguntas, encontrar respuestas y proponer nuevas características.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. También puede obtener ayuda gratuita para la instalación a través de nuestro servicio de soporte técnico de chat en directo.You can also get free installation help through our Live Chat support.


BlogsBlogs

Saque partido de la información y de las recomendaciones disponibles en los blogs de Developer Tools que le mantendrán al día sobre las nuevas versiones y con publicaciones con mucha información sobre una gran variedad de características.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Historial de notas de la versión de Visual Studio 2019Visual Studio 2019 Release Notes History

Para obtener más información sobre versiones anteriores de Visual Studio 2019, consulte la página Historial de notas de la versión de Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Principio de página
Top of Page