Cómo: editar archivos XMLHow to: Edit XML files

El Editor XML es el nuevo editor de archivos XML.The XML Editor is the new editor for XML files. Se puede utilizar en un archivo XML independiente o en uno asociado con un proyecto de Visual Studio.It can be used on a stand-alone XML file, or on a file associated with a Visual Studio project. El Editor XML está asociado con las siguientes extensiones de archivo: .config, .dtd, .xml, .xsd, .xdr, .xsl, .xslt, y vssettings.The XML Editor is associated with the following file extensions: .config, .dtd, .xml, .xsd, .xdr, .xsl, .xslt, and .vssettings. También está asociado con otros tipos de archivos que no tengan registrado un editor específico y que incluyan contenido XML o DTD.The XML Editor is also associated with any other file type that has no specific editor registered, and that contains XML or DTD content.

Note

Los documentos XHTML son manejados con el Editor HTML.XHTML documents are handled by the HTML Editor.

Para editar un archivo XMLTo edit an XML file

  1. Haga doble clic en el archivo que desea editar.Double-click the file you want to edit.

Para agregar un nuevo archivo XML a un proyectoTo add a new XML file to a project

  1. Desde el proyecto menú, seleccione Agregar nuevo elemento.From the Project menu, select Add New Item.

  2. Seleccione archivo XML desde el plantillas panel.Select XML File from the Templates pane.

  3. Escriba el nombre de archivo en el nombre campo y presione agregar.Enter the filename in the Name field and press Add.

    Se agrega el archivo XML al proyecto y se abre en el Editor XML.The XML file is added to the project and opened in the XML Editor. El archivo contiene la declaración XML predeterminada, <?xml version="1.0" encoding="utf-8" ?>.The file contains the default XML declaration, <?xml version="1.0" encoding="utf-8" ?>.

Para agregar un archivo XML existente a un proyectoTo add an existing XML file to a project

  1. Desde el proyecto menú, seleccione Agregar elemento existente.From the Project menu, select Add Existing Item.

    El Agregar elemento existente aparece el cuadro de diálogo.The Add Existing Item dialog box appears.

  2. Seleccione un archivo XML y presione agregar.Select an XML file and press Add.

Para crear un nuevo archivo XML o XSLTTo create a new XML or XSLT file

  1. Desde el archivo menú, seleccione nuevo.From the File menu, select New.

    El nuevo archivo aparece el cuadro de diálogo.The New File dialog box appears.

  2. Seleccione archivo XML para crear un nuevo archivo XML, o bien, seleccione archivo XSLT para crear una nueva hoja de estilos XSLT.Select XML File to create a new XML file; or, select XSLT File to create a new XSLT style sheet.

  3. Haga clic en abiertos.Click Open.

Para crear un proyecto de archivos XMLTo create a project for XML files

  1. Desde el archivo menú, seleccione Newy, a continuación, seleccione proyecto.From the File menu, select New, and then select Project.

    Aparecerá el cuadro de diálogo Nuevo proyecto .The New Project dialog box appears.

  2. Seleccione el lenguaje de código de su elección, seleccione proyecto vacíoy haga clic en Aceptar.Select the code language of your choice, select Empty Project, and click OK.

  3. Agregue archivos XML al proyecto.Add XML files to the project.

    El Editor XML busca los esquemas que agregue a este proyecto y los utiliza para la validación e IntelliSense en cualquier archivo XML, de esquema o XSLT que edite mientras este proyecto está abierto.The XML Editor finds the schemas you add to this project and uses them for validation and IntelliSense in any XML, schema, or XSLT files that you edit while this project is open.

Vea tambiénSee also