2. Creación de una aplicación para PC de comunicación remota holográfica2. Creating a Holographic Remoting PC application

En este tutorial, aprenderá cómo crear una aplicación de PC para la comunicación remota holográfica y a conectarse a HoloLens 2 en cualquier momento, lo que proporciona una manera de visualizar contenido 3D en realidad mixta.In this tutorial, you will learn how to create a PC app for Holographic Remoting and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality.

ObjetivosObjectives

  • Configurar Unity para la comunicación remota holográficaConfigure Unity for Holographic Remoting
  • Aprender a compilar e implementar la aplicación con Visual StudioLearn how to build and deploy the application with Visual Studio
  • Desarrollar una aplicación de comunicación remota holográfica y conectarla a HoloLensDeveloping Holographic Remoting application and connecting to HoloLens

Configurar la escena para la comunicación remota holográficaConfiguring your scene for Holographic Remoting

En esta sección, configurará el proyecto para que transmita la experiencia de realidad mixta a su dispositivo HoloLens 2 desde su PC en tiempo real a través de una conexión Wi-Fi.In this section, you will configure your project to stream your Mixed Reality experience to your HoloLens 2 device from your PC in real-time over a Wi-Fi connection.

En la ventana Project (Proyecto), vaya a la carpeta Assets > MRTK.Tutorials.PCHolograhicRemoting > Prefabs y haga clic y arrastre el elemento prefabricado HolographicRemoting a la escena.In the Project window, navigate to the Assets > MRTK.Tutorials.PCHolograhicRemoting > Prefabs folder, and click and drag HolographicRemoting prefab into your scene.

Unity con el objeto prefabricado HolographicRemoting recién agregado aún seleccionado

Compilación de la aplicación para PCBuild your application to PC

La aplicación de comunicación remota holográfica ya está lista para compilarse en su PC.Your Holographic Remoting app is now ready to build on your PC. Siga los pasos que se indican a continuación y realice estos cambios para compilar esta aplicación en su PC.Follow the below steps and make these changes to build this application on to your PC.

1. Configuración del reproductor1. Set the player settings

En el menú de Unity, seleccione Edit > Project Settings (Editar > Configuración del proyecto) para abrir la ventana Player Settings (Configuración del reproductor):In the Unity menu, select Edit > Project Settings to open the Player Settings window.

En la ventana Project Settings (Configuración del proyecto), expanda Publishing Settings (Configuración de la publicación), desplácese hacia abajo a la sección Funcionalidades y seleccione la casilla de funcionalidad que aparece a continuación además de las funcionalidades ya existentes.In the Project Settings window, expand the Publishing Settings, scroll down to the Capabilities section and select the below-shown capability checkbox in addition to the existing capabilities.

  • Servidor cliente de InternetInternet Clint server
  • Servidor cliente de red privadaPrivate Network Client Server

En la sección XR Settings (Configuración de XR), seleccione la casilla WSA Holographic Remoting Supported (Admitir la comunicación remota holográfica de WSA) y habilite la comunicación remota holográfica.In the XR Settings section, select the WSA Holographic Remoting Supported checkbox and enable the Holographic Remoting.

Ventana XR Settings (Configuración de XR) de Unity con WSA Holographic Remoting Supported (Admitir la comunicación remota holográfica de WSA) habilitado

2. Compilación del proyecto de Unity2. Build the Unity Project

En el menú de Unity, seleccione File > Build Settings (Archivo > Configuración de compilación) para abrir la ventana Build Settings (Configuración de compilación).In the Unity menu, select File > Build Settings to open the Build Settings window.

En la ventana Build Settings (Configuración de compilación), haga clic en el botón *Add Open Scenes _ (Agregar escenas abiertas) para agregar la escena actual a las escenas.In the Build Settings window, click the *Add Open Scenes _ button to add your current scene to the Scenes. En la lista Build (Compilación), haga clic en el botón Build (Compilar) para abrir la ventana Build Universal Windows Platform (Compilar Plataforma universal de Windows):In the Build list, then click the Build button to open the Build Universal Windows Platform window:

Ventana Build Settings (Configuración de compilación) de Unity con la escena agregada

En la ventana Build Universal Windows Platform (Compilar Plataforma universal de Windows), elija una ubicación adecuada para almacenar la compilación, como por ejemplo, Mis Documentos\AprendizajeRealidadMixta.In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, Documents\MixedRealityLearning. Cree una nueva carpeta y asígnele un nombre adecuado, por ejemplo, ComunicaciónRemotaHolográficaPC.Create a new folder and give it a suitable name, for example, PCHolographicRemoting. A continuación, haga clic en el botón Select Folder (Seleccionar carpeta) para iniciar el proceso de compilación:Then click the Select Folder button to start the build process:

Ventana Build Settings (Configuración de compilación) de Unity con la ventana de solicitud Select Folder (Seleccionar carpeta)

Espere a que Unity finalice el proceso de compilación.Wait for Unity to finish the build process.

Proceso de compilación de Unity en curso

3. Compilar e implementar la aplicación3. Build and deploy the application

Cuando se complete el proceso de compilación, Unity solicitará al Explorador de archivos de Windows que abra la ubicación en la que almacenó la compilación.When the build process is completed, Unity will prompt Windows File Explorer to open the location you stored the build. Navegue dentro de la carpeta y haga doble clic en el archivo .sln para abrirlo en Visual Studio:Navigate inside the folder, and double-click the .sln file to open it in Visual Studio:

Explorador de Windows con la solución de Visual Studio recién creada seleccionada

Nota

Si Visual Studio solicita que instale nuevos componentes, dedique un momento a comprobar que todos los componentes de los requisitos previos estén instalados, tal como se especifica en la documentación Instalación de herramientas.If Visual Studio asks you to install new components, take a moment to ensure that all prerequisite components are installed as specified in the Install the Tools documentation.

Configure Visual Studio para PC. Para ello, selecciona la configuración Publicación, la arquitectura x64 y la opción Equipo local como destino:Configure Visual Studio for PC by selecting the Release configuration, the x64 architecture, and Local Machine as target:

Visual Studio configurado para el equipo local

Haga clic en el botón que indica Equipo local.Click the button that says Local Machine. Comienza la compilación e implementación de la aplicación en el PC.It starts to build and deploy the application on to your PC. La aplicación se instalará de forma predeterminada en su PC.The application will be installed in your PC by default.

Prueba de la aplicación remota de comunicación remota holográficaTesting Holographic Remoting remote application

Para conectar la aplicación de PC a HoloLens 2, siga el proceso siguiente:To connect your PC application to your HoloLens 2, follow the below process:

1. Instalación de la aplicación Remoting Player en el dispositivo HoloLens 21. Install the Remoting Player application on HoloLens 2 device

_ En HoloLens 2, visite la aplicación Store y busque "Remoting Player"._ On your HoloLens 2, visit the Store app and search for "Remoting Player."

  • Seleccione la aplicación Remoting Player.Select the Remoting Player app.
  • Pulse Instalar una vez para descargar e instalar la aplicación.Tap Install to download and install the app.

2. Conexión de la aplicación de comunicación remota holográfica para PC a Remoting Player2. Connect the Holographic remoting PC app to the Remoting Player

  • Inicie Remoting Player en HoloLens.Start the Remoting Player on your HoloLens.
  • Tome nota de la dirección IP de HoloLens.Take note of the HoloLens IP address. Remoting Player la mostrará como un holograma en cuanto se inicie.It will be displayed as a hologram by the Remoting Player as soon as it launches.
  • Abra la aplicación de comunicación remota holográfica para PC en su PC.Open the Holographic Remoting PC application on your PC.
  • Una vez iniciada la aplicación, escriba la dirección IP y haga clic en el botón Conectar para conectarse.Once the application is launched, enter the IP address and click on the Connect button to connect.

EnhorabuenaCongratulations

En este tutorial, aprendió cómo crear una aplicación para la comunicación remota holográfica y a conectarse a HoloLens 2 en cualquier momento, lo que proporciona una manera de visualizar contenido 3D en realidad mixta.In this tutorial, you learned how to create a Holographic Remoting remote app and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality. Una vez que HoloLens esté conectado a la aplicación de comunicación remota holográfica para PC, debería ver la experiencia de realidad mixta transmitida en el dispositivo HoloLens 2.Once the HoloLens connected to the Holographic Remoting PC application, you should see the mixed reality experience streaming into your HoloLens 2 device.