Creación de animaciones

[Microsoft Agent está en desuso a partir de Windows 7 y puede no estar disponible en versiones posteriores de Windows.]

Para empezar a crear animaciones para el personaje, seleccione el icono Animaciones del árbol. Esto muestra la página Propiedades con la configuración predeterminada para todas las animaciones. Puede modificar el tamaño del marco, la duración predeterminada del fotograma y la configuración de la paleta de colores en la página Propiedades .

Establecer el tamaño del fotograma del carácter

El alto y el ancho del fotograma de animación deben permanecer constantes a lo largo de toda la definición de caracteres (es decir, para todas las animaciones de ese carácter). Aunque puede cambiar el tamaño del marco de su configuración predeterminada (128 x 128 píxeles), las imágenes mostradas en el Editor se escalarán para ajustarse al tamaño de pantalla predeterminado. Si cambia la configuración predeterminada del marco, puede mostrar el tamaño completo y no escalado del marco si elige Abrir ventana marco en el menú Editar .

Establecer la paleta de caracteres

De forma predeterminada, el Editor usa la primera imagen de mapa de bits que se carga para establecer la paleta de colores predeterminada del carácter, los colores que determinan cómo aparece el carácter y establece el color en la posición de la paleta 11 como color de transparencia. Sin embargo, puede establecer la paleta y la transparencia explícitamente en el grupo Información de paleta . Esto le permite especificar un archivo de imagen que se va a usar para la paleta. Puede especificar uno de los archivos de imagen de animación o cualquier archivo gráfico. El archivo de paleta que especifique debe ser un archivo de color de 8 bits (256). Una vez cargado, use el botón Cambiar configuración para cambiar el color de transparencia.

La paleta de colores del carácter no debe reasignar los colores del sistema estándar. El Editor reservará automáticamente la paleta de colores del sistema al mostrar imágenes. Además, todas las imágenes de animación deben usar la misma paleta de colores y color de transparencia. Esto es muy importante. Si no lo hacen, es posible que vea la reasignación de colores de las imágenes al cargarlas en el Editor.

Aunque puede establecer la paleta de colores para el carácter, en Windows sistemas en los que las propiedades Display se establecen en una paleta de colores de 8 bits (256), el color del carácter estará sujeto a la paleta del sistema actual. Dado que las aplicaciones pueden cambiar la paleta del sistema, es posible que el carácter no aparezca con la configuración de color correcta. Aunque no hay ninguna manera de evitar esto, puede reducir el efecto limitando el número de colores que usa y estableciendo la paleta del carácter en función de la paleta usada por la aplicación que impulsa el carácter. Por ejemplo, si va a desarrollar un carácter que se va a usar con páginas web, puede establecer la paleta del carácter mediante la paleta de tonos medio de Microsoft Internet Explorer. Para capturar la paleta del explorador, haga clic con el botón derecho en una imagen de una página web y elija el comando Guardar imagen como y elija Mapa de bits en la opción Guardar como tipo y, a continuación, haga clic en Guardar. Para optimizar los archivos de imagen de animación en un archivo de paleta específico, es posible que desee usar un producto como DeBabelizer de equilibrio.

Crear una nueva animación

Después de determinar la configuración de animación global, puedes empezar a crear animaciones. Para crear una nueva animación, elija Nueva animación en el menú Editar o en el botón Nueva animación de la barra de herramientas. Esto agrega un nuevo icono de animación en el árbol bajo el icono Animaciones y asigna al nuevo icono un nombre predeterminado. Para cambiar el nombre de la animación, escriba en el campo Nombre de animación. Tenga en cuenta que los nombres de animación dentro de una definición de caracteres deben ser únicos. Además, evite usar caracteres en el nombre que no sean caracteres válidos para los nombres de archivo.

Adición de marcos

Cada animación se compone de fotogramas. Para crear un nuevo fotograma para la animación, elija Nuevo fotograma en el menú Editar o en la barra de herramientas. Esto agrega un nuevo icono de marco al árbol debajo del icono de animación y muestra tres páginas con pestañas. La página General incluye controles que le permiten cargar y ajustar una imagen para el marco. También incluye un área de visualización para la apariencia del marco.

Screenshot that shows the Image pane with the filename, path, and position.

Un marco puede contener una o varias imágenes. Para definir una imagen para un marco, haga clic en el botón Agregar archivo de imagen justo encima del cuadro de lista Imágenes . Se muestra el cuadro de diálogo Seleccionar archivos de imagen , lo que le permite seleccionar un archivo de imagen de mapa de bits.

Screenshot that shows an image file being selected in File Explorer.

Seleccione el archivo que desea cargar, elija Abrir y la imagen aparece en la pantalla del marco en la página General . El Editor acepta imágenes almacenadas como formato GIF de 1 bits (monocromática), de 4 o de 8 bits Windows formato de mapa de bits.

Puede usar los cuatro botones de flecha debajo de la imagen en el cuadro Posición para ajustar la apariencia de la imagen dentro del marco. Si la imagen es mayor que el tamaño del marco, solo se mostrará la parte de la imagen que aparece dentro del marco. Si aumenta el tamaño del marco, es posible que la imagen se ajuste para ajustarse al área de presentación del Editor.

También puede mostrar un marco si elige Abrir ventana marco en el menú Editar . Esto muestra el marco actual en una ventana independiente sin escalar las imágenes cargadas en el marco. El tamaño inicial de esta ventana se basa en la configuración de alto y ancho del marco. Puede cambiar el tamaño más pequeño, pero no más grande. La ventana Marco refleja los cambios realizados con los controles del Editor y también permite ver el marco mientras ve sus otras páginas de propiedades.

Screenshot that shows the Position pane.

Puede crear un marco a partir de varias imágenes. Cada vez que seleccione el botón Agregar imagen y elija otra imagen, la imagen se agrega a la lista y al área de presentación de la imagen. También puede agregar varias imágenes seleccionando más de un archivo. Presione MAYÚS o CTRL mientras hace clic en el cuadro de diálogo Seleccionar archivos de imagen y, a continuación, elija Abrir. Los botones Subir y Bajar encima del cuadro de lista Imágenes mueven una imagen seleccionada en el orden de visualización (orden z) del marco. También puede mover imágenes arrastrándolas dentro de la lista. Al seleccionar una imagen en la lista y hacer clic en el botón Eliminar , se quita una imagen. Para cambiar una imagen que ha cargado en otro archivo de imagen, puede hacer clic en el nombre de archivo para editarla directamente o usar el botón ... (puntos suspensivos) para abrir el cuadro de diálogo Seleccionar archivos de imagen y seleccionar otro archivo.

Screenshot that shows the ellipses button.

Puede usar el cuadro de texto Duración para establecer la duración del marco; es decir, cuánto tiempo se mostrará el marco. Si un fotograma no tiene ninguna imagen y una duración cero, el fotograma no se mostrará cuando se reproduce la animación.

También puede especificar un archivo de efectos de sonido que se reproducirá cuando se muestre el fotograma. Si tiene previsto cargar el carácter desde un servidor web, es posible que desee comprimir el archivo de efectos de sonido para minimizar el tiempo de carga. A continuación, puede especificar el archivo de sonido comprimido en el Editor de caracteres del Agente. Además, evite usar un efecto de sonido con una duración mayor que la duración de la animación y, especialmente, evite un efecto de sonido que se repite, ya que los servicios de animación de Microsoft Agent no envían un evento completo de animación hasta que se completa el sonido. Evite también especificar un efecto de sonido para cualquier animación que asigne a los estados de escucha o audición , ya que esto interfiere con la entrada de voz. Por último, aunque puedes incluir más de un efecto de sonido en una animación, evita colocarlos para que se superpongan, ya que esto puede afectar al tiempo de la animación. Además, tenga en cuenta que los efectos de sonido pueden reproducirse a diferentes velocidades en función del hardware del usuario.

Para agregar fotogramas a la animación, elija de nuevo el comando New Frame y siga el mismo procedimiento. Como opción, también puede cargar varias imágenes y generar automáticamente nuevos marcos para ellas. Para usar esta característica, elija Nuevos marcos de imágenes en el menú Editar . Los marcos se crearán en orden alfabético en función de los nombres de archivo de la imagen. Cuando haya terminado de definir todos los fotogramas de la animación, puede elegir de nuevo el comando Nueva animación para comenzar una nueva animación.

Hay otras maneras de agregar fotogramas a animaciones y mover fotogramas dentro o entre animaciones. Puedes seleccionar otro fotograma (de la misma o de otra animación) y elegir Cortar o Copiar, a continuación, seleccionar la animación o un marco en esa animación y elegir Pegar. También puedes arrastrar un fotograma de una animación a otra. Si arrastras dentro de una animación, la acción mueve el fotograma. Si arrastras a otra animación, copia el marco. Al arrastrar a un fotograma anterior en la misma animación, se inserta el fotograma antes del marco al que se arrastra. Al arrastrar a un marco siguiente, se coloca después del marco al que se arrastra. Si arrastra un marco con el botón derecho del mouse, al soltar el botón se muestra un menú emergente con las opciones de transferencia.

También puede crear una animación copiando una animación existente (seleccione la animación y elija Copiar) y seleccione el icono Animaciones u otro icono de animación y elija Pegar. El Editor crea automáticamente un nuevo nombre para la animación, aunque puede cambiar el nombre.

Bifurcación

Al crear un marco, también puede definir qué fotograma se reproduce a continuación. De forma predeterminada, el siguiente fotograma reproducido en la secuencia de animación es siempre el siguiente fotograma en el orden z. Sin embargo, al elegir la página Bifurcación , puede establecer la probabilidad de hasta tres otros fotogramas que el servidor pueda reproducir. Escriba el porcentaje de probabilidad y el número de fotograma de destino en los campos adecuados. Puede especificar la bifurcación incluso para los fotogramas que no tienen imágenes y que tengan su duración establecida en cero. Esto le permite bifurcarse sin mostrar primero una imagen determinada.

Screenshot that shows the 'Branching' page.

Puede usar la característica de bifurcación para crear animaciones que se repetirán indefinidamente. Sin embargo, tenga en cuenta que cuando se reproduce una animación de bucle, otras animaciones de la cola del personaje no se reproducirán hasta que un evento, como un usuario que presiona la tecla de inserción para hablar o la aplicación cliente que llama al método Stop , detiene la animación en bucle. Por lo tanto, considere cuidadosamente el contexto en el que se usará la animación antes de crear una animación de bucle.

La página de bifurcación también le permite crear la bifurcación de salida. Una rama de salida es una rama de un fotograma que la animación tomará cuando se detenga la animación y antes de que se reproduzca la siguiente animación. La definición de ramas de salida le permitirá moverse sin problemas durante la transición de una animación a otra. La bifurcación de salida no debe crear un bucle circular, pero finalmente debe poder salir al último fotograma de la animación.

No es necesario proporcionar una rama de salida para cada fotograma, pero si no lo hace, la animación seguirá la bifurcación normal del fotograma. Si el fotograma no tiene ninguna rama explícita, la animación se bifurca automáticamente al fotograma que lo sigue. Por ejemplo, si bifurca del marco 3 al fotograma 1 y el fotograma 1 no tiene ninguna otra bifurcación (normal o rama de salida), el marco 1 se bifurcará al marco 2. Si el fotograma 2 no tiene bifurcación, la animación se bifurcará al fotograma 3 y tendrá un bucle circular. En su lugar, podrías bifurcar del fotograma 3 al fotograma 1 y luego establecer la rama de salida del fotograma 1 en cualquier fotograma que sea posterior al fotograma 3 y normalmente continúe con el último fotograma de la animación.

A veces, es posible que necesites crear un marco final explícito de una animación que no se reproduce visiblemente, pero proporciona un final de la animación. Por ejemplo, debes salir de la animación, pero salir del último fotograma no sería adecuado. Para ello, cree un marco de duración cero en blanco como último fotograma de la animación. Esto permite que la animación se reproduzca normalmente a través del último fotograma de la animación y también te permite proporcionar un punto de salida final para la bifurcación de salida.

Vista previa de una animación

Puede obtener una vista previa de la animación en el Editor de caracteres del Agente si elige el comando Vista previa en el menú Editar o el botón Vista previa de la barra de herramientas. Esto reproduce la animación, incluidas las ramas y los efectos de sonido, empezando por el fotograma seleccionado actual. Se restablece al fotograma seleccionado actual cuando se completa la animación. Para reproducir toda la animación, vaya a la vista de árbol, seleccione el icono de la animación o el primer fotograma de la animación y elija el comando Vista previa . El Editor anima los fotogramas en la página General . Para detener la vista previa antes de que finalice, elija el comando Detener vista previa . El comando Vista previa cambia automáticamente a Detener vista previa mientras se reproduce la vista previa.

También puede obtener una vista previa de la bifurcación de salida si elige el comando Vista previa de la bifurcación en el menú Editar o en la barra de herramientas. permite probar cómo aparecerá la bifurcación de salida desde cualquier marco específico.

Asignación de superposiciones de habla

Puedes definir un carácter para que hable durante el último fotograma de su animación. En este marco, elija la página Superposición . Esta página le permite cargar y asignar archivos de imagen de boca a las posiciones de boca estándar compatibles con Microsoft Agent. Haga clic en el botón Agregar imagen y seleccione la imagen en el cuadro de diálogo. También puede seleccionar varias imágenes y el Editor cargará y asignará las imágenes a partir de la posición de boca seleccionada. Haga clic en los botones Subir y Bajar o arrastre una entrada para cambiar una asignación de imagen en la lista. Haga clic en el botón Eliminar para quitar una imagen. También puede editar el nombre de ruta de acceso de un archivo asignado si hace clic en su entrada en la lista y vuelve a establecer su nombre de archivo, o bien seleccionando el botón de puntos suspensivos para mostrar el cuadro de diálogo Seleccionar archivos de imagen .

Screenshot that shows the 'Overlays' page with a file selected.

Las superposiciones de boca deben caber dentro del contorno del marco base sobre el que aparecerán. Si no lo hacen, se recortarán en el marco base.

Si quieres que el carácter hable con su boca fuera del marco base(por ejemplo, cuando el carácter hable lateralmente) cree primero el marco base con la cabeza del carácter (o el área que se moverá mientras el carácter habla) como su imagen superior. A continuación, defina las superposiciones de boca para reemplazar esa imagen y establezca la opción Reemplazar imagen superior de marco base . También puede usar el botón Establecer todo para establecer esta opción para todas las superposiciones de boca en el marco.

Asignación de una animación de devolución

Para crear una transición suave de una animación a la siguiente, diseñe las secuencias de animación para comenzar y terminar con una imagen neutra. Para obtener más información, vea Diseño de caracteres para Microsoft Agent. Sin embargo, esto no significa que todas las animaciones terminen en la posición neutra. Puedes animar un carácter a través de una secuencia de fotogramas, hacer que hable durante el último fotograma y crear una animación complementaria independiente que devuelva el carácter a la posición neutra. Esta animación complementaria se denomina animación Return.

Puedes definir una animación De retorno creando una animación explícita para este propósito. También puedes crear una animación De retorno mediante la bifurcación de salida que definas dentro de la animación. Para asignar una animación Return, seleccione la animación en el árbol y seleccione la animación Return que creó o Use Exit Branching (Usar bifurcación de salida) en la lista desplegable Return Animation (Animación de retorno) de la página Propiedades.

La creación y asignación de una animación Return tiene una ventaja adicional: cuando el servidor obtiene una solicitud para reproducir otra animación, intentará reproducir la animación Return para la última animación que ha reproducido, si se asigna una animación Return. Esto garantiza una transición fluida. Si una animación comienza y termina en la posición neutra, no es necesario definir una animación De retorno. De forma similar, si piensa controlar las transiciones de una animación a otra usted mismo, es posible que no tenga que asignar una animación De retorno.

Asignar animaciones a estados

Los servicios de animación de Microsoft Agent reproducen automáticamente animaciones cuando la aplicación cliente de hospedaje usa determinados métodos. Por ejemplo, cuando una aplicación llama a los métodos MoveTo y GestureAt , el servidor determina automáticamente dónde se muestra el carácter y reproduce una animación adecuada. De forma similar, Microsoft Agent reproduce automáticamente animaciones inactivas cuando el usuario no ha interactuado con el carácter durante varios segundos. Estas condiciones, cuando el servidor reproduce automáticamente animaciones en nombre de una aplicación, se denominan estados. Sin embargo, para que el servidor sepa qué animación se va a reproducir, debe asignar animaciones a estos estados.

Para asignar una animación o animaciones a un estado, cree la animación adecuada, expanda la entrada Estados en la vista de árbol de la ventana Editor y seleccione el icono Estado. La lista de animaciones que ha creado aparece en un cuadro de lista en el lado derecho de la ventana. Comprueba la animación que quieres asignar a este estado. Ten en cuenta que puedes asignar más de una animación al mismo estado. Esto permite que el servidor seleccione aleatoriamente diferentes animaciones para el estado. La asignación de una animación a un estado no impide que una animación se reproduce directamente.

También puedes asignar una animación a un estado seleccionando la entrada de la animación en el árbol. El cuadro de lista Asignar al estado de la página Propiedades muestra los estados. Active la casilla de verificación del estado al que va a asignar la animación.

El Editor no admite la creación de estados adicionales porque los estados solo se aplican a situaciones en las que el servidor debe reproducir automáticamente una animación en nombre de la aplicación cliente. Por lo tanto, no hay ninguna ventaja en definir su propio estado. Si es necesario, puedes reproducir cualquier animación explícitamente mediante el método Play .

Guardar la definición de caracteres

Puede guardar el archivo de definición del carácter si elige el comando Guardar en el menú Archivo o el botón Guardar definición de caracteres de la barra de herramientas. Si desea guardar el archivo de definición de caracteres con un nuevo nombre, elija el comando Guardar como en el menú Archivo . El Editor guarda la definición editable de un carácter como definición de caracteres del Agente (. ACD) archivo. También puede editar este formato de archivo de texto autodocumentado con la mayoría de los editores de texto y las aplicaciones de procesamiento de texto.

Imprimir la definición de caracteres

Para imprimir la definición del carácter, elija el comando Imprimir en el menú Archivo o el botón Imprimir de la barra de herramientas. Para establecer las propiedades de la salida impresa, elija el comando Configurar página y elija la configuración antes de seleccionar el comando Imprimir .

Crear un carácter

Cuando haya terminado de crear las animaciones, el carácter y las imágenes deben compilarse en un formato especial que microsoft Agent usa para cargar estos datos. Para crear un carácter, seleccione el comando Build Character (Generar carácter) en el menú Archivo o en la barra de herramientas. Si tiene modificaciones no guardadas en el archivo de definición de caracteres, el Editor guarda el archivo de definición antes de mostrar el cuadro de diálogo Carácter de compilación .

Screenshot that shows the 'Build Character' window with a file selected.

El Editor de caracteres del Agente propone automáticamente un nombre de archivo en función de su nombre de archivo de definición de caracteres. El cuadro de diálogo Carácter de compilación también incluye una lista desplegable para que pueda elegir entre compilar el carácter como un único archivo de almacenamiento (. ACS) o como varios archivos. Si elige esta última, el Editor crea un . Archivo ACF que incluye los datos de los caracteres y un . Archivo ACA para cada animación que haya creado. Si tiene previsto instalar y tener acceso a un carácter almacenado en el mismo equipo que la aplicación cliente, normalmente elegiría el formato de archivo estructurado único. Este formato proporciona una instalación fácil y eficaz y acceso al carácter. Sin embargo, si se tendrá acceso al carácter desde un servidor web mediante el protocolo HTTP, compile el carácter mediante . Formato de archivo ACF (individual). Esta última estructura de archivos permite que un script de página web cargue archivos de animación individuales y almacene los datos en la memoria caché de archivos del explorador del usuario. Proporciona un acceso más eficaz a través de la Web porque los datos de animación se pueden descargar según sea necesario, en lugar de exigir al usuario que espere a que todo el conjunto de animaciones se descargue a la vez. Además, dado que los datos del carácter se almacenan en la memoria caché del explorador, el espacio del archivo se puede recuperar automáticamente.

Aunque también puede descargar datos de caracteres (ya sea como un único archivo estructurado o varios archivos) desde un servidor web e instalar en otro lugar en el equipo de un usuario, este método requiere disposiciones de seguridad para descargar e instalar. Como resultado, la API de Microsoft Agent no incluye compatibilidad con la instalación descargable de un carácter, excepto en la memoria caché del explorador. Sin embargo, todavía puede admitir este escenario mediante la creación de su propio control de instalación y distribuirlo siguiendo las convenciones de seguridad adecuadas. Para obtener más información, consulte el Kit de desarrollo de software de cliente de Internet de Microsoft.

La opción Comprimir permite establecer si los datos de caracteres están comprimidos. Normalmente, querrá establecer esta opción para compactar los datos de caracteres, aunque la creación de un carácter con los datos compactos tarda más tiempo.

Una vez compilado un carácter, las compilaciones posteriores serán más rápidas si compila el carácter en la misma ubicación de directorio. El Editor de caracteres comprueba y copia automáticamente los archivos que no han cambiado y vuelve a compilar los datos que se han editado.

Si el Editor detecta errores en el archivo de caracteres al compilar el carácter, escribe la información en un archivo de registro y muestra un cuadro de mensaje. Puede elegir ver el archivo de registro o ignorarlo y leerlo más adelante con un editor de texto. Sin embargo, tenga en cuenta que el Editor sobrescribirá el archivo de registro la próxima vez que cree un archivo de caracteres.

Edición de un carácter existente

Para editar un carácter existente, elija Abrir en el menú Archivo , seleccione el archivo de definición del carácter (. ACD) en el cuadro de diálogo resultante y elija Abrir. El archivo se cargará en el Editor. Tenga en cuenta que no se pueden cargar archivos de caracteres compilados (. ACS. ACF o . ACA) con el Editor.

Dado que el archivo de definición del carácter (. ACD) es un archivo de texto, también puede editar la definición de un carácter abriendo el archivo con un editor de texto o un programa de procesamiento de texto. Sin embargo, al completar los cambios, asegúrese de guardar el archivo en su formato original antes de cargarlo en el editor de caracteres para su compilación.